SOLVED: Keyboard doesn't work in Premiere Pro

New Here ,
Jun 10, 2020 Jun 10, 2020

Copy link to clipboard

Copied

Hi all!

 

My main computer is under maintenance so I'm using my old notebok and I encountered this issue when editing in Premiere Pro. The keyboard doesn't respond to the program at all (any shortcuts like ctrl-z, C, G, etc...), although, when in combination with the mouse, it does (ALT and CTRL work when I zoom in/out).

When I installed Premiere I had a warning message telling me to update my NVIDIA card driver, I am using a GEFORCE 840M on a WINDOWS 10 64 BIT. I did update it and tried to reset the window layout, it doesn't seem to work.

My keyboard works fine with any other program, I've tried both my laptop keyboard and a USB one and the problem is just the same for both.

 

Any kind user could help me out solving this problem? It's kind of frustrating to work just with the mouse eheh 🙂

 

Best,

Leo

TOPICS
Error or problem , Performance , User interface or workspaces

Views

3.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 10, 2020 Jun 10, 2020

Hi Leo,

Thanks for posting your solution. I'll redo it here so people can see it's been solved.

 

Leo said:

EDIT: I solved the problem by:

 

  1. Copying this file: C:\Program Files\Adobe\Adobe Premiere Pro CC 2019\Keyboard Shortcuts\en\Adobe Premiere Pro Defaults.kys
  2. Pasting the file to: C:\Users\user_name\Documents\Adobe\Premiere Pro\13.0\Profile-[YOU PROFILE]\Win\Adobe Premiere Pro Defaults.kys
  3. Reset Premiere by selecting Adobe Premiere Pro Defaults in the Keyboard Shortcuts Settings.

 

Thanks,

...

Likes

Translate

Translate
Adobe Employee ,
Jun 10, 2020 Jun 10, 2020

Copy link to clipboard

Copied

Hi Leo,

Thanks for posting your solution. I'll redo it here so people can see it's been solved.

 

Leo said:

EDIT: I solved the problem by:

 

  1. Copying this file: C:\Program Files\Adobe\Adobe Premiere Pro CC 2019\Keyboard Shortcuts\en\Adobe Premiere Pro Defaults.kys
  2. Pasting the file to: C:\Users\user_name\Documents\Adobe\Premiere Pro\13.0\Profile-[YOU PROFILE]\Win\Adobe Premiere Pro Defaults.kys
  3. Reset Premiere by selecting Adobe Premiere Pro Defaults in the Keyboard Shortcuts Settings.

 

Thanks, Leo.

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2022 Apr 03, 2022

Copy link to clipboard

Copied

I was nearing a heartattack but this finally worked after many different attempts. Thanks Leo! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

LATEST

Thank you thank you thank you sooo much! Worked by me ( ͡~ ͜ʖ ͡°)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

thanks leo, you are a life saver!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

Hi there !

 

I have the same problem but I use a Azerty Belgium keyboard.
What can I do for solving this.

Best regards,

Kenny

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Thanks a million. This sulotion worked. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Thanks for reporting back, Peter. This community gives back, even 1.5 years later.

 

Regards and Happy New Year, Peter.

 

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

FOR MAC USERS having the same problem...

 

  1. Copy the .kys file by going to Applications/Adobe Premiere Pro 2022 (Or whatever version you are using) ... then select "Adobe Premiere Pro 2022.app" - The Premier Pro application. Right click on the application, Show Package contents, follow this path... Contents/Keyboard Shortcuts/en/Adobe Premiere Pro Defaults.kys - copy this file "Adobe Premiere Pro Defaults.kys"

  2. Pasting the .kys file in Macintosh HD/Users/macbook/Documents/Adobe/Premiere Pro/22.0/Profile-[YOUR PROFILE]/Mac - Paste "Adobe Premiere Pro Defaults.kys"(the 22.0 folder may change depending on the version you are using)

  3. Open Premiere, click Premier Pro drop down menu (top left of the screen) Keyboard Shortcuts (Keyboard shortcuts may be elsewhere depending on your version, get to the keyboard shortcuts menu). Under Keyboard Layout preset there should be two options named "Adobe Premiere Pro Defaults" select the one that isnt currently selected or try both. Click OK.

    If anything doesnt work try rebooting. Mine updated the keyboard the moment I select the new "Adobe Premiere Pro Defaults" option from the Keyboard Shortcut menu.

    Good luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Hi Travis,

Sorry for this problem. Adobe does not condone going into the package and opening it to access the contents. Do so at your own risk. Please file a bug here: https://adobe-video.uservoice.com/forums/911233-premiere-pro/suggestions

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

For me it worked differently – you need to paste the .kys file(s) to in Macintosh HD/Users/macbook/Documents/Adobe/Premiere Pro/22.0/Profile-CreativeCloud/Mac

Meaning – NOT IN PROFILE [YOUR PROFILE], BUT IN THE PROFILE-CREATIVECLOUD!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines