• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

SVG: Use <image> element with href - doesn't work

New Here ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

Hi I just got Adobe Premiere Pro 5 minutes ago and I am experiencing issues right away:

I have an SVG which inside itself has an <image> element which has an href to another svg which is located in the same folder as the parent SVG.


I get this error:
could not find a plugin to read the linked file "pin.svg" Choose replace to select or ignore to leave the link unchanged

 

Maybe Adobe cannot display this <image> element at all? It is common in SVGs so that would be very weird.


replacing and selecting the file itself doesn't work.
This error message is pretty poor too, I am not sure if sth is wrong with my svg or if the <image> element is just unsupported.

It works with Inkscape, but there I have other things that bother me, e.g. the id not being the name of the elements.

TOPICS
How to

Views

243

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

LATEST

Try opening the SVG in Photoshop or Illustrator.  

Assuming that it appears as expected, export that as a PNG.

 

Import the PNG into Premiere Pro.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines