Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Terrible playback performance in Premiere Pro 2021

Explorer ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Updated to Premiere Pro 2021 in hopes that it would improve Premiere's performance, but instead, it has gotten much much worse. Premiere now freezes and stutters constantly just trying to watch back a piece of 1080p 60fps footage at 1/4 playback resolution. Would appreciate any advice you may have.

System specs -----

RTX 2070

Ryzen 5 3600x

32 GB 3200MHz Ram

Internal SSD for both footage and Premiere itself

TOPICS
Freeze or hang, Performance

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Advocate , Mar 18, 2021 Mar 18, 2021
few more steps to try then:1) Manually clear media cache - close Adobe PP/AE/ME, go to cache location and clean/delete folders: Media Cache, Media Cache Files, PTX, Peak Files2) Toggle off hardware accelerated Decoding in Preferences > Media... Remember to clear media cache and restart the app each time you change this settings, or after any app/driver update as well3) Reset workspace: Window > Workspaces > Reset to saved layout (or just switch to different one) 4) Try on/off "Mercury Transmit" ...

Likes

Translate

Translate
Advocate ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

try Preferences > Audio Hardware > Default Input => select "No Input"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

doesn't seem to have made a difference. Did let me know that my mic input was broken though, so that's nice.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

few more steps to try then:

1) Manually clear media cache - close Adobe PP/AE/ME, go to cache location and clean/delete folders: Media Cache, Media Cache Files, PTX, Peak Files

2) Toggle off hardware accelerated Decoding in Preferences > Media... Remember to clear media cache and restart the app each time you change this settings, or after any app/driver update as well

3) Reset workspace: Window > Workspaces > Reset to saved layout (or just switch to different one)
4) Try on/off "Mercury Transmit" option (Preferences > Playback > Enable Mercury Transmit)
5) Make sure that NVidia G-Sync/ AMD Freesync is off in driver control panel
6) Make sure you are using NVidia 'Studio' driver and not 'Game ready' one

7) Reset app preferences: close all Adobe apps, go to My Documents > Adobe  and rename folders Premiere Pro / Adobe Media Encoder. Now start the app while holding Shift+Alt, open your test project and see if there is any improvements.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Did most of this stuff, and not only did it solve my problem, but performance is also an insane amount better than it has ever been. Thank you, friend.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Thanks again, Basil1891!

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi Demstein,

 


what is the soucre of these clips? 

please share few sample clips.

 

if you are working with HEVC/H264 then try to playback the clips with software decoding.(Uncheck "H264/HEVC hardware accelerated decoding" under Preferences > Media)

 

Regards

Abhishek 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Abhishek,
I suspect that others are experiencing similar issues with hardware decoding on the GPU. Thanks for your assistance.

 

Sincerely,

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Just to throw another report in, experiencing this myself since the update to 2022. As other have mentioned performance is better if I tick "High Quality Playback" and keep the resolution at Full, but it's still very poor in comparison to 2021. I'm primarily editing 10-bit H.264 UHD footage from Panasonic Lumix S1/S5 cameras.

 

SPECS..

Windows 10 Pro

RTX 3080

Ryzen 7 5900x

64GB 3600MHz RAM

 

All drivers are up to date and I've tried clearing Media Cache, turning Hardware Acceleration off/on, and a fresh reinstall of Premiere, and nothing. Will try installing the latest Beta later and see if it's any better.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

LATEST

Whoops - meant to reply in the 2022 thread! Admin please delete.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines