• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Transform / captions/text keyframe issue

Community Beginner ,
Mar 09, 2023 Mar 09, 2023

Copy link to clipboard

Copied

So basically, I was editing a shorts clip and I use the captions function a lot to make subtitles but it doesn't work exactly how you would imagine it but none the less, I select all the captions and "upgrade caption to graphic" and then I paste my preset of transform (for the pop-in effect) and drop shadow (so it looks nicer). Everything is nice and well until I exit premiere and come back to finish my work later. It RANDOMLY moves the keyframes on the transform effect on RANDOM subtitles.

It used to be at the start of the graphic but it randomly moves out of place (https://imgur.com/a/Jg1E7av)

Here is a bit of a mess of a video showing the problem ( https://streamable.com/uh2a26 )

(dont say anything about my wallpaper ty)

Notice how when first played the subtitles look normal, everything is popping in and working as intended, but after I reopen premiere the pop-in effect on some subtitles is no longer there.

If someone can help me find a workaround or a fix I would greatly appreciate it because it would be the difference between night and day for my workflow! This isn't mutch to go off of so let me know what more I can provide!

Views

332

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 10, 2023 Mar 10, 2023

Copy link to clipboard

Copied

Inguss,

 

Your information makes sense, and I do not know why it would work and then not when reopening.

 

This is exactly what the new upgrade caption to graphic should allow. I have not tried it, and I have wondered how a preset can be applied consistently when the graphic duration might vary.

 

I would test this by simplifying - use a few graphics created text items - not captions converted, create a simple effect with very few keyframes and copy (not a preset), and just the motion, no shadow. Do you see the problem? If so, it may be easier to troubleshoot.

 

If not, look at the original; is there is any pattern to what appears random?

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2023 Mar 10, 2023

Copy link to clipboard

Copied

I tried this, didn't seem anything wrong to be happening, I have to say though that I didn't do the text exactly how I would usually do it maybe that's why. Anyway, I also wanted to add that it doesn't happen exactly when I just convert the captions to graphic and add the preset, then it doesn't happen. It usually happens only when I am almost done with the project, changed the text color, made it so the words pop up only when said as you can see in the video, etc.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 11, 2023 Mar 11, 2023

Copy link to clipboard

Copied

Got it. I'd promise to test this, because it is an important new workflow. But a) I'm just back from a lovely cruise and have my projects to do and many tests backed up and b) for the first time managed to get a mild case of covid. It does slow me down!

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 29, 2023 Mar 29, 2023

Copy link to clipboard

Copied

Any updates on this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2023 Mar 29, 2023

Copy link to clipboard

Copied

Inguss, thanks for asking. I forgot that your post was what got me started experimenting with this.

 

But I was sidetracked by other issues. I still have no idea why some keyframes would move.

 

You seem to be getting correct results on what was distracting me, but below are links to 2 posts reporting some of my experiments. I now think the workflow being used by some is to upgrade captions to text, probably keeping it all centered, then using transform to apply animation, and nesting to move the captions from the center - or just leaving them centered. I found one good tutorial, but don't have the link at the moment.

 

https://community.adobe.com/t5/premiere-pro-discussions/align-textbox-to-the-borders-of-the-frame/m-...

 

https://community.adobe.com/t5/premiere-pro-discussions/text-moving-when-scaling-up/m-p/13673061#M45...

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2023 Mar 30, 2023

Copy link to clipboard

Copied

I don't think this would work for me. I constantly have to make changes to the text, I am not done when I paste the preset on all the subtitles, I still have to make changes to the color, maybe make some different animations etc. It is a bug inside premiere pro that just needs to get fixed, am I wrong? We shouldn't have to workaround this type of stuff, it should just work properly. For now, I am just not closing the project, ever, and keeping it open in the background on my computer so the keyframes bug out and it has been working fine. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 13, 2024 May 13, 2024

Copy link to clipboard

Copied

LATEST

Hello @Inguss28602811p2b4,

Thanks for the message. I apologize for the team's lack of response. Are you still having this issue? If so, let the team know.

 

I'll move your post to the Discussions board while we await your information. Sorry for the hassle.

 

Thanks,


Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines