Type tool / Essential Graphics Text not working.

Community Beginner ,
Apr 25, 2017 Apr 25, 2017

Copy link to clipboard

Copied

Hi there! I'm trying to get this new Type Tool in Essential graphics to work, but I'm not getting it to work. (Premiere Pro 2017.1) Which really bums me out because this is exactly the type of change I have wanted for handling text in Premiere. Is there some setting I'm unaware of?

Here's exactly what I do:

1. I switch to Graphics layout.

2. I place the playhead over a clip, and select it for good measure. The clip shows up in the program monitor.

3. I select the "T" icon (TypeTool).

4. I click in the program monitor. A new clip named "Graphics" shows up on the timeline.

5. I try to write, but that just activates keyboard shortcuts. I.e. if I where to try to start writing "variety" I would get the Selection Tool, since that's mapped to V.

I've tried this many times, with no luck. Creating an ellipse or a rectangle work fine though. I can choose "New Item" in the Graphics clip an ellipse or rectangle shows up fine, but as before nothing happens when I press New Item->Text in the Graphics clip either. So regardless with what I've tried I'm still stuck with the old legacy titling window.

What am I doing wrong?

Thanks for your help!

/R

Views

35.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 30, 2017 Sep 30, 2017
This thread led to another thread that has the solution: restart premiere while holding shift + alt.

Likes

Translate

Translate
New Here ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

Hi, I was also frustrated.  I figured out what was going on for me.

If you're on the reference tab instead of the "program" tab it won't activate the text tool.

Here is a screenshot I grabbed to try to explain better.

Screen Shot 2018-05-07 at 2.37.01 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2018 Jul 30, 2018

Copy link to clipboard

Copied

it has to be a bug.. sometimes the type tool works, sometimes it doesn't.. very strange. Even after restart the problem isn't solved and it has to be project related. I found a work-around by dragging in some lower thirds from the essential graphics browser.. once this is activated the type works again.. this issues should be solved by Adobe.. it's indeed a waste of time !!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

Yep, stopped working for me also. Latest version of PP2018 on a mac, 10.13.6.

I can enter text in the text tool but it doesn't appear in the sequence. Doesn't matter what window layout I use.

Any progress with this?

Bob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2018 Nov 20, 2018

Copy link to clipboard

Copied

hello there,

I'm still having the same issue. I have the latest versions, have deleted the caches, and the program monitor is active.

Any clue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

It looks like this issue is back,  and restarting premiere while holding shift + alt isn't fixing it. I am running cc 14.4.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

Same here. How has this problem not been addressed in 3 years?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

just finding this problem for the first time myself (been using premiere since pre creative suite) in 2021 v15.2.0 (build 35)

 

will try thr restart holding Shift + Alt, very frustrating - thank goodness for the brains trust of the community

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

LATEST

so opening PrPro whilst hodling Alt+Shift resets prefeerences and clears some caching?

 

fixed the problem for me

 

how is this problem caused? is there a preference that enables overiding the selection of panes and only applys key commands as if in the context of the timeline?

 

many thanks to Brad Curran for linking the solution

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines