Ultra Key having Artifacts when used along with Blur on PP2022

Community Beginner ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Recently, we have updated our project files to the 2022 version and moved our work there but when we tried rendering our sequences we noticed that whenever we used Ultra Key on our footage along with another layer with Gaussian Blur below, the rendered footage would often contain artifacts where either the layer with Ultra Key or with the one with Blur would have glitches where they would become see through. Sometimes Ultra Key would also color the footage green on preview and render.

 

Our footage is in H.264 and we either render it to ProRes or H.264 again. Attached are some cropped snapshots of the renders we had. 

vlcsnap-2022-02-20-01h35m21s138.png

vlcsnap-2022-02-20-01h42m19s162.png

vlcsnap-2022-02-20-01h45m23s216.png

  

TOPICS
Error or problem , Export

Views

165

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Delete the Media Cache and Media Cache files:
https://community.adobe.com/t5/premiere-pro/faq-how-to-clear-your-media-cache-in-30-seconds-in-premi...

If that doesn't work, try resetting the preferences:
https://community.adobe.com/t5/premiere-pro/faq-how-to-reset-trash-preferences-in-premiere-pro/td-p/...

If that doesn't work, try resetting the Workspaces:
Reset a workspace
Reset the current workspace to return to its original, saved layout of panels.
1. Do one of the following:
• Click the Workspace menu icon and select Reset to Saved Layout.
• Choose Window > Workspace > Reset to Saved Layout.
from here:
https://helpx.adobe.com/premiere-pro/using/workspaces.html

If that doesn't work, try Preferences > Audio Hardware and set Input to None.

If that doesn’t work, try updating or rolling back your graphics driver directly from the video card manufacturer’s site. If NVIDIA, do a clean installation of the latest Studio Driver (NOT the Game Driver)

If that doesn't work, try creating a new project and import the old one into it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Already tried cleaning cache on previous renders we had but it mysteriously comes back when we don't expect it.

Cleaned up cache from Adobe Premiere and even in After Effects. We also tried fresh installs and the beta but no luck. Maybe will try resetting the workspace and setting Audio Hardware Input?

 

It makes me paranoid whenever I do the rendering, having to keep an eye out for any bad frames and then rerendering the whole video again. 😞

 

We use a Windows PC btw with RX570 and Ryzen 5 2600 CPU 16gb Ram.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Are you using adjustment layers?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

No, we used adjustment layers with Gaussian Blur on them at first but then we tried to prerender it along with the layers underneath then replacing the layers on the timeline with prerendered footage and it still had glitches. So it's not about the Gaussian Blur I guess. The only other thing I suspect at this point is the Lumetri Color effect with Ultra Key on this version. -_-

The 2021 version worked fine on us before but we did the unfortunate thing of switching at this time 😞

 

UPDATE: We tried setting the renderer to "Mercury Playback Engine Software Only" and at first glance, it probably fixed the issue? But it took sooo long to render though. So this problem maybe happens only with the GPU Renderer (OpenCL)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Hi Deo Franc232406468k5w,

 

We're sorry about the poor experience. It seems like a GPU driver issue. Have you tried updating the GPU drivers & checked if it's helping?

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2022 Feb 20, 2022

Copy link to clipboard

Copied

Yes we are on the latest Radeon Adrenalin Drivers. Ever since we noticed the issue, we kept updating the GPU driver, Premiere Pro and Windows 11 just hoping a fix would happen. 

 

It's only a hunch but I think it might be related to the footage being H.264 though because we didn't notice any glitching with ProRes footage. (But I guess we really don't know cause it happens suddenly and somewhat randomly.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2022 Feb 20, 2022

Copy link to clipboard

Copied

Have you tried doing the color work, then nesting the clips? Or doing other work then nesting before Lumetri?

 

Sometimes if there are mulitple effects on a clip, nesting between solves processing order issues.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

After rerendering a couple of videos and nesting and isolating a lot of Lumetri Color effects, we think it probably solves the issue? 🤔

 

Either way, we're still monitoring the situation though cause we still have a lot to render over the next few days. But still not having to nest would be better.. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

Keep us informed, please?

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Okay.. we haven't noticed any glitching today with the nesting method. Just noticed Lumetri Color not applying color to the footage but a quick nest isolating the effect and clearing media cache solved the problem.

 

I'll update once I see the glitching back again. Thanks 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Among other things, developers need to rebalance the Ultra Key effect, because it does not cope with the task very well. The background removes unevenly, even twisting the settings. And if it does, then together with the object. This is provided that the background is not outrageously dirty. I understand that you need a smooth back chromakey, but customers often provide a mixed-color background. In my opinion, this effect requires rebalancing. It hasn't been updated for a long time. I have already written about this

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

LATEST

So here's an update:

Nesting and isolating Lumetri Color most likely fixed the glitching issue as we have not seen anymore glitching frames but still the issue of having green-colored footage still exists.

On that note, the Beta version is handling the "greening" issue much better with less sections of the footage turning green.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines