• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Version 23.1 much slower after update (macOS Ventura and M1)

Community Beginner ,
Dec 13, 2022 Dec 13, 2022

Copy link to clipboard

Copied

Since I've upgraded to version 23.1, virtually everything is significantly slower.  This includes simple things like scrubbing through a clip on the timeline as well as more complex things like exporting.  Also, the Dip To White effect has changed and no longer works as it used to - was that intentional?  And will it be changing back or at least renamed as it no longer dips to white?

 

I am running a Mac with the Apple M1 Pro chip, have 32GB of memory and Ventura 13.0.1. Nothing changed on my computer that I am aware of besides the upgrade to 23.1 of Premier Pro.  

 

Please let me know if the performance of Premier Pro will be corrected so at least it's no slower than it was before version 23.1 - and if the Dip To White effect will be changed.

 

Thanks!

TOPICS
Effects and Titles , Performance

Views

649

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Sorry about that, HootieGPop,

Some users are having a lot of trouble with v.23.1. Can you try 23.0 instead? Let us know how it goes. The team is working on a fix right now.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Hey Kevin.

Thanks for the reply and the suggestion.  Reverting to a previous version isn't that simple for us.  We're using the team function and have already saved the project under 23.1.  If we downgrade to 23.0, we get messages saying we can't open the project.  Any suggestions for a work around when the project has already been saved under a newer version of PP?

 

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2022 Dec 19, 2022

Copy link to clipboard

Copied

Thanks for the reply, Kevin. I hope the update happens sooner than later. The slow responsive timeline is a real bummer. Making the editing process feel like a chore for a lot of us, by the sounds of it! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

Hey Kevin.  

You mentioned you're working on a fix.  Can I get a timeline for when that's expected to be available?  

 

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

I went back to 23.0 and it fixed the problem for me on my 2017 IMac Pro, 3.2 GHz 8-Core Intel Xeon W, Radeon Pro Vega 56 8 GB, 32 GB 2666 MHz DDR4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2022 Dec 19, 2022

Copy link to clipboard

Copied

I'm with you my friend. I have a practically brand new Mac Studio with 128 of RAM and the M1 Ultra chip. My Premiere Pro is acting like I'm running on 1GB of RAM. Hopefully it gets fixed because before it was so effortless and easy to go through my 4K footage!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 16, 2023 Jan 16, 2023

Copy link to clipboard

Copied

I also so had to go back to 23.0 I'm on a windows system and have the same issues. Extreme lags in the timeline when moving layers, keyframes, etc. Totally unusable. I'm runinng on win 11, i9, 64gb ram and RTX 3090.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2023 Jan 26, 2023

Copy link to clipboard

Copied

LATEST

I have had similar issues specifically with the lag on playback. 

Luckily this solution worked for me. link for the thread: https://community.adobe.com/t5/premiere-pro-discussions/huge-performance-and-lag-issues-with-premier...

WarriorKnot_0-1674742128481.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines