• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Weird keyframe behaviour(linear keyframes appear like bezier ones, only reopening premiere fixes it)

New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

I have the following bug in Premiere, I dont know where this is coming from, it is really weird:

When i add keyframes to audio clips in the timeline to change their level, the keyframe type is set to linear as default, and thats what i want, it always worked like that since i started using premiere 6 years ago.

But now, linear type keyframes do have a bezier type shape, and i dont want that. I dont know why it does that, and the weirdest part is the following: if i save the project, close premiere and then reopen the program, the keyframes added before are now correctly linear types as they should be. all keyframes added in new audio parts (not in the ones with keyframes in it, they behave normally) have the weird behavior again.

See the attached screenshot for clarification: the keyframes with a linear shape where added before reopening the program, when added they also had the worng shape. The keyframe in the right audio clip was just added, the linear type is selected, but the shape isnt linear.

It also has nothing to do with the type of audio clip (audio clip from video or unique audio file, the bug appears in both cases in the same way)

TOPICS
Audio , Editing , Error or problem

Views

1.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 06, 2020 Dec 06, 2020

Known issue: save, close and reopen project or revert to previous version.

Votes

Translate

Translate
New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

I have the same problem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

Known issue: save, close and reopen project or revert to previous version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

Thanks a lot for your answer!

It must be an issue of the latest version then, hadnt had this before 14.6

Hopefully they fix this soon, I was aware of the workaround you offered, but still thats a pretty annoying bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

This is still happening in PP2022 (v 22.5) on Windows 10.  The recommended solution does not work.  Have also tried closing all the way out of PP and restarting.
CRTL+click inserts an audio keyframe that maximizes the audio to the start of the clip, and sets it as "Continuous Bezier". Changing the type leaves the level incorrectly set; it just changes the curve to a line.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

The only —very hacky— workaround I've found is to set a keyframe at the very start of the clip, change that to linear, and then add my other keyframes, which now come in as "linear".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2023 Nov 17, 2023

Copy link to clipboard

Copied

I can confirm that this issue is still present in November, 2023... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

LATEST

In the position settings, right click on a keyframe that appears to be a linear keyframe.  Go to Spatial Interpolation.  Bezier is likely selected.  Change that to Linear.  Repeat for any other keyframes within the position settings.  It appears that linear keyframes are occasionaly created with Bezier preselected.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines