Why in Macbook Pro 16 Premiere Pro 14.1.0 not working with AMD Radeon Pro 5500M correct??

Community Beginner ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

my happiness did not last long ...
I bought the new Macbook Pro 16 from AMD Radeon Pro 5500M 8G and cannot use METAL hardware acceleration support. I have Premiere Pro 14.1.0 installed.

I have been trying all day and only supports Intel UHD Graphics 630 as hardware support.
I previously owned a Macbook Pro with RX560 and it worked perfectly.
Why doesn't it work on the new Macbook Pro 16 correctly?

I read various similar cases in this forum - switching to Open CL is not a solution for me - for example.

regards

Wojciech

TOPICS
Hardware or GPU , Performance

Views

913

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

you only have software only, open CL available and Metal greyed out?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

Beginning with the now-discontinued 2018 release, Premiere Pro will now only recognize the GPU that's set or connected as "primary" for the purposes of MPE GPU acceleration when there is a conflict between two dissimilar GPUs that use the exact same GPGPU API. That means that on most laptops with an Intel/AMD combo GPU (both of which use OpenCL or Metal), then only the integrated Intel graphics is used no matter what.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

try this please:

https://gfx.io/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

Thanks for advice... but I will repeat again: I previously owned a Macbook Pro with RX560 and it worked perfectly.

right now I will turn off power save in sytem preference, use gfxCardStatus and still after all, I can't use Radeon Pro GPU power to work in Premiere Pro, because it only works with Intel Graphics

 Zrzut ekranu 2020-04-23 o 08.48.50.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2020 Apr 23, 2020

Copy link to clipboard

Copied

and also I found this topic witout solved:

https://community.adobe.com/t5/premiere-pro/adobe-premiere-pro-new-macbook-pro-16-inch-not-using-a-r...

I have got this same situation... no rendering with Radeon GPU....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

I've been reading through the forum about these issues. This is so crazy. I'm honestly going to cancel my Creative Cloud subscription if Adobe doesn't speak up about this. It's crippling every program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

LATEST

Update your Bootcamp driver for windows 10

https://www.amd.com/en/support/kb/release-notes/apple-boot-camp

 

Start Premier as administrator. Go to project settings. Your should been able to activate OpenCL.

In my case it works. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines