• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Speedramp in Premiere Pro 2020 is a mess

74 Votes
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Speedramping in Premiere cc 2020 let my eyes bleed like ****.
No smooth, but cruel lagging while playbacking the speedramped clip.
The rendered file however is fine.

Fix that as soon as possible, before I went out of blood.
Thanks
Idea No status
TOPICS
Editing and playback

Views

8

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
21 Comments
Adobe Employee ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

HI Jan-Alexander,

Does this happen with all uses of time remapping on your machine or are there specific settings that reproduce the problem? Can you share more details and steps on how to reproduce the playback problems? I'd be happy to look into this on the Adobe side.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Hi Premiere Pro team. I am going to elaborate a bit on what he is saying. Currently, while using the CUDA renderer, speed ramping will not playback smooth and ruins the entire timeline. The playhead doesn't move, the video won't play, the audio plays back fine however.

This issue has been here for months, I don't know how such a major feature hasn't been fixed yet, I have been using Premiere Pro 2019 waiting for the issue to be resolved, since speed ramping works fine in 2019.

Please fix this issue, if you have any further questions for me, please let me know so we can get someone fixing this. I have seen tons and tons of forums on this exact same topic.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I just noticed the issue when i was going to do some speed ramping, i thought it was a problem with my computer to more i searched i noticed that Windows and Mac users are having the problem.
when i apply the speed ramp it shows the image at the beginning of clip. and when it gets to its normal speed it plays back. if i render the clip it still happens. if i export it. you can tell that speed ramp worked but you are working in the blind not knowing if it came out right.

so i am hope this will help a bit. so you can get it fixed.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I also have an issue with time ramps. I'm always updating versions of my clips that are capture exactly the same way so all I should do is REPLACE the clip and keep all its attributes as is. Well, this doesn't really work 99% of the time when using Timeremapping. It is a pain **********, I basically have to manually match the clips every time. Also, sometimes one day the clips are playing fine on my timeline but then I come back the next day, same project and all the time remaps are screwed, nothing plays back properly so I have to redo them all to match what I had done the day before. This has been happening since 19. Super frustrating!

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

YES Please update.and fix quick..I had to uninstall and reinstall....lost everything. Speed ramping worked in 2019 vrs. I was online with 2 tech support people for almost 8 hrs. could not fix.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

When is this going to be fixed??? I've had the same issue with 2020 since its release.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

The whole speed ramp system to me is confusing and difficult to use. I always end up being to short or to long or stuff it up some how and clip becomes 1 frame short. I think the way the speed ramp GUI feature works needs to be completely rethought.

Ideally I just want to be able to place to nodes and a ideal speed, then have PP auto speed ramp the best it can with in those parameters. I find the bezier curve and nodes just to difficult to work with.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I cannot believe this bug still hasn't been fixed Premiere 2020 is a dumpster fire.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I am experiencing an issue with Speed Ramping. An image keep showing up as soon as I start the ramp, throughout the entire process of the ramp. Extremely frustrating as this is a feature that is used in a majority of my projects. How has this not been fixed yet are you kidding?????

Here is how you can re-produce:
- Drag clip onto timeline
- Right click, show clip keyframes
- Time remapping, speed
- Create a speed ramp, play back

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Guys just go to Edit>Preferences>Audio Hardware and change the default input from Digital Audio S/PDIF High definition audio device and change it to none. And look at the results. It's weird but gonna work 🙂

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Ever since PP 2020, playback on my speed ramped footage has just shown a thumbnail of the clip and it is driving me mad. Speed ramping is such an important day to day editing feature that can't be messed up for months. Please fix this, we are paying a monthly subscription.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

it s a disaster
when I upload my files, interpret them in 24 fps (originals are 30,60,120) and then I speedramp them, when I cut on music and play its a mess I can't work, its just playing broken blinking stop motion style whatever. not possible to work, please Adobe fix it, we are already 45 people and there are 1000000 more who just didn't vote yet

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

0sorry guys the last 3 days and the delays on the order I'm sorry my order and packages and went going to my email so because of the covid-19 G5 linkage we will order yours a free device of your choice of one device of only protein

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Amen, I've had this issue for quite some time now.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I can't believe still no fix for this issue.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Just updated TODAY and STILL no fix.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Really hard to believe that this still hasn't been fixed today in June 2020. OP addressed this issue in november 2019. I also thought it was a problem with my computer but now see that this is a major issue with Premiere Pro 2020.

If we're gonna have to pay a monthly subscription for the rest of our lives instead of being able to buy the product one time, I expect monthly updates and bug fixes. All of my friends that are on Final Cut are laughing out loud right now, not experiencing those issues and NOT paying every single months for it.

Very disappointed. I am an Adobe guy and always have been a raving fan, but now I just feel like I'm being laughed at.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

+1 Please fix Adobe team, this is very difficult to manage

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

In addition, i think Speedramp shoud be something like Final Cut Pro or Davinci, it's so easy and smooth to control the footage. Right now, we have to click every single Footage to turn it on, so please consider it, thanks Team!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Premiere Pro 14.9.0 aka the freshest. Can't even add/control the ramp keyframes. Has been like this since last year. Awful..

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

LATEST
I've spent hours on the phone with Apple because Adobe has me convinced I have bad graphics cards in both my two new Mac Pro 2019 machines.....I'm so so angry right now, and every time I edit....Adobe, PLEASE

Votes

Translate

Translate

Report

Report