Adobe Premiere Pro CC 2019 not automatically switching to headphones

New Here ,
Mar 09, 2019 Mar 09, 2019

Copy link to clipboard

Copied

Hi,

Since a few days, my Premiere Pro CC is not switching to plugged-in headphones when audio is played. I tried to fix it with audio hardware preferences. However, when I change the default output to headphones, speakers stop working even when headphones are plugged out and the vice versa. I tried installing an older update to see if my current version had bugs, but it didn't work. Is anyone else having the same issue?

[Discussion moved from Adobe Creative Cloud to Premiere Pro CC - Mod]

Views

4.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Aug 09, 2019 Aug 09, 2019
I'm using MacOS (Mojave) and this is how I solved it. 1. Open Audio Midi Setup app (found in utilities folder)2. Hit the + button on the lower left hand of the app window and choose "Create Aggregate Device"3. Plugin your headphones and with the Aggregate Device Selected on the left-hand side make sure your speakers, microphone, and headphones are all selected with checkmarks. I also made sure that in the GUI window I drug my External Headphones to be the first in line. (Colored rectangles are d...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 10, 2019 Mar 10, 2019

Copy link to clipboard

Copied

jamshidbeky29744174  wrote

I tried installing an older update to see if my current version had bugs, but it didn't work. Is anyone else having the same issue?

What didn’t work? Installation? Or did you have the same sound problem?

Looks for me like a sound problem independant from Pr.

Do you have Aition installed? If yes, could you try if Audition has the same problem?

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

I had the same issue and have been trying absolutely everything with no success until I found a thread that recommended downloading an AISO driver. Once installed you go to your Premiere Audio Hardware setting and change if from MME to AISO. And it worked! Below is the link to the driver I used. I hope that helps.

ASIO4ALL - Universal ASIO Driver For WDM Audio

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

LATEST

Hmmm...I'm totally tempted, but a bit hesitant...thanks so much for this, Christine! I appreciate it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 11, 2019 Aug 11, 2019

Copy link to clipboard

Copied

Plug your speakers into the analog or digital audio output from the motherboard or sound card.

Plug your headphones into the headphone jack on the speakers.

This works every time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2019 Aug 09, 2019

Copy link to clipboard

Copied

I'm using MacOS (Mojave) and this is how I solved it.

1. Open Audio Midi Setup app (found in utilities folder)

2. Hit the + button on the lower left hand of the app window and choose "Create Aggregate Device"

3. Plugin your headphones and with the Aggregate Device Selected on the left-hand side make sure your speakers, microphone, and headphones are all selected with checkmarks. I also made sure that in the GUI window I drug my External Headphones to be the first in line. (Colored rectangles are draggable).

3. Closeout of the Audio Midi app and open up Premiere Pro. Go to Preferences, Audio Hardware, and in the "Default Output" choose "Aggregate Device"

After I did this whenever I plug in my headphones they take priority and audio from Premiere Pro plays through them.

Screen Shot 2019-08-09 at 6.01.31 PM.png

Screen Shot 2019-08-09 at 6.03.15 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2019 Oct 13, 2019

Copy link to clipboard

Copied

You save my life! Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 01, 2019 Nov 01, 2019

Copy link to clipboard

Copied

Thank you! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2019 Nov 20, 2019

Copy link to clipboard

Copied

You are my HERO.  This saved me probably 10 hours a year.  Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

FIXED!!! You sir, deserve an award of some sort. Fixed one of the most annoying problems I had with premiere!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2020 Jun 12, 2020

Copy link to clipboard

Copied

Thaaaaaank you!!!!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines