Highlighted

Adobe Premiere Pro stops responding while on loading screen

New Here ,
Oct 23, 2020

Copy link to clipboard

Copied

After 14.5, Premiere pro stops responding when it shows the loading screen. I had to switch to 14.4. And that worked. But when I launch the application again. It wouldn't load too! So I decided to switch to 14.5 to see if it was fixed. But it did the same thing again. Any fix?

TOPICS
Error or problem

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe Premiere Pro stops responding while on loading screen

New Here ,
Oct 23, 2020

Copy link to clipboard

Copied

After 14.5, Premiere pro stops responding when it shows the loading screen. I had to switch to 14.4. And that worked. But when I launch the application again. It wouldn't load too! So I decided to switch to 14.5 to see if it was fixed. But it did the same thing again. Any fix?

TOPICS
Error or problem

Views

73

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 23, 2020 1
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Please tell us your system specs: OS version, Premiere version, amount of RAM, Hardware specs including graphics card.

Does your system meet the minimum specs required?

https://helpx.adobe.com/premiere-pro/system-requirements.html

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
New Here ,
Oct 23, 2020

Copy link to clipboard

Copied

Here are my specs

Storage Type: SSD, HDD
Total Storage Capacity: 2240 gigabytes
Solid State Drive Capacity: 240 gigabytes
Hard Drive Capacity: 2000 gigabytes
System Memory (RAM): 8 gigabytes
Graphics: AMD Radeon RX 580
Processor Speed (Base): 3.6 gigahertz
Processor Model: AMD 3rd Generation Ryzen 5
Processor Model Number: 3600
Operating System: Windows 10

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
New Here ,
Oct 28, 2020

Copy link to clipboard

Copied

I have exactly the same problem with 14.5. I got back to 14.4, this version got the problem too even if it wasn't the case before. When I got back to 14.5, nothing was fixed. 

 

14.5 version also has major problems with keyboard shortcuts not responding while editing titles.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0
LEGEND ,
Oct 28, 2020

Copy link to clipboard

Copied

In 14.4, reset your workspace to the default editing workspace. Then update to 14.5 and try again.

This FAQ may affect your issue: https://community.adobe.com/t5/premiere-pro/faq-how-to-solve-issues-related-to-undocked-panels-in-pr...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0