Anyone else having problems with the latest update? Premiere Pro 15.2

Community Beginner ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

So yesterday I installed the new update and from that point on there seems to be a ton of problems.

 

Some examples are the following:

1. I can't see the clips while dragging them on the timeline, I can move them but the don't show live. A workaround to that is disabling the audio waveforms, but that is hardly a fix.

2. As I am using multiple sequences in a project, at random points I cannot perform any actions within a sequence. At that point I have to swap to a different sequence and come back to the one I was working on and then it works (apart from all the bugs).

3. Within a sequence it doesn't let me use some of the panels like Essential Sound (I click on it but nothing works) and even if I go to another sequence (as above) and then back to the one I m working on, it doesn't work. But this doesn't happen to all sequences, on others it works fine. 

4. Also, within some sequences it doesn't let me move the clips to another sequence but dragging and dropping, only with copy paste.

5. I have encountered 3 different playback problems so far. The first was a weird effect of green and purple colors instead of normal ones, but it hasn't shown up again in a few hours now. The second was that one clip plays normally until one point and then it becomes completely black at another and then back to normal. The last one is a playback start delay, in which whenever I press Space the playback starts after 1 second, which can become really frustrating if you have a ton of work. I tried clearing the cache and creating new projects on different drives but nothing did the trick.

6. At some points I would change the audio output and it didn't work unless I restarted Premiere. This problem hasn't shown up again in quite some hours. 

 

Generally my experience with the new update has been really bad. I hope these things will get fixed soon.

 

My system is up to date and the parts are the following:

CPU - AMD Ryzen 7 5800X

MB - ASUS TUF Gaming X570 PRO

GPU - AMD Radeon RX 580

RAM - Corsair Vengeance LPX 32GB 3600MHz

SSD - Samsung 970 Evo Plus 1TB

 

TOPICS
Editing, Error or problem, Performance

Views

418

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

Yes, the first problem you mention appeared in 15.1 and I flagged this up in the forum. The only work-around I used was to revert back to 15.0. My Premiere Pro just did an auto update (despite turning off auto-updates) and I'm disappointed to find that the drag clip problem is still here two iterations later. It makes Premiere unusable so, once again, I'm reverting back to 15.0. Before I do, can you explain your work-around by disabling audio waveforms? How do you do that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

In your timeline you click on the wrench tool icon (it's called Timeline Display Settings) and you will see a list of things you can show on the timeline. There you have to uncheck Show Audio Waveforms. I hope this helps you, for me it is really annoying!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

Thanks, George, appreciate the explanation. And yes, it's the first really frustrating bug I've had in a while. I don't like using older versions of Premiere but this bug makes 15.2 and 15.1 completely unusable. I don't understand how such an obvious error slipped through the net... twice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

Yes exactly! Let's hope they will fix the problems! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

I've added it to the bug report page too. Could be worth you commenting on this to bump it up?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

LATEST

I'm unable to edit my preferences whenever I try to change any preferences the application crashes with a spinning wheel.  Does anyone have a fix for it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines