app.sourceMonitor.getProjectItem() returns undefined when double-clicking video in activeSequence

Explorer ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

Hello everybody!

 

I am experiencing some strange behavior regarding the sourceMonitor object.

 

I have an activeSequence opened in the timeline which contains some stuff:

timeline.png

When I rightclick the video in V1 and select "reveal in project", it jumps to the item in the bin.

After double-clicking it, or selecting "open in source monitor" in the context menu, it shows up in the source monitor and I can do:

var sourceMonitorProjectItem = app.sourceMonitor.getProjectItem();

I get the projectItem from the sourceMonitor and can do stuff with it.

 

The problem is:

If I double-click the video in the V1 of the activeSequence, it is opened in the sourceMonitor and I can scrub there, but if I try to get the projectItem of the sourceMonitor, the sourceMonitorProjectItem is undefined.


Here is the proof:
ACP-172_sourcemonitor_ 2020-12-21 17-55-51.gif 

 

Is this a bug or is this working as intended?
If not, is there a dirty-hack workaround? ( 😉 )

Regards,

Guntram

p.s.: The context menu of the video in the V1 of the activeSequence does not contain an option like "open in sourceMonitor"...

TOPICS
Error or problem, SDK

Views

89

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Jan 05, 2021 Jan 05, 2021
Hi Guntram, We were able to reproduce your problem, and I wrote up bug CEP-2292. I made a notation in the bug to update this forum as new info becomes available.  Thanks for providing the files and details.   -Dan  

Likes

translate

Translate

Translate
Adobe Employee ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

Hi Guntram,

 

Can you send me a .prproj containing the clip-and-sequence in question, and steps to repro the behavior?  [bbb@adobe.com]

What sort of thing is the clip being opened, in the Source monitor? If a trackItem (the API doesn't know what a 'clip' is) has a backing projectItem, it should work...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

Hi Guntram,

We were able to reproduce your problem, and I wrote up bug CEP-2292. I made a notation in the bug to update this forum as new info becomes available.  Thanks for providing the files and details.

 

-Dan

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines