Audio waveform not showing visually

New Here ,
Jan 02, 2019 Jan 02, 2019

Copy link to clipboard

Copied

Having issues with this since updating to 2019. Basically, after importing a clip into the timeline everything is as it should be (video plays, audio plays) but the audio waveform does not show up until it's played through so I cannot visually see the audio waves unless I play/skip through the whole clip, which obviously makes editing a lot slower.

Attached an example. Image 1 is the clip just imported to the timeline and image 2 is after playing through a few seconds (as you can see the audio only shows up after I've played through the clip and the remaining audio waves are still blank)

Any help would be appreciated!

Using Windows and Adobe Premiere Pro 2019.

Audio1.PNG

Audio2.PNG

Views

97.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jan 02, 2019 Jan 02, 2019
First, go to Edit > Preferences > Audio and make sure that the setting "Automatic audio waveform generation" is ticked. If this is un-ticked no waveforms are generated when importing files. This will not affect already imported clips, it will only affect clips you import from now on.Second, for creating audio waveforms on clips that dont have them, select the clip/s in the Program panel and go to Clip > Generate Aduio Waveform.If the first trick fails i would have trashed the Preferences in Prem...

Likes

Translate

Translate
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Same problem here, almost over a year after first reported. The fact that you have to go whatever extra steps to see a waveform is embarassing. Did anyone at Adobe actually work as an editor? Time spend waiting and troubleshooting just keeps piling up 😞

 

Render-and-replace option seems to be working so far, thanks for that at least.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

I found a vídeo with the solution:
https://www.youtube.com/watch?v=AWi_ezZD0fU

Have any of the following questions? #premierproWhy are my waveforms missing?How to get waveforms in Premier ProPremier Pro CC not showing waveformWhere did ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

I found a vídeo with the solution:
https://www.youtube.com/watch?v=AWi_ezZD0fU

Have any of the following questions? #premierproWhy are my waveforms missing?How to get waveforms in Premier ProPremier Pro CC not showing waveformWhere did ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

(edit) solved with with explanation donated beforehand in this thread

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

The above solution didnt work for me -as well as most of the other suggestions. I closed PPro, deleted the .pek files, then it regenerated them when i reopened the project. Works like a charm...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Try right clicking on the clip on the timeline > Render and Replace. Worked for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2021 Jan 30, 2021

Copy link to clipboard

Copied

this worked for me! Thank you. Thank you. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

What worked for me is:

1. Unlinking Video and Audio

2. Right-clicking on the audio "line"

3. Render and Replace...

SimonasVS_0-1613856543673.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Summary of "Fixes" (Star-Rated, on a 5-star scale):

  1. *** Render & replace.  I and many others here have found this work-around, and it seems the most robust approach, in that is works the most often.  But it's slow, makes extra files, and in rare cases, even this fails.
  2. *** Avoid editing audio tracks in Multicam sequences.  For my own reasons, I often ignore this advice and later regret it.  For example, muting audio track 1 in your multicam sequence, is trouble.  You might think you can just unmute some other track, and thereby still have an audio waveform in your derived sequence.  But the underlying code behind the multicam sequence does some mapping, and this doesn't seem designed to allow us to do these sorts of edits.  You might get audio, or you might not.  If you've done fairly little in the multicam sequence, you might be able to just unmute audio track 1 of the multicam sequence, and the audio waveform in the sequence derived from it may return.  But, the more you edit things in a multicam sequence, the more likely the bug will not be recoverable, by user manual efforts.
  3. ** Clip > Generate Audio Waveform ... is quick to try.  I think this worked for me once in several years.  But mostly no help.
  4. ** Edit > Preference > Audio > check "render audio when rendering video" ... may help.  Default is off.  So try turning on, then re-add your video to you sequence.  Might get lucky.  I have little experience with this one.
  5. * Edit > Preference > Audio > check "automatic audio waveform generation" ... fixes problem only if this was unchecked (and the default is checked), and then only for clips added to timeline after this is rechecked.  Most of time, this was not the problem, so it's not the fix.
  6. * Clear cache & peak files, some think preferrably manually (to be more complete).  This has yet to work for me, and many here report the same non-result.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

From personal experience - Averdahl's solution may work, but I've never resorted to that myself because I actually use preferences to store the state of my editor, and prefer to not mess with it. The simplest solution I've found to work is to renaming the file and importing it again (sometimes more than once). I'm assuming this is a fairly basic cache issue and would be resolved by deleting the faulty preview and re-importing but, jesus mother of god, this should not be incumbent on the user. The fact that even manually invoking Generate Audio Waveform fails to generate a  valid waveform is just baffling.

 

My experience is that Adobe feeds on user sanity and has had this bug, among oh so many others, around since forever. Moreover, not only does pretty much every single major revision make me want to shoot myself, the absolutely absurd plethora of basic bugs and quirks that keep re-emerging is often mind-boggling on a Bethesda level.

 

Since these seem to be favorite solutions to various problems on the web:

 

@adobe : to be clear, I'm not suggesting introducing more bugs to widen the gamut, but if every second issue with your software requires the user to trash their preferences or nuke the cache, move files around, deal with lost work due to instant crashes, unzip and edit the project file, never upgrade, or roll back their drivers or editor, then it just might be time to invest in a better QA team. Or I don't know, maybe at least listen to their damn feedback.

 

But enough barking up a dead tree: even this basic issue hasn't been fixed in years and I'm confident won't be for years to come.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines