Highlighted

AVCHD inquiry SONY HDR-CX405, Catalina iMac running Premiere Pro 2020

New Here ,
Jun 25, 2020

Copy link to clipboard

Copied

I'm running Premiere Pro 2020 on a 'brand' new iMac (Catalina) just out of the box.  I have a Lacie Rugged USB-C drive with 50gb of AVCHD files from a consumer grade SONY Handycam "HDR-CX405" The footage was shot at 60 (59fps) 1080p 

 

Everything is brand spanking new and I was expecting to feel the speed of the new machine. 

 

So, I can't load my "PRIVATE/AVCHD" folder into Premiere Pro (Long Wait Times, multiple crashes) Then eventually after waiting upwards of 20min to load 12gb of video footage at 1080, Premiere wouldn't let me do anything with it, while it was extremely slowly trying to conform the MTS, which it ultimately couldn't do. Also, I was getting mixed audio from different clips..audio from the wrong clip etc. 

 

Basically the whole thing was a wash. Nothing worked. I could not view these files or edit them. 

 

I reinstalled Premiere Pro from Adobe Cloud and tried again, but with no luck. 

 

What am I missing here? I've worked with AVCHD in Premiere many times.  Normally I work with much higher level camera equipment, but I just shot some stuff on a cheap Sony handicam for my own enjoyment, it's not even that high res. What's the deal? 

 

Topics

Crash, Error or problem, Freeze or hang, Import

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AVCHD inquiry SONY HDR-CX405, Catalina iMac running Premiere Pro 2020

New Here ,
Jun 25, 2020

Copy link to clipboard

Copied

I'm running Premiere Pro 2020 on a 'brand' new iMac (Catalina) just out of the box.  I have a Lacie Rugged USB-C drive with 50gb of AVCHD files from a consumer grade SONY Handycam "HDR-CX405" The footage was shot at 60 (59fps) 1080p 

 

Everything is brand spanking new and I was expecting to feel the speed of the new machine. 

 

So, I can't load my "PRIVATE/AVCHD" folder into Premiere Pro (Long Wait Times, multiple crashes) Then eventually after waiting upwards of 20min to load 12gb of video footage at 1080, Premiere wouldn't let me do anything with it, while it was extremely slowly trying to conform the MTS, which it ultimately couldn't do. Also, I was getting mixed audio from different clips..audio from the wrong clip etc. 

 

Basically the whole thing was a wash. Nothing worked. I could not view these files or edit them. 

 

I reinstalled Premiere Pro from Adobe Cloud and tried again, but with no luck. 

 

What am I missing here? I've worked with AVCHD in Premiere many times.  Normally I work with much higher level camera equipment, but I just shot some stuff on a cheap Sony handicam for my own enjoyment, it's not even that high res. What's the deal? 

 

Topics

Crash, Error or problem, Freeze or hang, Import

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation