Blurry exports H.264

Community Beginner ,
Jan 21, 2021

Copy link to clipboard

Copied

Hello,

during the export,some clips are blurry(not all project). I checked the original footage and they`re not blurry at all. In the past, I solved the problem just replacing the blurry clip. However now this is not enough. I`ve tried to export in H.264 VBR2pass but without success. The original footage is in DV 720x576,captured in AVI if this helps.

 

Thanks in advance

TOPICS
Editing, Error or problem, Export, Performance

Views

113

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 21, 2021

Copy link to clipboard

Copied

Of course in Premiere Pro

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 21, 2021

Copy link to clipboard

Copied

Can you please post a picture of one frame of video.  There is several kinds of "blurry" and each has its own way to resolve.  if you want to try something (But I would wait for advice after you post your video frame sample) there is few things that jump out as possible without seeing the blurry video frame for myself.  (There is a picture icon when you create a reply that allows you to attach a photo).

 

1) You have an AVI @ 576 this to me means its likely an interlaced video.  If so some people might call that blurry when they export, because it has the effect of appearing like your looking through horizontal blinds.  Premier seems to play them back fine int he preview window, but combined with an export it sometimes looks really bad.  When we see your still frame, we will know what it is.

 

2) The bit rate you used on the export is too low.  if that's the case, it will look like lego bricks to different degree's depending on how low the bit rate used was.   Combined with frame size of the export (and upscaling) it will also play a  role in the 'blur' - please specify the bit rates you used also.  If your exporting 4K I try to not go under 50k unless I have a specific reason.  if you are using VBR, I tend to set the max to 60/65 and and the target to like 45/50 (I adjust based on how much noise is in the video and movement, both of which need more bit rate to improve display quality).

 

3) What frame size is your export.  If you are for example, exporting that 576i vertical, and trying to get it to scale up to a 2160p, and not doing anything about the type of upscale you are using, the video will also be blurry.  The work around that's "suitable" is to create a 4k time line, and put your lower frame size video on it.  Use the "transform" filter under the "distort" heading (NOT the scaling you see by default on every clip) and scale it up to fit the frame.  There is an option on type of scaling (which is the quality of the math used).

 

FlyingFourFun_0-1611253298691.png

And the quality and type of upscale:

 

FlyingFourFun_1-1611253352440.png

 

Some type of graphics images work better or worse with the different "Sampling" settings, which is why they are both presented.

 

This will improve dramatically the quality for the upscale for exporting in 4K (or high than what you started) but its not a miracle worker.    The reason why when you play an old AVI file in media player and it looks okay is typically Media player is handling that de-interlace and doing this scaling for you, and often, people don't scale up the video, they watch it at its defaults 1:1 pixel size.

 

As a side note, if scaling is your issue, and you want remarkable results purchase Topaz Video Enhance AI and it will work small miracles for you.  BUT be warned, it doesn't work on Interlaced video either so you have to deal with that.

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 21, 2021

Copy link to clipboard

Copied

Hi FlyingForFun. Thanks for the detailed answer. Yes, the video is an interlaced one and it has the horizontal blinds effect. Post here below a frame.

 

riccardor88384511_0-1611262052915.png

-FRAME SIZE.The setting of the Sequnce was 720x576 , exported in the same  frame size ,720x576.

-BITRATE: I used the VBR pass2  targetbitrate10,maximum bitrate 10. You say that you use max 60 and target 45-50. How do you get these numbers? My maximum in the box of birate is 17.4. I just post the window of my export windows.

riccardor88384511_1-1611262600234.png

I also have to say that the frame above had an upscale in effect control from 100 to 115 that contributed to the "Blurry"effect.

 

Thanks

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 21, 2021

Copy link to clipboard

Copied

Okay lots of answers in that list;  Your source footage is in fact interlaced, in the screen shot you provided you will see it say "lower field first", that's a type of interlacing.  I would suggest you apply a de-interlace (or consider it);  Apply this effect BEFORE others.   Chance your sequence settings so its not a interlaced sequence also, or you will not be able to de-interlace it;  This step will be very important to remove some of the 'blur' especialy in places where there is movement on the frame (technicaly the 'blur' from interlacing is called combing btw).

 

the 115% zoom is not a big concern but with this source footage its likly contributing to your blur also.  When you start video of your original source quality, it will magnify flaws.  I would suggest if you can in your settings,  try and change the transform setting for zoom to BiCubic and see how it works for you, its often better results, but not always.

 

As for bit rate;  I was assuming your 4K output.  the following chart is a good reference for different format and bit rates upto 1080p if you have not seen this before.

 

Type Video Bitrate, Standard Frame Rate (24, 25, 30) Video Bitrate, High Frame Rate (48, 50, 60)

1080p8 Mbps12 Mbps
720p5 Mbps7.5 Mbps
480p2.5 Mbps4 Mbps
360p1 Mbps1.5 Mbps

 

I treat the above as the lowest,  so your rates are actually very good for this, maybe even high as toyr between 480p and 720p.  (based on the screen shoot I saw)  Based on your frame size, the system will not let you pick the rates I suggested, they are for 4K).

 

So and the end of all of this,  I believe what I am seeing for the 'blurry' in your video is a combination of low frame size, zoomed up, and interlaced footage.  Its possible to improve the output with a deinterlace (but dont forgot to use a deinterlaced sequence setting) and a little better upscale and if you can use less zoom.  15% on 4k is not too bad, but with your source footage it is a bigger impact.

 

Keep in mind that because you have interlaced footage your vertical res is only half of that 576.

 

Another few things you can try to improve that output is to apply a noise remove filter (you have a little bit of compression artifacts and noise.   Noise Remove can add lots of processing time (be warned).  I think some people also smooth out the compression and noise by apply a slight Gaussian blur  (I think people use 3%).  It will soften the picture, but some people enjoy that look, it reduced the pixelation you see with compression artificacts.

 

There is ways to make even bigger improvement to the quality using Topaz Labs Video Enhance AI, if this footage is really important to you, try thier download trial edition and see if its work the several hundred for you.  

 

With that said,  I think you will find deinterlacing, a marked improvement, tweek with noise removal or the blur for a bit more, and try to lower the zoom level.  I can see the combing from your interlaced video in her hair where there is a strand off to the side against the wall, on the neclace etc.  With motion, this will get much worse,  if you properly fix the interlacing issue it will make the biggest impact.  There are better ways than the built in tools in premier to deinterlace, but try the free included tools first.  If thats not enough improvement, post a seperate question here if you dotn already find a post about this. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 21, 2021

Copy link to clipboard

Copied

Post screenshot export settings with left tab to output with an image.

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 21, 2021

Copy link to clipboard

Copied

This is how you export your video either 4;3 or widescreen.

Scale footage as little as possible in the timeline.

export DV avi.jpg

Remember SD footage will never look good full screen on a HD monitor or TV.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 22, 2021

Copy link to clipboard

Copied

Thanks everybody for your replies. I tried to deinterlace with topaz lab video but it didn`t work. I did with Handbrake. I don`t know if the result it`s good, put it on timeline with progressive settings and exported asyou both siad. The result is this.

 

riccardor88384511_0-1611329013327.png

The bitrate that i have to use id 7.5 right or 5?

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 22, 2021

Copy link to clipboard

Copied

FlyforFun I still don`t understand the Upscale thing that you said. I followed your instructions and the result is that the image is very small like this.

 

riccardor88384511_0-1611330691204.png

Did I miss anything?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 22, 2021

Copy link to clipboard

Copied

Ok, so your on the right track with that smaller picture inside the bigger video frame.  I assume that sample is from the output you created in Handbrake, thats deinterlaced?  if so, continue to use that.  Also,  I assume the timeline you created is 4k based on how small that picture is inside the timeline.  

 

To get that picture bigger in the frame using the built in tools of premier,  apply the "transform" effect, the one that appears under the title of "distort" in premier.

 

The one highlited here in this pitcure:

FlyingFourFun_0-1611331488620.png

 

Once you do that, edit the effect thats been applied to the clip, and you will see a window that looks like there.  There is two things you need to change.    Change the scale number, which should read as 100% to a bigger number, until it fills the entire video frame.  It probably a number around 400%, but you may have try a few different ones.  The varible is the "samples", I would change it to "bicubic", it defaults to "bilinear".

 

FlyingFourFun_1-1611331554010.png

These changes will  leverage premiers built in scale up, and will give you good results.

 

When you do this, and export, the output should be better.

 

If you want to get fancy, you can add a noise remove filter etc, but thats up to you.

 

If you happy with it thus far, you can stop here (most people do).

 

As for Topaz.  if you wan to try that,  take the footage you deinterlaced from Handbrake, and import it into Topaz,

 

In Topaz, there is a bunch of settings for the type of scalign it does,  for now, leave it at the default one.  In the middle of the right hand screen, you will see this dialog:

 

FlyingFourFun_2-1611331981844.png

In the "settings" dislog, select the output size you want.  For your workflow, go ahead and pick 4K, leave the check box for Crop to fill frame off if you want,  you and click it and the live preview will show it what it does.    

 

In the "Save Result" pick MP4, like the screen shoot, Check off keep Audio, pick your file save location.  Pick a compression factor.  I always use 5, which makes really big files, so I suggest you try 10 which will be smaller and work just fine.

 

On the top right of that screen shot you will see an icon with an 'eye' inside a camera, you can click on that to preview a few seconds of your settings applied to the footage you imported.    If you dont like the result, try different "AI Models" and see which is best for your footage.

 

If you export the video from Topaz, import that back into a new project, put it on a new timeline and those settings should match to the video Topaz created.    Then work with the file as normal.  Your 15% zoom should look fine on this 4k footage.

 

You also have the option of takign that 4k footage you created, and when you create a new timeline in Premier,  make that new timeline a 1080p one.  Place the Topaz 4k footage into that time line.  It will be bigger than than the time line, so you will need to scale it down 50% to fully fit, but now when you scale it, you will scale the 50% to take 65% and it will retain all the detail it possible can inside that 1080p timeline.

 

The simpliest way, that will likly get you results that are more than acceptable is the using what was described for the premier way, which the transform effect.    I know this sounds more complex than maybe it needs to be...  apologies for that.  But stick with me,  once you do this, the next time, you need it it will seem really easy to you.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 22, 2021

Copy link to clipboard

Copied

Ok, I`ve tried. The result is not so bad. You can see by yourself

 

riccardor88384511_0-1611334971575.png

Anyway, thanks a lot for the detailed instruction , it really helped

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 22, 2021

Copy link to clipboard

Copied

I agree its looking better!

You can now start to go crazy on it if you want...  there are lots of other tricks to improve it even more, but you have done the heavy lifting now....   Like Sharpen and noise reduction (Neat Video is popular).

 

I will say, if you want to try something, now that this is a 4k timeline.  If you export your final project to 1080p it will actually look a even a little better yet (but it will be 1080p).  You can try a few min of video, and see if you like it but you do give up the 4k however.

 

Overall, I think you have done a great job reading past my bad spelling, and long descriptions.  You have removed Interlacing, mastered the upscale and many other skills.  It looks much better now!

 

Hopefully you can continue your work and focus on the creative vs the technical.  This is actually Adobe mission, but the program has so many options to do the same things, with different results....

 

If you are doing projects like this often, and you need better results than what you go there, that Topaz software is really good.  I have used it on personal projects - 20 year old footage - and it was worth every penny...  But, as you can tell, you can get very usable results just with Premier.

 

As a pro tip, I would never use the scale, position that's the default for clips (See screen shot below)

 

FlyingFourFun_0-1611336116536.png

 

The transform effect you just used is the preferred way.   The only time I use the default (above) motion / position / is to set it once, and never move it.  But if I have to scale, I ALWAYS use the Distort/Transform.  if you stick to this approach, it will serve you well into the future as it supports motion blur etc and much more versatile.  Frankly, I have no idea why Adobe keeps that default position/scale around, it should be replaced with the Distort/Transform.

 

At the end of the day,  Thanks for sticking with my rambles/spelling...  I trust you achieved what you were looking for and learned a few things along the way!  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
riccardor88384511 AUTHOR LATEST
Community Beginner ,
Jan 22, 2021

Copy link to clipboard

Copied

OMG you helped me so much! When I finished my shooting I realized that I used the interleaced and not progressive. I tried different solution to deinterlace but it was looking really bad. But with this solution ,it went beyond my expectations. I`m so happy! Thx again

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 22, 2021

Copy link to clipboard

Copied

Ok some good news,  from what I can see, you don't having any of the interlacing artifacts in that sample (The full frame size one).    As for Bit rate, you don't "have" to use 7.5/5.0 - you can use you 12 or what ever you were using before.  The file will  be bigger, but there is more room for higher quality, and you will reduce the compression artifacts.  There is a balance between size an quality, harder to explain, then apply, so in your case, anything over 7.5 will be fine (those where suggested).

 

So the good news is, it appears you were able to deinterlace.  

 

Topaz doesn't deinterlce, handbrake (which I keep forgetting about) does deinterlace.  Topaz will ONLY do upscaling.  I see you have another post with question about upscale, so I will answer this part in that thread for you.  

 

But this footage looks better already.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more