Captions: I don't see my subtitles appear in preview (Premiere Pro 14.9 and earlier)

New Here ,
Aug 17, 2018 Aug 17, 2018

Copy link to clipboard

Copied

Hello,

 

I get stuck with subtitles. I know how to make subtitles in Premiere, by using Captions. I know how to Create, Insert and adjust them. But I just don't see them appearing in the preview screen, the "Reference" screen. I tried changing position, color, the type (Pop-on, Roll-up 2 lines,...)

 

Remarkably, I can export them into a separate SRT file and this way I can use the exported media. But it would be nice to see them in Preview.

 

Is there anyone out there that can help me please?

 

 

 

Premiere_Problem.png

TOPICS
Editing, Effects and Titles

Views

35.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Aug 17, 2018 Aug 17, 2018
You can see the captions in premiere pro by enabling them from the program monitor settings as follow -1. Go to the settings icon in the program monitor -2. Go to Closed Caption > Enable and go to Settings (choose the same standard & steam as of the caption your using) - 

Likes

Translate

Translate
Adobe Community Professional ,
Aug 17, 2018 Aug 17, 2018

Copy link to clipboard

Copied

You can see the captions in premiere pro by enabling them from the program monitor settings as follow -

1. Go to the settings icon in the program monitor -

Screen Shot 2018-08-17 at 4.07.30 PM.png

2. Go to Closed Caption > Enable and go to Settings (choose the same standard & steam as of the caption your using) -

Screen Shot 2018-08-17 at 4.07.36 PM.png 

Vishu Aggarwal
Adobe Certified Instructor, Professional and Expert

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2018 Aug 20, 2018

Copy link to clipboard

Copied

Thank you! This actually helped me to solve my problem! I'm very relieved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

Hi There, I'm having a similar issue I created open captions, the settings of the captions and the sequence are the same, however I can't see the subtitles in the program monitor window in order to edit the font. When I click on the wrench the captions are enabled and when I go to settings there is no open captions option, what can I do. 

Thank you!!

2020-01-19 (1).png2020-01-19.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

You appear to have visibility (eyeball) turned off on your subtitle track in the sequence.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

Hi Stan!

The visivility is off only on the english subtitles. I have 2 subtitles files in the timeline, the top one (V3) is the english version wich is off, underneath is (V2) wich is the video file and on (V1) is the spanish captions that I can't see. 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

I can't test at the moment, but I believe that the captions must be above any track, such as the actual video, that will block them. So move them to V4 and see what happens.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2020 Jul 27, 2020

Copy link to clipboard

Copied

Excuse my face on these, but I've tried to add captions for the last hour and everything is set up how it should be (evidenced below) but the captions STILL aren't showing on preview.

Everything matches, everything is enabled, visability is on, the track is above the video, text size is big enough, but still not showing!

 

Please help as it's for a project I need to export ASAP and I'm slowly running out of patience.

 

image.pngimage.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2020 Jul 27, 2020

Copy link to clipboard

Copied

This is odd. I don't recall a report where the captions were visible in the source monitor, but not the program monitor. You don't say specifically, so please cofirm that in the Program Monitor, in addition to the "Closed Caption Display" -> Enable, you also have "Closed Caption Display" -> Settings, set to CEA-708 Service 1. 

 

It is possible to set the Program and Source monitors to different settings, and that would create what you are seeing.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2020 Jul 27, 2020

Copy link to clipboard

Copied

Everything is the correct setting and mirroring each other. They are each CEA-708 Service 1, so I'm baffled myself. I've spend AGES making sure everything matches for it all to be displayed correctly, even the FPS are an exact match.

 

I've pretty much given up now and am having to type it all out with graphics as I'm on a serious time limit, so can't mess around anymore with it.

 

I've added the captions back and screenshotted so you can see the settings both match.

 

image.pngimage.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2020 Jul 27, 2020

Copy link to clipboard

Copied

I see no oddities (e.g. motion affects applied to the caption stream; mismatch in pixel size for some caption types), and the sequence is simple: one track of source video; one caption stream;  nothing on higher layers.

 

Corrupt project is always a possibility.

 

I would try one more test by creating a new test project, create the sequence, create a new 708 stream; see what you have.

 

If you are moving to graphics text, you are burning in, and don't need closed captions anyway. You could also try converting the 708 to Open Captions and see if they work. (You can convert any caption type to Open Captions; you cannot convert Open Captions back to anything; so keep a backup.)

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Did anything ever work for you? I am having the same issue and everyone keeps telling me to change the settings to EXACTLY what I currently have them at. They are in the source monitor and nowhere else. I feel like I am about to go insane. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

I am also experiencing the same thing... any updates on a fix?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

Hi,

I found that my subtitles were not appearing because I had them set in a
different place. Utilize the little boxes to click where the subtitles will
lay on your screen and then play with the font and the color and
transparency to make the subtitles revealed.

I hope this helps,

Shanna

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

Could you explain a bit more what you mean by "utilize the little boxes to click where the subtitles will
lay on your screen". Where are these little boxes? Could you provide a screenshot? Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Zeesy, re "utilize the little boxes to click where the subtitles will lay on your screen":

 

In this image (sorry I didn't have a better one), to the right of the red block, see the little gride of 3X3 boxes? They correspond to areas such as bottom middle, top right, etc.

 

PR 2017.1.4 Caption Panel Open Caption.PNG

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

@shannafuld, could you explain a bit more what you mean by "utilize the little boxes to click where the subtitles will lay on your screen". Where are these little boxes? Could you provide a screenshot? Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

After you done with subtitles delete from timeline and then drag the
caption from material and put it back to timeline... Then the preview
showing up... Hope it works for you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2020 Sep 29, 2020

Copy link to clipboard

Copied

This is what ended up working for me after nothing else did. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

I am experiencing similar issues. I was finally able to get the captions to appear once I create a new sequence with different footge in it, however the captions look weird, as if the kerning is very wide and I can't change it.

 

captions.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

That is a closed caption type stream; is that what you want?

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

LATEST

I had this problem and I tried all these remedies but all failed, then I let the computer start to render the export then after it had I cancelled the export and the titles magically appeared in the preview window. Kinda odd but glad its working. Yipeeee

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

I am having simmilar issues, and could use some clarification from some of the successful methods.

More details from @Rinx91 and @shannafuld would be helpful. I am trying to transfer subtitles that have been edited from multiple srt files into v5, and consolidate them into a single caption track on v6:

Zeesy_0-1612114397764.png

CEA-608 CC1 (v5) is one single caption track, that has been cut and rearranged into segments based on my edit. If I delete any single caption from the track, it is deleted from all instances and I cannot use it elsewhere. The orange srt track is an srt from a translator (v5). It is not visible when I export, even though it is visible in the project monitor. CEA-608 CC2 (v6) is a new track where I want to create one single captions track with all of my edited captions in order. When I paste in a single caption into this new track, it is not visible. All clips and tracks are set to visible under "Closed Caption Display" -> Enable, and each has been set to the appropriate setting and stream under "Closed Caption Display" -> Settings. As you can see from the screenshot, all timeline tracks are set to visible. I am able to change the text font, colour and background colour in the captions window, but they are only visible for v5. v6 appears coloured in the captions preview window, but is not visible in the source monitor:

Zeesy_1-1612115267924.png

Any advice would be much appreicated, especially with specifics on where settings are located and/or screenshots. If external software is required, a link would be very helpful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

Zeesy, you can combine some caption streams by exporting the srt. Then reimport.

 

However, my quick test indicates that you cannot mix Open and Closed 608 (or probably anything else). Also, you are not seeing some of the closed captions because you cannot have more than one service type visible at the same time.

 

But you can convert the closed caption 608 stream(s) to Open Captions. What you want is all Open Captions on one track. If you have captions on other tracks, disable those tracks. Then select the Sequence in the Project Panel, and File -> Export -> Captions - as srt. Import that srt back to the project and put in on whatever track you want.

 

What is your goal? Burned in? Sidecar export?

 

Stan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Hi - My subtitles aren't appearing, and I have already checked "enabled" in the settings and I selected "Open Subtitles." Still no subtitles. What else can I try?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines