Captions Text Poor Quality

Community Beginner ,
Dec 09, 2018 Dec 09, 2018

Copy link to clipboard

Copied

Hello,

I'm working on the project where I need to create Subtitles and I was using Captions. The problem is that the text comes quite poor quality with really hard edges. I was browsing the internet to find a solution and found quite a few issues like that but no solution. I have a screen-grab where the top text is the captions and the lower is the standard title but the same font and size was used. You can see the difference and just wonder if there are any settings I can change to show captions as nicely as the title?image.jpg

Views

8.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2018 Dec 09, 2018

Copy link to clipboard

Copied

Does the caption stream pixel size match the sequence size?

What specific dot version of PR are you running?

At 200%, my matching captions still show antialiasing, but not as badly as ones that are a smaller pixel size than the sequence. I wonder if that is it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2018 Dec 09, 2018

Copy link to clipboard

Copied

I run CC 2019 and the sequence and the captions the same settings exactly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2018 Dec 09, 2018

Copy link to clipboard

Copied

Mmm. Not sure what to say. It does appear difficult to get an appearance that will handle any upscaling. I certainly see antialiasing.

What font, size, etc.? No edge, correct?

Try Arial as a comparison. Yours appear to be sans-serif, but with a descender (J).

Curious whether some fonts work better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

It's he same with any font to be honest. I spoke to Adobe yesterday and been advised to install CC 2018. Did the test and I get exactly the same results. They of course blamed my computer that it's not powerful enough but if it would be computer the titles would appear exactly the same with hard edges. As titles showing fine and captions not I assume it's some kind of bug as I found few forums and the same problem on the internet.

Really frustrating as it's really good feature for subtitling but I can't use it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

Doing subtitle in Premiere is really nerve wrecking. I would recommand doing captions in another software (unless you want to "burn" them into the video, for which I would recommand using the standard text tool).

The captionning tool is one of the last area that is lacking in Premiere, and has not been updated for a long time. I've lost countless hours on it.

There are a lot of captioning tools, some of them are free like Subtitle Edit, where you'll be able to create good looking subtitles.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

yenaphe  wrote

The captionning tool is one of the last area that is lacking in Premiere, and has not been updated for a long time. I've lost countless hours on it.

There are a lot of captioning tools, some of them are free like Subtitle Edit, where you'll be able to create good looking subtitles.

Good point. I don' t disagree that the current state of captioning in PR results in frustration, but there have been changes in several of the 2017-2019 builds as well as some bug fixes. Part of the problem in this thread is regarding burned in "subtitles." Subtitle Edit (which I like very much) is no help, because it does not help when it comes to interpreting the text/background onto the video. PR's subtitles look just as good as Subtitle Edits when displayed in a player like VLC.

Going forward, I wonder whether the better feature request is to get better text resolution in captioning, or better captioning in the graphics text tools.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

I recently did 24mins of subtitling video and I used simple titles which was the pain as I had to copy/paste texts every few words and I ended up with a huge pile of text files in Project Area. I used CS5 at the time. Then I thought it should be a better way and after watching some tutorials on creating captions I decided to upgrade to Cloud version and now I can't even use it. Hopefully Adobe will fix it.

Thank you for all your comments.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

I get the same results you do: graphics text: nice and clean; Open Captions text: pixelates easily.

I'm wondering if it is related to being placed on a background (even with background opacity set to zero). And we have no direct control over the pixel resolution of the text.

Try this. Modify the captions stream so that it is higher resolution. I switched from my 1920x1080 sequence setting to 3840x2160. You'll need to position the caption to the middle to see it. Then change text size to what you need. Position using Effect Controls panel.

In either resolution, I think it looks a little better with a 2 pixel black edge on white with a black background.

Part of the point to Open Captions is to burn in. And crisp text matters.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

any fix here yet? I have the same problem, however on mac it works great? Is this a Windows problem only?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

kjetilw70676393  wrote

any fix here yet? I have the same problem, however on mac it works great? Is this a Windows problem only?

No fix. See this other thread for another workaround that I could not replicate.

Re: Premiere CC Open Captions - Poor rendering (aliasing)

Are you saying that you have confirmed that Mac's do not show poor burned in quality using the captioning tools?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2019 Feb 01, 2019

Copy link to clipboard

Copied

Yes I am very sure, I will provide an example in around 10 days! (going on vacation next week)

edit: I could also not replicate the workaround, setting opacity to 100% gives better results tho!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2019 Feb 01, 2019

Copy link to clipboard

Copied

Enjoy!

Thanks for the info.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Hello!

I just saw your posting about poor quality of captions. Having the same problems here, I found a solution that worked for me, and I hope it's working for you as well (Premiere CC 2019, Windows)

Here is what I've done:

Display a video with captions in the program monitor window and zoom to 100% (to see the difference clearly)

Go to the project panel and select the Tab for the captions

Right click on one of the captions and choose "select all"

click the button for text edge color

go to the input box for opacity (0-100%) and type "1"

The value "0" will cause the issues for the text. Maybe this depends on the graphics card. In my case (nvidia gtx 970 and 1060) the value "1" solved the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Interesting. And yes, improved - not regular graphics text quality, but much better.

What Edge value and color are you using? With edge zero, when I changed edge opacity, the edge value jumped to 5.8. Then I was able to reduce it.

I used Arial as the caption font, white text color, matching (white) edge, black background at opacity 100% and 0%.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Hi Stan!

I've found that both the edge opacity value of "0" and the edge value of "0" causes the poor quality of the text.

So if you don't want any edge effect you can work with the "1" value because the effect is not visible.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

What font were you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Font doesn't matter, I tried different ones.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Good.  When I get around to testing iths further, I wanted to make sure I tried the one you had used. I'll also use several.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2019 Sep 25, 2019

Copy link to clipboard

Copied

Genius! Worked for me. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2019 Oct 03, 2019

Copy link to clipboard

Copied

Thank you so much, after hours of research your solution fixed it for me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2020 Apr 21, 2020

Copy link to clipboard

Copied

Thank you! After hours of irritation, searching and watching Youtube from A-Z your solution worked! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2020 May 18, 2020

Copy link to clipboard

Copied

Same issue here on all up to date windows machines. As mentioned, does not seem to be present on macs running older versions of premiere!

Setting text edge colour to 1 instead of 0 has worked for me, so thanks a lot burkhards94611469

This does add a new problem if you have any background colour however. As soon as you set the Text Edge Colour to 1, the background box no longer centralises on the text. 0 centred, 1 not.

Really very annoying, might start a fresh thread on this one. But great work for getting us a step closer. This one has been an issue for a while for anyone running latest version on PC, and from my investigation so far anyone running past version 13 on Mac also.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

Hi guys,
I have the same problem under win10 and premiere pro. Open caption are aliasing like hell... Any fix ? Is this real that Mac doesn't have the issue ? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Hi guys, 
I think, that I have a solution for that. It could work. Try it.
If you have a white color subtitle (100%) --> use the blending mode to "Screen" for the Subtitle.
If you have a black color subtitle (100%) --> use the blending mode of it to "Multiply" for the Subtitle.
In my case it works. 🙂 

Best regards
Orhan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines