Choppy 4k timeline playback

New Here ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

Hello all!

I want to start by saying I have never had any formal training in Premiere Pro. I have basically just learned as I go. I have always been able to scour the web and find any answer I may be looking for. I am stumped with this one, and haven't found any good information that pertains to my specific situation. Please go easy on me!! I promise I spent quite a bit of time trying to find a solution before posting here and potentially wasn't someone's time.

I just purchased a new camera to use for my YT channel. I am going from a Nikon D3300 (shooting 1080p60) to a Panasonic Lumix G7 (shooting 4k30 100Mbps). My playback in the timeline and just scrubbing in general is incredibly choppy. I had this issue previously with my 1080p60 footage from the Nikon before upgrading my computer.

My current setup:
i7-7820x Skylake X (OC to 4.7GHz)
Aorus X299 Gaming 7
32GB G.Skill TridentZ @ 3000MHz

Nvidia GTX 1080 Founders Edition
EVGA Supernova G3 750w PSU
OCZ RD400 PCIe NVME M.2 SSD (media/scratch drive)
Crucial MX300 SATA3 M.2 SSD (OS drive)

When I play any 4k footage back that is sped up (time-lapse style of me doing something) or with a transition or effect applied to it, it is super choppy. Initially my CPU usage pegs at 99% for a second or two and then it goes back down and jumps between 60 and 80 percent (footage is choppy the entire time). Sometimes the CPU won't peg and it will hit a max of like 87% and then drop back down (footage also choppy the entire time). My disk usage is basically at 0-5%, and my GPU usage is 0-11% depending on the scene I am playing back. Also, I want to add that even if I change my playback resolution to 1/8, it does not help. I feel like I have to be missing something because my computer should be plenty powerful enough, but maybe I am wrong. Any suggestions or tips would be greatly appreciated! I have already tried everything in this link and it has not helped.

10 Tips to Improve Playback in Adobe Premiere Pro — Premiere Bro

Views

1.7K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jul 25, 2017 Jul 25, 2017
A bit naive ... but you've got a decent rig there, so you'd think it was great to go. Well ... 4k interframe media is just nasty in an NLE or grading app.To get better performance with it, in the Media browser panel check the "Ingest" box, and click the wrench icon next to it. Set things for "Creating Proxies" on ingestion, and select one of the Cineform presets.Then for all future projects, when you ingest media into PrPro, it will start by creating the proxies for you. For this project, you'll...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

That G7 shooting 4k/30fps at 100Mbps is in what ... mp4, mov, or AVCHD? It is probably long-GOP which especially in 4k is a right bear on the CPU/RAM/cores/threads subsystem. An order of magnitude harder than 1080 media of the same type.

So yea, you start building effects & especially with time-ramps, reverse, warp stabilizer & Lumetri, your computer is going to probably choke.

That's what the proxy-on-ingest process is for. Don't be rude to your gear, you know?

I know colorists with past ten grand of computer gear on/under their workstations, who proxy all interframe long-GOP media.

Use a Cineform preset for the proxies ... remember, you want an intraframe codec which will produce larger file-sizes but edits sweet. You DON'T want some H.264/5 interframe codec for proxies.

Neil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

Neil- Thank you so much for your response! The files coming off of my Lumix are actually mp4. I went in and set the playback to Cineform (YUV 10-bit). It was initially on "I-Frame Only MPEG". As for the rest of my sequence settings, under video previews I have unchecked the following boxes as well:

-Maximum bit depth

-Maximum render quality

-Composite in linear color

This hasn't seemed to change much, if at all. I did noticed that when I am not working with sped up footage (8x speed), I don't seem to have any issues for the most part. Have I just underestimated the amount of processing power for what I am working with and doing? I felt like I surely must have missed something, and that my computer would do fantastic for anything I wanted to edit in 4k. I think I may have a very naive outlook on this?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

A bit naive ... but you've got a decent rig there, so you'd think it was great to go. Well ... 4k interframe media is just nasty in an NLE or grading app.

To get better performance with it, in the Media browser panel check the "Ingest" box, and click the wrench icon next to it. Set things for "Creating Proxies" on ingestion, and select one of the Cineform presets.

Then for all future projects, when you ingest media into PrPro, it will start by creating the proxies for you. For this project, you'll need to select your media in the Project panel, right-click, and select "Proxies/Create Proxies".

Also, go to your Program monitor, click the big + icon to bring up the control icon options for that panel, and hovering over the available options, when you see "Proxy" on the one, drag it onto your control area for the Program monitor. Then you simply click it to make it blue, and your computer is playing back using the proxy media ... much easier. Click it again to turn it 'off' and it's gray, you're using the original media.

PrPro will always export using the original media except for one rare situation you won't encounter unless you know about it and want to.

Neil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2017 Jul 25, 2017

Copy link to clipboard

Copied

You sir, are a gentleman and a scholar. I greatly appreciate that tip. I messed around with proxies after reading your first reply and the proxies have ZERO issues during playback (obviously). My next (and final) question is, what are the downsides of editing this way? Just not seeing the media in it's full resolution? I guess I just don't understand why everyone doesn't use this OR maybe they are, and I was just clueless on the subject. haha

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2017 Jul 26, 2017

Copy link to clipboard

Copied

The only downside is ... you're right, not seeing 'full' media during editing. But when slapping on and adjusting transitions, do you really need to see everything in 28k?

Oh ... the other ... proxies don't currently handle time-ramped media well, I think. So that's something it would be nice to get fixed in another release. Currently for I think it's time-ramped, reversed, and warp-stabilized clips, it's still needed to render those to previews.

Neil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

I had choppy video issues with 4k video.  Switching from Nvidia Studio Driver to the Game Ready Driver fixed the issue. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

Switching from Nvidia Studio Driver to the Game Ready Driver fixed the issue. 

That's unexpected, usually it's other way around. What about version, was it the same? Different release is most likely reason, not 'studio' vs 'game' edition

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines