Chroma Key looks good in After Effects but BAD back in Premiere Pro (Dynamic Link)

Explorer ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

After getting a GREAT looking chroma key in After effects via Dynamic Link, when the clip is previewed back in Premiere Pro the video looks like white and noisy, like the background is ghosting through or something

Why is the Chroma key in Premiere Pro looking so bad but perfect in After Effects?

Am i doing something wrong?

 

background ghosting premier pro.png

 

TOPICS
Editing, Effects and Titles

Views

66

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Feb 17, 2021 Feb 17, 2021
This has been solved in the other thread. It was being caused by Premiere Pros "Linear Light" in Sequence Settings. I unticked it and ghosting disapeared. https://community.adobe.com/t5/after-effects/chroma-key-looks-good-in-after-effects-but-bad-back-in-premiere-pro-dynamic-link/m-p/11839856#M162683

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Post screenshot sequence settings.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Here are the sequence settings for Premiere Pro

 

sequence settings premiere pro.png

 

Here are the Coposition setting in After effects (if needed)

 

composition settings.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Ok so after more testing i have an update.

If i apply a white solid background in AE, the preview in PP looks good.

But if i apply the white background in PP (leaving the background transparent in AE), that white background in PP seems to come through the keyed out subject.

I directly exported a clip  with alpha channel from AE. when playing the video in VLC also looks good, BUT if i take that same export and add to PP same problem, the white background starts to affect the image. strange.

 

background ghosting problem.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Ive created a MORE DETAILED reply in the after effects forum, though i think the problem is with PP

 

https://community.adobe.com/t5/after-effects/chroma-key-looks-good-in-after-effects-but-bad-back-in-...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

This has been solved in the other thread. It was being caused by Premiere Pros "Linear Light" in Sequence Settings. I unticked it and ghosting disapeared.

 

https://community.adobe.com/t5/after-effects/chroma-key-looks-good-in-after-effects-but-bad-back-in-...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines