Clip FX Editor keeps opening when I click on timeline clips

New Here ,
Aug 30, 2017 Aug 30, 2017

Copy link to clipboard

Copied

Every two or three times that I click on an audio clip in the timeline, the Clip FX Editor - Multiband Compressor window opens right in front of what I'm doing. All the clips have the multi band compressor applied. I have to close the window every time so that I can make the edits I want. It's driving me mad. Anyone have a solution?

Views

3.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 31, 2017 Aug 31, 2017

Copy link to clipboard

Copied

Single or double clicking?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2017 Aug 31, 2017

Copy link to clipboard

Copied

Single click. I only happens about half the time. Even if I move the window instead of closing it, it'll pop back up blocking my timeline again after a few more clicks on audio clips.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 31, 2017 Aug 31, 2017

Copy link to clipboard

Copied

OK.

Are you (perhaps unwittingly) clicking on the FX badge?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Definitely not what's happening, although I suspected at one point that's what I was doing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

I found no solution. But randomly, the issue has 99% disappeared this week. I have no idea why. Really annoyed that you can't park these FX windows in a spot and keep them there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Did you find a solution? I'm having the same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2017 Sep 15, 2017

Copy link to clipboard

Copied

I have the same issue.  Clip FX editor is new.  I went onto chat for help and the best thing we can do is remove the effect, edit as normal and then add the effects after all cuts have been made.  Not a great solution by any means but it might suffice until they can figure it out.  I haven't tried this yet but we could try editing the clip in Adobe Audition (add the same effects) and then go back into Premiere and edit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 10, 2018 Jan 10, 2018

Copy link to clipboard

Copied

This still p**ses me off. Whenever 'Selection follows playhead' is selected this happens. Seems like clunky design to me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 10, 2018 Jan 10, 2018

Copy link to clipboard

Copied

Seen this too, quite annoying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

Honestly the best way if you're applying the same effects to multiple clips and going about your edit with this pop up issue (like I am frustratingly so... ugh) then

- I'd select one of the many clips with the same effect

- close the clip fx window

- select the click and copy it

- paste attributes to all clips you want to have that same effect.

This will paste the same audio processing you had from before but with a "closed" clip fx. I have no idea why we can't just turn off the clip fx editor except for when we need it, or why it doesn't have its own window that is not in front of your dang time line when you're trying to work.

It's all about workflow and apple does the same stuff, with all the floating windows all over the place.  When editing it's important to SEE the action and SEE the sounds in your visuals, so why y'all making it so hard to SEE our work!? ❤️ you Adobe! Been with you for years.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2018 May 27, 2018

Copy link to clipboard

Copied

Has anyone found a solution to this yet?

I am working on a sound mix with a hard deadline and this is driving me insane! Went to reach out to Adobe but customer service is all shut down.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2018 May 27, 2018

Copy link to clipboard

Copied

Since the initial post we have moved on several versions.

Have not seen this lately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2018 Jun 30, 2018

Copy link to clipboard

Copied

This is still going on here, no idea what to do. This is terrible! HEY Mr. Adobe? where are you to fix this?

[profanity removed by moderator]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 16, 2018 Jul 16, 2018

Copy link to clipboard

Copied

Why can't Adobe design it so you can dock the clip FX window or at least have it pop up somewhere other than right in front of what you are doing?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 17, 2018 Jul 17, 2018

Copy link to clipboard

Copied

You can turn the FX off: wrench timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

I have the same issue with 12.1.2. I know this thread is a year old, but is there any solution for this? There is nothing in the sequence wrench settings that fixed the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

That turns off the fx  badge on the audio clips next to the clip name.

When you select an audio clip with f/x on it, the f/x GUI pops up in the middle of the monitor. Convenient sometimes but it gets in the way other times!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

Well its either off or on and watch where you click.

Expand the tracks so you have room to click.

Have you tried trashing preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2019 Jun 03, 2019

Copy link to clipboard

Copied

Thanks Ann!

So you are saying when you turn off fx badges, the audio f/x GUI will not pop up on your screen?

In the first pic, Fx badges are off. No clip is selected so the GUI isn't open. In the second pic an audio clip is selected and fx GUI pops up!

I want the ability to disable and enable that GUI popping on.

I will try trashing prefs.

Screen Shot 2019-06-03 at 2.05.25 PM.png

Screen Shot 2019-06-03 at 2.05.50 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 18, 2019 Aug 18, 2019

Copy link to clipboard

Copied

Driving me crazy too.... But after reading the earlier comments in this thread, I found the solution event though people still seems to have this problem? Make sure you have the effect-window CLOSED before copying it. The open/closed seems also to be a parameter that will be copied/pasted.

If you paste closed FX-windows, you will have closed FX-windows. And the opposite way around.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2019 Oct 08, 2019

Copy link to clipboard

Copied

If you disable the track targeting for the audio; so for example if this multiband compressor is on an audio clip on track 'A1', disable A1 and it will stop doing this.

 

Not the most ideal method in case you need track targeting but it does the job!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2020 Jan 06, 2020

Copy link to clipboard

Copied

When scrolling through the timeline with "Selection Follows Playhead", the Clip Fx Editor pops up constantly, but I noticed that if you move this window to a different area for a clip, it will remember that area for that individual clip. So if you move the Clip Fx Editor to another screen, and then copy that and paste the audio effect on other clips, it will pop up on the other screen always.

 

In combination with what david_bicho posted earlier, the best method would be:

1) Add the audio effect and make the adjustments for one clip

2) Move the Clip Fx Editor to a part of the screen (or another screen) where you are okay for it to pop up

3) Click the red button to close the Clip Fx Editor

4) Then copy the clip

5) Choose "Paste Attributes" and paste your effect on successive clips where you want the audio effect to be applied.

 

This way, by default the Clip Fx Editor won't pop up, but when it does it is in a part of the screen that won't cover up your timeline or other critical parts of the editing interface.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2020 Sep 10, 2020

Copy link to clipboard

Copied

So there's NO way to turn it off? B/C this last suggestion is not working. It pops up right where I'm working EVERY TIME.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines