Highlighted

Color Shift on Export

Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

Hello,

I'm using Lumitri Color on a clip. When I export it, the color does not match the program monitor.

Doesn't matter if I export h.264 or ProRes. Or if I export directly from the program, or with Media Encoder. The result is the same.

In the screenshot, the left window is the program monitor, the right is in adobe AME.

Screen Shot 2018-06-22 at 3.22.07 PM copy.jpg

OK I think I got it!

I set my Display Profile, in Color setting Display in System Preferences to "HD-709-A"

This seemed to only effect the color outside of Premiere, meaning all other applications and OS X color, into a properly saturated space. So now video displayed in Program monitor, and in exports viewed in QT player, matches.

On the HP monitor settings, (accessed directly via the monitor itself, not system prefs), its still set to BT709.

Does this mean that: Premiere is bypassing the color profile assigned to OS X via System Preferences, and is sourcing its color profile directly from the monitor. And that by assigning a HD-709-A profile in system prefs, its properly saturating color in the rest of OS X, to match the wider gamut on the monitor?

Does that make sense?

Is HD-709-A the right choice to match the monitors BT709 profile?

Thanks!

Views

7.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Color Shift on Export

Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

Hello,

I'm using Lumitri Color on a clip. When I export it, the color does not match the program monitor.

Doesn't matter if I export h.264 or ProRes. Or if I export directly from the program, or with Media Encoder. The result is the same.

In the screenshot, the left window is the program monitor, the right is in adobe AME.

Screen Shot 2018-06-22 at 3.22.07 PM copy.jpg

OK I think I got it!

I set my Display Profile, in Color setting Display in System Preferences to "HD-709-A"

This seemed to only effect the color outside of Premiere, meaning all other applications and OS X color, into a properly saturated space. So now video displayed in Program monitor, and in exports viewed in QT player, matches.

On the HP monitor settings, (accessed directly via the monitor itself, not system prefs), its still set to BT709.

Does this mean that: Premiere is bypassing the color profile assigned to OS X via System Preferences, and is sourcing its color profile directly from the monitor. And that by assigning a HD-709-A profile in system prefs, its properly saturating color in the rest of OS X, to match the wider gamut on the monitor?

Does that make sense?

Is HD-709-A the right choice to match the monitors BT709 profile?

Thanks!

Views

7.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 22, 2018 0
Adobe Community Professional ,
Jun 22, 2018

Copy link to clipboard

Copied

First thing is go into Me's Preferences and uncheck "import sequences natively".

Second, to check the export properly, check the "import into project" button in the PrPro export dialog,  and compare the sequence and the export in the Program monitor.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

Thanks Neil.

So I brought back my exports into Premiere, and compared them in the program monitor, and they all match. Furthermore, the H264 export matches what I see in premiere when I open with VLC.

But when I open with Quicktime, Quicktime 7, or upload to YouTube, viewing in Chrome, the color is shifted in the same way.

I unchecked "import sequences natively", didn't seem to change anything.

I'm using a new machine. I've never experienced this on other machines.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

I think I'm having this problem: CreativeCOW

yikes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Adobe Community Professional ,
Jun 22, 2018

Copy link to clipboard

Copied

PrPro works internally in, and as best as possible displays Rec709 b-cast standards for color/tonality. It is internally color managed though it doesn't allow user options.

Quicktime is infamous for being color stupid and the only browser that pays attention to color space information in video playback is Firefox.

Rec709 is designed as color profile of sRGB at gamma 2.2. Many monitors especially on the newer Macs are say profile of something close to P3, so you can get a quick mismatch outside of a color aware app with such monitors.

YouTube can be bizarre. All my uploads properly display color/gamma, for many users they don't if uploading in H.264.

You can get around that 2 ways ... export in DNxHD/R which will be bigger files but YouTube does take, or use H.264 but after uploading go to your controls in YouTube and select the video and "retouch". Don't do anything just save, and in an hour or so it will re-encode your video properly.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 2
Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

Thanks. I will look into those options.

What I'm doing currently is I used a viewling lut from that cretive cow post, on an adjustment layer over my footage, to correct the look of the program monitor, to match the quicktime player and youtube color.  then just turn off the adjusment when exporting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
LEGEND ,
Jun 22, 2018

Copy link to clipboard

Copied

I think Jamie LeJeune has it right in the following thread from the Blackmagic forums.  He's specifically talking about Resolve, but the idea holds true for all NLEs.  The upshot is, "The only image you can trust is to run SDI out to an accurately calibrated reference monitor."

http://forum.blackmagicdesign.com/viewtopic.php?f=21&t=68410

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Explorer ,
Jun 22, 2018

Copy link to clipboard

Copied

But this isn’t about color consistency between different screens.... I’m

taking about within my own computer. It shouldnt be a tall ask, and require

SDI hardware or whatever, to except that what I see in premiere is what I

will get when what I export. The difference is massive in what I’m seeing.

To try and get color to match from my screen to the millions of other

Screen on the planet, yeah, that should be complicated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Adobe Community Professional ,
Jun 22, 2018

Copy link to clipboard

Copied

Even on your own computer you are dealing with apples and soccer stadiums. Until you understand what actually is going on, you will try every wrong thing in the book.

Been there done that and wasted a lot of my time and others. So I try to help folks move past that.

So you can just do your work, and *know* it will be correct.

What color space is your monitor set to? Do you profile with a puck & software combo at least? What gamma does your monitor run natively? What white point?

What color management is set in your OS?

That's a start. And until you know that, and why it matters, you can't get control.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Explorer ,
Jun 25, 2018

Copy link to clipboard

Copied

OK thanks a bunch for helping out with whatever you can.

So my monitor is a HP Z32x monitor. My display profile is set to "HP Z32x", which I'm assuming means the monitor is handling the color? My monitor is set to "AdobeRGB (D65)" color profile.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Explorer ,
Jun 25, 2018

Copy link to clipboard

Copied

And currently, If I place an adjustment layer as a viewing LUT atop all my footage, with a P3 to rec709 conversion input LUT set,  it fixes the issue.

I would prefer to not use the conversion LUT...is this messing with my footage?

Also, the issue is happening on both footage with Lumetri effects applied, or just straight unedited footage.

Generally speaking, the image in Premiere is more saturated.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Adobe Community Professional ,
Jun 25, 2018

Copy link to clipboard

Copied

Set that beautiful puppy to the BT709 setting, according to the pdf that I've just read. That's ... a rather nice bit of gear.

What's your OS?

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Explorer ,
Jun 26, 2018

Copy link to clipboard

Copied

Yeah seems like a great monitor, once I can get it working!

I set the monitor to BT709. Which immediately made everything much less saturated. Video inside of Premiere looks normal.

But the mismatch is still present when I export out of premiere and view the QT file in Quicktime Player. It is properly saturated in Premiere, and undersaturated in QT player. But If I bring the QT file back into Premiere and view it in  the Source Monitor, it matches what I see in the sequence in the Program Monitor.

Is there something I need to change in my system preferences? It looks like everything on my computer -- except what I'm seeing in the Program monitor in Premiere -- is much less saturated than it should be. The OS, webpages in Chrome, system icons, everything... unsaturated and darker than on any machine I remember using.

It seems like Premiere is now letting the monitor handle the color properly, but everywhere else on my computer, including playing a video in Quicktime, is undersaturated.

I'm running OS X Sierra 10.12.6

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Adobe Community Professional ,
Jun 26, 2018

Copy link to clipboard

Copied

QuickTime player is infamous for it's poor color management. DO NOT every use that to check video quality. And the only browser that is color-aware is Firefox, neither Chrome nor Safari are.

If you want a player on your computer outside of PrPro, check with VLC or PotPlayer.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Explorer ,
Jun 26, 2018

Copy link to clipboard

Copied

OK I think I got it!

I set my Display Profile, in Color setting Display in System Preferences to "HD-709-A"

This seemed to only effect the color outside of Premiere, meaning all other applications and OS X color, into a properly saturated space. So now video displayed in Program monitor, and in exports viewed in QT player, matches.

On the HP monitor settings, (accessed directly via the monitor itself, not system prefs), its still set to BT709.

Does this mean that: Premiere is bypassing the color profile assigned to OS X via System Preferences, and is sourcing its color profile directly from the monitor. And that by assigning a HD-709-A profile in system prefs, its properly saturating color in the rest of OS X, to match the wider gamut on the monitor?

Does that make sense?

Is HD-709-A the right choice to match the monitors BT709 profile?

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Explorer ,
Jun 26, 2018

Copy link to clipboard

Copied

To be clear, everywhere I view my video now looks the same: in premiere, uploaded to YouTube, QT player, VLC...

So this isn't an issue with the specific programs, its about how color passes through to monitor from OS X vs Premiere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Adobe Community Professional ,
Jun 26, 2018

Copy link to clipboard

Copied

To answer the last statement, yes.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 1
New Here ,
Jan 14, 2020

Copy link to clipboard

Copied

Hi a little late to this thread but hoping to get answers still. I have an older system and dont have the HD-709A in my system pref under the display section. Any other reconmendations? Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2020 0
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

Late answer to your question too 😛 Maybe you solved this already, but Apple changed the name of the color profile. It's now called Rec.709 Gamma 2.4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 1
New Here ,
Aug 27, 2020

Copy link to clipboard

Copied

I'm late to this, but here's what was causing my color shift: hardware encoded exports were shifting my colors. When I changed the setting on export to software encoding, colors stayed the same.

 

I noticed it when I had a project that used motion graphics. The motion graphics were being software encoded, while the rest of the project was being hardware encoded. By forcing the whole render to software encode, the issue was solved. And I'm happy with the colors.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2020 1