Highlighted

CUDA GPU is Enabled but Premiere only uses CPU

New Here ,
Nov 21, 2020

Copy link to clipboard

Copied

Hello there, I've been trying to fix the issue for about 4 days now. I tried absolutely everything I can. (reinstall Premiere, Installed and Re-installed Drivers, etc.) and I don't think anything is wrong with my system. I searched other posts about this, nothing helped in my situation, tried everything with CUDA posts, but the issue still remains. I have CPU AMD Ryzen 7 2700 and GPU GTX 1070Ti, when i'm editing my playback is just frozen at times. I checked what is being used to process this, and my CPU is at 100% when GPU is at 0%. And it's not like I'm adding 100 effects or something crazy like that, every project that has atleast 1 nested sequence or 1 effect is not playing back to me, only if I render it (1080p), and Hardware Encoding is enabled but GPU usage is 0%, CPU 100%. Mercury CUDA is enabled, premiere uses ONLY CPU. When i'm using a 3D program Blender it has CUDA aswell, and it works perfectly fine, uses both CPU and GPU, but premiere is acting like there is no GPU! Because of this problem, i can't finish my projects, the issue is that I can't see what i'm even doing! I am confused, please help? Heres a video what exactly is going on: https://www.youtube.com/watch?v=HUXo8wcAX18

TOPICS
Editing, Error or problem, Freeze or hang, Hardware or GPU, Performance

Views

141

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CUDA GPU is Enabled but Premiere only uses CPU

New Here ,
Nov 21, 2020

Copy link to clipboard

Copied

Hello there, I've been trying to fix the issue for about 4 days now. I tried absolutely everything I can. (reinstall Premiere, Installed and Re-installed Drivers, etc.) and I don't think anything is wrong with my system. I searched other posts about this, nothing helped in my situation, tried everything with CUDA posts, but the issue still remains. I have CPU AMD Ryzen 7 2700 and GPU GTX 1070Ti, when i'm editing my playback is just frozen at times. I checked what is being used to process this, and my CPU is at 100% when GPU is at 0%. And it's not like I'm adding 100 effects or something crazy like that, every project that has atleast 1 nested sequence or 1 effect is not playing back to me, only if I render it (1080p), and Hardware Encoding is enabled but GPU usage is 0%, CPU 100%. Mercury CUDA is enabled, premiere uses ONLY CPU. When i'm using a 3D program Blender it has CUDA aswell, and it works perfectly fine, uses both CPU and GPU, but premiere is acting like there is no GPU! Because of this problem, i can't finish my projects, the issue is that I can't see what i'm even doing! I am confused, please help? Heres a video what exactly is going on: https://www.youtube.com/watch?v=HUXo8wcAX18

TOPICS
Editing, Error or problem, Freeze or hang, Hardware or GPU, Performance

Views

142

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 21, 2020 0
Adobe Community Professional ,
Nov 21, 2020

Copy link to clipboard

Copied

When your timeline shows a red render bar you first need to render for smooth playback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2020 0
New Here ,
Nov 21, 2020

Copy link to clipboard

Copied

Yes. But, most of the time it shows red. And if I render it, and change something, you need to render it again which takes a lot of time. Is it really the only solution to this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2020 0
Adobe Community Professional ,
Nov 22, 2020

Copy link to clipboard

Copied

Post screenshot sequence settings and clip properties.

Guessing you are using an effect that is not gpu accelerated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2020 0
New Here ,
Nov 23, 2020

Copy link to clipboard

Copied

I didn't understand what you mean about clip properties. Sequence properties: 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Community Professional ,
Nov 23, 2020

Copy link to clipboard

Copied

Resolution of the images you have used on the timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Community Professional ,
Nov 22, 2020

Copy link to clipboard

Copied

Is everything setup 100% correct? The video below might be helpful.



Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2020 0
New Here ,
Nov 23, 2020

Copy link to clipboard

Copied

Yes, pretty much it's the exact same as in the video, but my GPU just doesn't want to work in premiere. I'm kind of new to Premiere because I changed softwares, and its turns out that some effects use CPU and others use GPU which I just don't understand.. But still my Premiere only prioritizes CPU. As I said i tried everything I can, just doesn't work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Engaged ,
Nov 22, 2020

Copy link to clipboard

Copied

How is your playback if you turn off the noise?

Are you using high-resolution texutres?

What is the size of the sequence "123"?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2020 0
New Here ,
Nov 23, 2020

Copy link to clipboard

Copied

It's the exact same

Yes they are high-res, but I used these textures before in another software and my performance was smooth
It's 1080p 60 fps (if that's what you mean)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Community Professional ,
Nov 23, 2020

Copy link to clipboard

Copied

Please post screenshots as requested.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Engaged ,
Nov 23, 2020

Copy link to clipboard

Copied

So: you are not using any effect (turning off noise doesn't change anything). Most probably that "123" is not optimized well, and I think your problem is related somehow to those high-res textures, after all, if those run smoothly outside of Pr doesn't mean that those will run smoothly in Pr.

It's hard to guess exactly what's happening without seeing the actual timeline of "123", I will suppose that you are not using any effects on those textures as you said (but those textures are gray in the project window and blue in your timeline!?), so my advice is to crop those textures in Photoshop to 1920x1080 and colorize those before importing into Premiere and see if the problem persists.

Personally, I suspect that you are using effects on those high-res textures which may cause the playback problem ( crop or scale down those in Ps if this is the case)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0