Highlighted

Encore compiling error because of pop-up menu

New Here ,
Feb 13, 2019

Copy link to clipboard

Copied

I created dozens of blu-rays, always with the same pop-up menu template.

Only the background and buttons are changed from project to project.

But this time the blu-ray built crashes and I get an error message saying:

"code 6", "Graphics buffer underflows" - Failed to multiplex with maximum IG PTS: 54900000 (in 90kHz)

error.jpg

I searched the forums. Seems like I am not the only one and no one found a soluton.

The photoshop file has exactly the same dimensions and dpi like all my other pop up menu pages. But it doesn't work this time. I can't figure out why but I know the problem is caused by the pop up menus because when I delete the pop-up menu from the project the built works.

I also started from scratch and renamed the files etc.

When I start from scratch and just import a movie file and set the pop-up menu it works. But as soon as I link a chapter it doesn't work and I get the "buffer" error.

Also, when I want to preview the blu-ray in Encore and the pop up menus are active it does not work to preview. I get the error message:

"Zeile 21 ist für diesen Streamtyp nicht verfügbar."

I appreciate any help.

Thanks guys and girls.

TOPICS
Encore

Views

965

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Encore compiling error because of pop-up menu

New Here ,
Feb 13, 2019

Copy link to clipboard

Copied

I created dozens of blu-rays, always with the same pop-up menu template.

Only the background and buttons are changed from project to project.

But this time the blu-ray built crashes and I get an error message saying:

"code 6", "Graphics buffer underflows" - Failed to multiplex with maximum IG PTS: 54900000 (in 90kHz)

error.jpg

I searched the forums. Seems like I am not the only one and no one found a soluton.

The photoshop file has exactly the same dimensions and dpi like all my other pop up menu pages. But it doesn't work this time. I can't figure out why but I know the problem is caused by the pop up menus because when I delete the pop-up menu from the project the built works.

I also started from scratch and renamed the files etc.

When I start from scratch and just import a movie file and set the pop-up menu it works. But as soon as I link a chapter it doesn't work and I get the "buffer" error.

Also, when I want to preview the blu-ray in Encore and the pop up menus are active it does not work to preview. I get the error message:

"Zeile 21 ist für diesen Streamtyp nicht verfügbar."

I appreciate any help.

Thanks guys and girls.

TOPICS
Encore

Views

966

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Hopefully Neil Wilkes will drop in and comment. I'm not sure that I found another instance of your exact message: Fatal error (vs file exists) and Failed to multiplex vs other variations.

Line 21 sounds like captions, which are not supported in Bluray, and won't play in Encore preview anyway.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
New Here ,
Feb 13, 2019

Copy link to clipboard

Copied

no captions, pop up menus are like I always do them (at least I can't spot any difference)

I spent a whole day with the psd file...I just don't get it to work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 15, 2019

Copy link to clipboard

Copied

I was not convinced it was the menu, but I have no idea.

Oliver sent me the psd. I looked at the psd, but did not have a chance to try it in an Encore project.

You have a multipage popup menu, but most of the layer prefixes are missing except for the highlight designation. I'm surprised it works, but, as you say, it has in the past! There are many layers, and a simple link might work and more might not. If it turns out to be the menu, I have no idea why it has worked before and not now.

I would modify a copy of the psd and try it in a test project. First just 3 or 4 links, then a second page also.

Here is a link to the EN CS6 pdf help. The on line links are messed up.

https://help.adobe.com/archive/en/encore/cs6/encore_reference.pdf

Menus -> Using Photoshop to create menus -> Layer name prefixes for menus.

Also, pull up a multipage popup menu from the EN library; example, Corporate/Space Multipage Popup HD.psd.

Button layer names always start with a plus sign in parentheses. (Jive keeps changing that into a big circle with a +, so I can't add it here!)

The code for a new page is (#) and then the page name. It is possible that as long as there is a # symbol, it works, but help and the library versions show just the # in parens, then "Page 1", "Page 2" etc. Note that the first page in a multipage is page zero, so the second page is the first one labeled, and it is "Page 1."

You will also find that a highlight layer (=1) is above a text or other set element in a button group. This does not matter unless the element covers the highlight and prevents it appearing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

thanks Stan,

I changed the menu so that the name scheme is exactly the same like the files from the Encore library.

Same error.

Then I removed the backgrounds from all button groups.

Then it worked.

So the error lies in the image from the background but I can't tell what the error is.

On one of the pop up menus with two pages I started copying one image layer (from my original file that ain't working) to one of the button groups.

The compile worked.

I then added one more to the second menu page of that very same pop up menu. The built also worked.

So, I continue adding. I will soon know which layer causes the crash.

I hope I will understand then WHY and find a FIX.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Community Professional ,
Feb 15, 2019

Copy link to clipboard

Copied

Sounds like good troubleshooting.

Images in button layers can cause issues; for example if they are vector perhaps, in which case, rasterizing them can help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

So, my pop up menu has two pages, each with 9 buttons. I changed the names of all layers according to the Encore standards. Then I activated one after one in Encore. Starting with one. That worked. Two worked, too. Then I made a jump and activated all buttons on page 1. It worked. Then two buttons on page 2. It worked. Then all on page 2. Error. Then I unselected one button on page 2. It worked again. Did it several times with different buttons to see if a particular button is the problem but it ain't. Encore error only happens when all buttons are active.

I have pop up menus with up to five pages and up to 12 buttons per page and never experienced problems so I guess the amount of buttons can't be the problem. But what is the problem then?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Community Professional ,
Feb 15, 2019

Copy link to clipboard

Copied

There are button and other limits in BD, but, as you say, that has not been a problem for you before.

I'll try to test this....

Here's my most relevant note, a post by Daniel Ludwig on the Cow forum:

BD-limitation is different according to BD-spec. it´s got a 16MB limit for all IG (interactive graphics) within one title (menues are a titles as well), as the IG-stream will be loaded completly into the players RAM-buffer before starting the title.

so you could have as much multi-pages/buttons/background/button-groups within the IG-stream as you want.

but in fact there is a limitation as far as I remember, and it´s regarding buttons within a single button-group. this is limited to button 0 to 32, but I´m not quite sure about it.

http://forums.creativecow.net/readpost/145/871320

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Community Professional ,
Mar 11, 2019

Copy link to clipboard

Copied

oliverk37878173  wrote

So, my pop up menu has two pages, each with 9 buttons. I changed the names of all layers according to the Encore standards. Then I activated one after one in Encore. Starting with one. That worked. Two worked, too. Then I made a jump and activated all buttons on page 1. It worked. Then two buttons on page 2. It worked. Then all on page 2. Error. Then I unselected one button on page 2. It worked again. Did it several times with different buttons to see if a particular button is the problem but it ain't. Encore error only happens when all buttons are active.

I have pop up menus with up to five pages and up to 12 buttons per page and never experienced problems so I guess the amount of buttons can't be the problem. But what is the problem then?

Are any of your buttons overlapping?

Encore would not like that much.....even though it is theoretically possible in Blu-ray - and that would immediately increase the graphics buffer content.

I'll have a poke through the specs & see what I can find.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2019 0
New Here ,
Mar 11, 2019

Copy link to clipboard

Copied

no overlapping, 100 percent sure

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2019 0
Adobe Community Professional ,
Mar 13, 2019

Copy link to clipboard

Copied

Hi Oliver.

It occurred to me that as the Encore AuthorCore is an old Sonic Solutions one, the Blu-ray section may also be this.

So I checked through the library of Knowledge-base articles from before Rovi shut Sonic Solutions down (blame them for Encore going obsolete too) and managed to find the following:

A buffer underflow error may occur when data cannot be fed into the player’s buffer quick enough for

the player to playback all of the required data at the correct time. This may be caused by having a

video stream with high target and maximum bitrates, and little difference between the two values. This

increases the likelihood that data cannot be placed in the buffer fast enough, due to its limited size,

resulting in the buffer running out of data during playback.

A possible buffer underflow error you may receive when multiplexing is:

|ERROR|MUX_SN_E_TS_UNDERFLOW_ERR|E:\Projects\Hoops\Mux\MUX\Disc\DB\BDMV\STREAM/

00001.m2ts|0|Buffer underflows|tswrapper.dll::CTSWrapper::ProcThreadMain::Graphics buffer underflows.

- Failed to multiplex with maximum IG PTS: 54900000 (in 90kHz).

To eliminate this you can reduce your IG bitrate (note this does not affect size) within Scenarist HDMV.

Select the IG in the Data Tree, go to the properties window and change the bitrate from 1.0 to a lower

value (reducing the bitrate) often reducing this to 0.9 or 0.8 is sufficient:

This looks really familiar, so I wonder if there is a way to reduce your IG bitrate in Encore?

I have attached the graphic from the article as well.IG Underflow.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2019 0
New Here ,
Mar 19, 2019

Copy link to clipboard

Copied

hi Neil,

thanks for pointing this out.

The project that is giving me troubles has actually way less bitrate than my usual blu-rays and the process is the same like always. I render with the Premiere h264 blu-ray preset and Encore does not need to convert the stream. It is 100 percent compliant. The pop-up menu itself only has a small picture in it. It is the same like my others basically so I don't think this IG bitrate setting will be the solution but I will give it a try and let you know.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 19, 2019 0
Adobe Community Professional ,
Mar 25, 2019

Copy link to clipboard

Copied

Hi Oliver.

You are confusing video bitrate with IG bitrate - IG bitrate is your total graphics load on the system, and nothing to do with the actual video bitrate.

What you must remember is that in Blu-ray everything is a video - even the menus.

The menu graphics are IG - Interactive Graphics - and these are pre-loaded when you first load the disc, and their bitrate is calculated separately to the video playback bitrate. It is also severely restricted to (IIRC) around 16Mb.

This is why we use BD-J.........it gets around these picky limitations

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

ah I see...

but then again I don't understand because the menu is from the same template I always use.

The image in the big is exactly the same size as always so I don't understand how it could be bigger than 16mb

I gave up on this project's pop-up menu. I hope I never enounter a problem like this again

Thanks to all of you for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
Adobe Community Professional ,
Feb 20, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Stan+Jones  wrote

Hopefully Neil Wilkes will drop in and comment. I'm not sure that I found another instance of your exact message: Fatal error (vs file exists) and Failed to multiplex vs other variations.

Line 21 sounds like captions, which are not supported in Bluray, and won't play in Encore preview anyway.

Not sure why - this is way outside my comfort zone, and it is indeed a Closed Captioning error.

"Line 21 is not available for this stream type".

It also sounds very much like you are hitting the limits of the player buffers - 16Mb is not much, and the best way to do this is to use JPEG instead of PNG as you can get much more out of the pitiful limitations of IG mode.

Other possible pitfalls are that again in IG you can only use full colour for the backgrounds - all buttons are limited to 256 colours.

(We do not use IG at all - all our titles are BD-J so sorry I cannot be much more help)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Adobe Community Professional ,
Feb 20, 2019

Copy link to clipboard

Copied

Thanks, Neil.

I did a test project with the menu, but can't do much without a lot of linking.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
New Here ,
Feb 20, 2019

Copy link to clipboard

Copied

I just sent Stan a new PSD filw which I did almost from scratch. The backgroud image comes from a smaller size now, all button/layer naiming/mapping meets Encore's standard now.

It still does not work though. Two pages, each with 9 buttons. I did much more complex menus like this with the same template so I really don't think it can have anything to to with the buffer/MB size limitations...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
New Here ,
Jul 17, 2019

Copy link to clipboard

Copied

For what it is worth - had very similar error message.  After much testing, here's how I solved it: the main menu used a video motion background – Menu/Properties/Motion tab.  I had it linked to a Blu-ray h.264 file.  The problem went away once I relinked instead to the full 1080p ProRes master, and then let Encore transcode just that menu background.  Surprised, as I used the same encoding preset in Media Encoder (2017 ME app, as it seems there is a problem with the 2019 ME app) that all the movies were encoded to (and those were not a problem).   No more error on the build!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2019 0
New Here ,
Aug 23, 2020

Copy link to clipboard

Copied

I'm running into a similar problem. What does this mean? Simple answer please!

.Screen Shot 2020-08-23 at 6.07.10 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2020 0
Adobe Community Professional ,
Aug 23, 2020

Copy link to clipboard

Copied

Tony, the 2 links I had for your specific error (graphics underflows/recommended IG PTS) were not carried into the new Adobe forums. I have no idea what they suggested.

 

Neil Wilkes hasn't dropped by lately, but perhaps he will....

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2020 0
New Here ,
Aug 23, 2020

Copy link to clipboard

Copied

Stan,

Feel free to send me the links via Email:

[personal info deleted by mod]

Thank you for the reply!

 

Tony

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2020 0
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

Sorry; what I meant was that the actual thread was not brought into the "new" Adobe forums. So when you enter the link, it takes you to the main forum page with no content. I could post the link here, but it would do no good.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

I'm here.

Is this still an issue?

 

Apologies for not being around much lately, but I am finding it really awkward finding relevant stuff since the Encore forums were killed off, although I will make more effort in future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0