Highlighted

Essential Graphics - Expressions involving audio not making it to Premiere

Community Beginner ,
Aug 07, 2017

Copy link to clipboard

Copied

Hi There

So I'm having trouble trouble with the new Essential Graphic Template from AE to Premiere. Specifically I've written expressions that play different sound based on the content of a source text file. The expression works great in AE, but only plays the default sound in Premiere. I filed a detailed bug report with Adobe, which I'm sharing here in the hope that a community member might have a suggestion on how to get this baby working.

Any help grately appreciated.

Steps to Reproduce Bug:

1. Create composition containing multiple sound clips and a text layer.

2. Add stereo mixer effect to each clip.

3A. Add an expression to mute/hear each sound clip, using the left and right channel values of the stereo mixer effect, based on the text value of the text layer.

or

3B. Nest the sound clips in their own composition and write an expression to play back the appropriate sound clip based on the text value of the text layer in the parent composition using time remapping.

4. Create an essential graphic template making the text value of the text layer an editable attribute.

5. Export essential graphic template to premiere by either CC library or local file.

Results:

The expression works fine when played back in After Effects. However, the correct sound does not play in Premiere. Premiere only plays the value that was the default when exported from AE, changing the default value in Premiere has no effect.

The result is the same using either of the methods described above.

Expected Results:

I would expect the expression to have the same behavior in both AE and Premiere. Changing the value of the text source in the essential graphic template, should play back the correct sound.

Views

309

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Essential Graphics - Expressions involving audio not making it to Premiere

Community Beginner ,
Aug 07, 2017

Copy link to clipboard

Copied

Hi There

So I'm having trouble trouble with the new Essential Graphic Template from AE to Premiere. Specifically I've written expressions that play different sound based on the content of a source text file. The expression works great in AE, but only plays the default sound in Premiere. I filed a detailed bug report with Adobe, which I'm sharing here in the hope that a community member might have a suggestion on how to get this baby working.

Any help grately appreciated.

Steps to Reproduce Bug:

1. Create composition containing multiple sound clips and a text layer.

2. Add stereo mixer effect to each clip.

3A. Add an expression to mute/hear each sound clip, using the left and right channel values of the stereo mixer effect, based on the text value of the text layer.

or

3B. Nest the sound clips in their own composition and write an expression to play back the appropriate sound clip based on the text value of the text layer in the parent composition using time remapping.

4. Create an essential graphic template making the text value of the text layer an editable attribute.

5. Export essential graphic template to premiere by either CC library or local file.

Results:

The expression works fine when played back in After Effects. However, the correct sound does not play in Premiere. Premiere only plays the value that was the default when exported from AE, changing the default value in Premiere has no effect.

The result is the same using either of the methods described above.

Expected Results:

I would expect the expression to have the same behavior in both AE and Premiere. Changing the value of the text source in the essential graphic template, should play back the correct sound.

Views

310

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 07, 2017 1
New Here ,
Jul 22, 2020

Copy link to clipboard

Copied

Hi, Moley! Could you solved this issue? I'm having the same problem, and we are in 2020, 3 years after you reporting the bug. Hope Adobe guys have fixed it! Thanks from Argentina!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2020 0
Adobe Community Professional ,
Jul 22, 2020

Copy link to clipboard

Copied

I'm not sure that the mogrts can carry sound options ... did you have the setting on in Ae to only allow options that carry over to Premiere?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2020 0