Exporting open captions as .srt file

Community Beginner ,
Dec 20, 2016

Copy link to clipboard

Copied

Hi,

The Adobe help page on working with captions (Learn to work with captions in Premiere Pro ) states that:

'You can export Open Captions as Open Caption formatted SRT and XML files and also convert single stream sidecar and embedded single stream files to Open Caption in Premiere Pro.'

I'm working with Open Captions (in Adobe Premiere Pro CC 2017.0.1) and whilst I can burn them into the finished film no problem, I can't seen any way to export the open captions as a separate .srt file.

Any help would be much appreciated!

Views

78.5K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Jul 14, 2017
Richard van den Boogaard Adobe Community Professional , Jul 14, 2017
Hi,To export the captions as a separate SRT file (or various other formats) do this:Select the file that says Captions in the Project Panel.Go to the menu File > Export > Captions and select the SubRip file format from the top Dropdown box.This will not render out the video, but ONLY save the captions file as an SRT.(It took me a while to figure this out as well)

Likes

Translate

Translate
Jump to answer Jump to answer
Community Beginner ,
Mar 06, 2017

Copy link to clipboard

Copied

I'm asking myself the same exact question :

"You can export Open Captions as Open Caption formatted SRT and XML files and also convert single stream sidecar and embedded single stream files to Open Caption in Premiere Pro."

Thanks, but how ?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Mar 20, 2017

Copy link to clipboard

Copied

cmd M then in second box on menu : Captions set Create sidecar File and choose srt. and export the bad boy!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 20, 2017

Copy link to clipboard

Copied

Your going to love me. Here is a workaround on this glitch:

When you are ready to export, select your timeline and SOMETHING else in the Project Window. Then when you export and go to the Captioning window- the export sidecar option will magically work.

Hope this saved you hours of frustration.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 26, 2017

Copy link to clipboard

Copied

Thanks a lot. Works perfectly!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 04, 2017

Copy link to clipboard

Copied

Hi! I saw that you tried to export an open caption as a sidecar file and was able to do it with the help of the community in this forum . I tried the same thing that people recommended you and it didn't work. Is there any advice that you can give me? Maybe i'm doing something wrong. Thanks in a advance!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 04, 2017

Copy link to clipboard

Copied

This works for closed captions- in other words, captions created with a separate captions layer. When that layer is on your timeline above the video and your export is that sequence. I'm recommending selecting that sequence and for instance- a black video clip from the project window and then selecting export.

In your video settings for export, select the caption tab and you should see all options in the drop down menu.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 04, 2017

Copy link to clipboard

Copied

Thank you very much for the answer! I really made a mistake choosing Open Captions...and now it can't be exported or converted to Closed Captions.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Jun 01, 2017

Copy link to clipboard

Copied

HI, I'm getting close by following your method, but I'm not getting the sidecar file when I finish exporting. Plus, I have to export the whole video just to see if there's a sidecar at the end, and there isn't.

What kind of format do you choose in your export settings? I understand your instructions about the Captions settings, but I mean the format options at the top. I've tried mp4 and png sequence. I've also tried deactivating the video tracks except the open caption track but still to no avail.

Would it have been easier if I hadn't started with Open Captions? If so, any way to convert?

Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 14, 2017

Copy link to clipboard

Copied

Hi,

To export the captions as a separate SRT file (or various other formats) do this:

Select the file that says Captions in the Project Panel.

Go to the menu File > Export > Captions and select the SubRip file format from the top Dropdown box.

This will not render out the video, but ONLY save the captions file as an SRT.

(It took me a while to figure this out as well)

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 27, 2017

Copy link to clipboard

Copied

I'm trying to export a srt file from a subtitle track I created in Premiere. When I try to click "Captions" from the "export" drop down menu, it's grayed out. Any idea why?  I've also tried this:

When you are ready to export, select your timeline and SOMETHING else in the Project Window. Then when you export and gof to the Captioning window- the export sidecar option will magically work.

But I can't find the .srt file once it has been queued/exported. Thanks in advance for your help!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 18, 2020

Copy link to clipboard

Copied

This is the question I am answering:

'I'm trying to export a srt file from a subtitle track I created in Premiere. When I try to click "Captions" from the "export" drop down menu, it's grayed out. Any idea why?'

 

Here is the answer/solution:

You need to make sure that Toggle Sync Lock icon in the track header of the srt tract in the timeline is toggled. When you do this the  "Captions" option in the "export" drop down menu becomes clickable. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 30, 2017

Copy link to clipboard

Copied

Thanks, this is the correct answer to export Open Captions layer to .srt file - ridiculously hard to find out how to do this. Thanks again, your answer should be marked as the correct answer in this thread.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 30, 2017

Copy link to clipboard

Copied

Thanks, but I wasn't answering a question, I was asking one. I tried one person's suggestion (When you are ready to export, select your timeline and SOMETHING else in the Project Window. Then when you export and gof to the Captioning window- the export sidecar option will magically work.) but I couldn't find the .srt file once it exported. In fact it opened up Media Encoder but I couldn't do anything once in that program. Any other advice would be very helpful. Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 30, 2017

Copy link to clipboard

Copied

Hi, I believe in the export menu, instead of choosing export media, there's an option  called "Captions". (Files > Export > Captions). Maybe it's not there but somewhere else. That's how I exported the .srt file. (Premiere Pro 2017) Hope it helps.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 27, 2020

Copy link to clipboard

Copied

Hi, I'm trying to export a timeline of SRT files but the captions button does not seem to work (greyed out). Do you know how to export a full timeline of multiple SRT files instead of the one SRT file selected?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 06, 2017

Copy link to clipboard

Copied

Thanks a lot, This a REAL fix for open captions

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 06, 2017

Copy link to clipboard

Copied

Hang on. Epic FAIL.

This export worked first time. Then I adjusted and added more lines to the caption clip, increased the length to a new edit. Now it doesn't export! At all!

It goes through the motions. I press save. No file is saved anymore, nothing. Its a blip, a crushing blow. Gutted.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
Mar 04, 2019

Copy link to clipboard

Copied

I downloaded an mp4 file which has subtitles embedded inside it. I can toggle them on or off in VLC media player. Is there anyway I can export from Adobe Premiere pro cc 2019? File>export>captions option is greyed out. I even created a new sequence from the clip, selected it on editing timeline,  then tried the same option to export the subtitles but it still it's greyed out.

What should I do?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 04, 2019

Copy link to clipboard

Copied

PR only embeds in mov and mxf. Here is a feature request you can upvote to add other options:

708 Closed Captioning – Adobe video & audio apps

I can't find it now, but someone said you could use Handbrake to embed in mp4.

To embed in MOV or MXF from PR, you use File -> Export -> Media (i.e. Ctrl-M) and set the captions tab to "embed." It does not help you, since mp4 is not included. It also only works if the caption stream is a supported type (e.g. Closed caption, not Open Caption) and it is the right export type.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 14, 2020

Copy link to clipboard

Copied

Fantastic...that sorted it...thank you

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 30, 2017

Copy link to clipboard

Copied

Unfortunately it didn't work for me. I tried several times with different file formats and it didn't work. Is there any other workaround that you could think of?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
May 31, 2017

Copy link to clipboard

Copied

Thank you! It really did work!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 04, 2017

Copy link to clipboard

Copied

That is so ridiculous - but thank you so much!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 09, 2017

Copy link to clipboard

Copied

Thank you love!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more