Font issue when using Titles. Font not correct/visual issue

Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

The font I'm trying to use for with the Title Tool is not displaying properly. In this particular case is a Google Font called 'Epilogue'. I've tried to re-install the font as well as updating Premiere Pro. Right now this is messing up my workflow entirely since I have to export pngs from Photoshop. 

 

Anyone know how to fix this issue I'd be really greatful. 

I'm using a 2019 Macbook Pro running macOS Big Sur, vesion 11.2.3. 

 

TOPICS
Effects and Titles, Error or problem

Views

127

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Does the font work OK if you use Essential Graphics to make the title instead of the Legacy Titler?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi thank you, this does work better, however there are a bunch of weights missing.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Use the Ess Graphics Panel instead.

The Legacy title is what it is Legacy.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

This works better, but a lot of font weights missing...

 

premiere-font-issue-2.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Might be a mac (Big Sur?) issue.

afbeelding.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Hi there. Having the same problem on a PC. The typeface details have remained the same but it doesn't look the same at all. Puls Premiere has decided to add a drop shadow to all the text Captions and now dumps all the text into one box.

 

pijbv_0-1616754887903.png  

pijbv_1-1616754940878.png

 

HELP please

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines