Glitchy preview on a Macbook Pro 16" in Premiere 2020

Community Beginner ,
Dec 10, 2019

Copy link to clipboard

Copied

Hi all,

 

Just like the AE GPU glitches that were happening Here and here and that were fixed 17.0.1

Premiere 2020 is experiencing the same glitch when zooming in on the program monitor.

 

Screen Shot 2019-12-10 at 10.23.34 AM.png

 

Since this was just fixed for AE I hope a Premiere fix can be made easily. FYI, a temp fix is to disable GPU acceleration in the project settings.

 

Thanks,

Rog

TOPICS
Error or problem, Hardware or GPU, Performance, User interface or workspaces

Views

1.5K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Community Beginner , Feb 26, 2020
johnm11376824 Community Beginner , Feb 26, 2020
Looks like the latest Premiere update finally fixed it!

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Employee ,
Dec 11, 2019

Copy link to clipboard

Copied

Hi Rog,

 

Thank you for keeping us updated! We'll get the issue tested at our end. We need to check if the issue is reproducible.

Is there anything else you'd like to mention? Like if it happens with a specific media files or projects.

 

Let us know.

 

Thanks,

Kartika

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 21, 2020

Copy link to clipboard

Copied

I have the same issue too v14.0.1 and top spec 16" MBP :

Screenshot 2020-01-21 at 14.06.06.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 14, 2019

Copy link to clipboard

Copied

Hello, ive got my MBP 16 and im currently experiencing the same glitch.

Premiere Pro 2020 Version 14.0.0

Glitch whenever i Zoom-InGlitch whenever i Zoom-In

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 16, 2019

Copy link to clipboard

Copied

Hi Sebastian!

Thank you for updating us. This issue is under investigation by our engineering team. 

Let us know if you have any other questions.

 

Best,

Kartika

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 14, 2020

Copy link to clipboard

Copied

Hi, have you got a solution yet?

 

I hope so... it's been nearly a month since this was first reported. Suffering with clients by my side. NOT COOL.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 14, 2020

Copy link to clipboard

Copied

sadly no.

still, no update that can fix this. I'm still waiting, and yes me too.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 22, 2020

Copy link to clipboard

Copied

Like the others, I'm on a 16" MacBook Pro.  The issue is easily reproducible when I zoom in on the canvas (Fit and 10% are ok, but at 4K 25% overflows the Preview window and the image scrambles into the lines).  Also an example is the Crop effect, I can crop one side, two sides, but when I bring in a third or sometimes the fourth edge, it scambles again.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 23, 2020

Copy link to clipboard

Copied

Exactly the same for me...it's a bit embarassing...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 28, 2020

Copy link to clipboard

Copied

Hi all--

Apple just released a new Catalina update (10.15.3). Does someone with the 16" MBP want to upgrade and see if there's a GPU fix for this issue?

 

WM

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 04, 2020

Copy link to clipboard

Copied

Just updated my MBP 16" to 10.15.3 and nothing, it is still doing it.

 

***UPDATE*** changing the GPU acceleration (METAL) back to OPEN CL (Deprecated) In the project settings and it works fine. I am able to zoom in and out of my program monitor without glitching. Which is fine even when rendering I switch it to OPEN CL, METAL just really sucks right now it's slower and useless. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 04, 2020

Copy link to clipboard

Copied

My is also the same as it was.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 09, 2020

Copy link to clipboard

Copied

Got the same problem! Hope this is resolved soon, been waiting months already. Adobe dynamic link also doesn't work for me.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 09, 2020

Copy link to clipboard

Copied

the band-aid solution right now is to switch your renderer in the project
settings to Open CL instead of Metal

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 14, 2020

Copy link to clipboard

Copied

Hey Adobe!

Using this work around of using OPEN CL instead of METAL.

 

Is there a patch coming soon tho? This glitch is really rough for:

1) the crop tool

2) zooming in you program panel

3) scaling up footage

 

I'm experiencing this issue in both AE & Premiere since I've gotten my 16in macbook pro. 

 

Please help us with a patch! 😞

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 21, 2020

Copy link to clipboard

Copied

Same issue. It has rendered Premiere Pro unusable on one of the most common configurations for nearly 2 months. You'd think that the latest MacBook Pro would be a configuration you want to support with your software...

 

What is going on Adobe, have you totally lost it?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 26, 2020

Copy link to clipboard

Copied

Looks like the latest Premiere update finally fixed it!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 26, 2020

Copy link to clipboard

Copied

Great to hear! Is this the new 14.0.3 update?

 

WM

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 23, 2020

Copy link to clipboard

Copied

The update has not soolved it.  I am still experincing it.  I have also foudn that my exports play back with glitches in certain situations. I have the PPro 2020 14.4.0 build 38 and am running Catalina 10.15.6 on a 16" MBP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 24, 2020

Copy link to clipboard

Copied

No not fixed. I run all screenrecordings through ffmpeg. Then I can use them. 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more