Highlighted

Help!! Premiere Pro CC is changing the color of my imported footage

Explorer ,
Aug 28, 2018

Copy link to clipboard

Copied

When I import my footage into Premiere, it seems contrast is being added to it. What was properly exposed footage looks like it has crushed blacks and blown out whites. I have not added any effects and there are no master clip effects added. When the footage is in a sequence, I can create an After Effects Composition, and the color returns to normal. I am looking for a solution inside Premiere so I don't have to create AEcomps for every clip. It affects both .mov and .mp4 files.

.mov

Screen Shot 2018-08-29 at 12.11.27.png

.mov AEcomp

Screen Shot 2018-08-29 at 12.11.43.png

.mp4

Screen Shot 2018-08-29 at 12.12.04.png

.mp4 AEcomp

Screen Shot 2018-08-29 at 12.12.15.png

Thank you in advance.

~ Geoff

System:

iMac Pro

High Sierra v.10.13.6

3.2 GHz Intel Xeon W

64 gb 2666 MHZ DDR4

Radeon Pro Vega 56 8176mb

Camera info:

Canon 80d shooting in .mov and .mp4

Premiere Pro CC v. 12.1.2

Update:

I have tried the same video on an iMacbook Pro computer with updated Premiere and AE. There was no issue with the colors. This problem might be specific to Premiere on iMac Pro systems.

I also created a GIF to better demonstrate the difference between footage in Premiere and the same footage routed through After Effects.

https://drive.google.com/file/d/1-ZFROJphhpAwZVc6zOrnCGhAuON5B7_8/view?usp=sharing

After Effects displays the colors correctly. Premiere doesn't. Why is this so?

TOPICS
Import

Views

22.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Help!! Premiere Pro CC is changing the color of my imported footage

Explorer ,
Aug 28, 2018

Copy link to clipboard

Copied

When I import my footage into Premiere, it seems contrast is being added to it. What was properly exposed footage looks like it has crushed blacks and blown out whites. I have not added any effects and there are no master clip effects added. When the footage is in a sequence, I can create an After Effects Composition, and the color returns to normal. I am looking for a solution inside Premiere so I don't have to create AEcomps for every clip. It affects both .mov and .mp4 files.

.mov

Screen Shot 2018-08-29 at 12.11.27.png

.mov AEcomp

Screen Shot 2018-08-29 at 12.11.43.png

.mp4

Screen Shot 2018-08-29 at 12.12.04.png

.mp4 AEcomp

Screen Shot 2018-08-29 at 12.12.15.png

Thank you in advance.

~ Geoff

System:

iMac Pro

High Sierra v.10.13.6

3.2 GHz Intel Xeon W

64 gb 2666 MHZ DDR4

Radeon Pro Vega 56 8176mb

Camera info:

Canon 80d shooting in .mov and .mp4

Premiere Pro CC v. 12.1.2

Update:

I have tried the same video on an iMacbook Pro computer with updated Premiere and AE. There was no issue with the colors. This problem might be specific to Premiere on iMac Pro systems.

I also created a GIF to better demonstrate the difference between footage in Premiere and the same footage routed through After Effects.

https://drive.google.com/file/d/1-ZFROJphhpAwZVc6zOrnCGhAuON5B7_8/view?usp=sharing

After Effects displays the colors correctly. Premiere doesn't. Why is this so?

TOPICS
Import

Views

22.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 28, 2018 0
Explorer ,
Sep 04, 2018

Copy link to clipboard

Copied

Update:

I have tried to uninstall and re-install Premiere Pro with no effect. I also recalibrated my screen to Rec.709. with no effect.

Is there anyone out there working with iMac Pro and Canon DSLR footage having similar issues?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 3
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

I occasionally get this sort of thing on clips from my Panny GH3 on my Win10 system. Yea, nuts, eh?

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Explorer ,
Sep 05, 2018

Copy link to clipboard

Copied

Neil,

Thank you for taking a look at my problem.

Is there anything you do to have your footage import correctly?

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

Not really, I've talked with engineers at NAB about this, and after sending them a clip, it didn't do it on their system. Ergo ... it's supposedly something 'here'. Can't figure out what it is.

Do you have a clip you could post via dropbox or something that I could test here to see if I can replicate your issue?

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Explorer ,
Sep 05, 2018

Copy link to clipboard

Copied

Neil,

Here is a link to a .MOV file that I have been testing with.

Dropbox - blue card no strap.MOV

Again thank you for taking the time to help me figure this out.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Adobe Community Professional ,
Sep 06, 2018

Copy link to clipboard

Copied

This came up totally clean on my system. I've got two grabs here, the first on import, the second after using the Creative tab shadow/highlight tint controls to correct a slight extra warmth push across the board to get to "neutral", checking the RBG Parade values in mid-upper shadows and mid-upper highlights to match channels as adjusting.

Nothing below about 3 or above 100 on import or after adjusting ... hmmm.

I will say, I shared some of the files that showed excess contrast on my machine from my Panny GH3 with a couple engineers. And on their machines, the files did the same thing yours did for me ... showed totally clean. As expected for carefully controlled lighting & exposure, from 2 to 99.

One might be caught thinking "What the ... ?"

Neil

ClientTest.PNG

ClientTest Corrected.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 0
New Here ,
Dec 17, 2018

Copy link to clipboard

Copied

I'm having the same issues with 1DX files, Phantom .cine files, and RED R3Ds.  The color sync "verify" idea didn't work either. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2018 0
Adobe Community Professional ,
Dec 17, 2018

Copy link to clipboard

Copied

Post any such issues on the UserVoice system please! Those go right to the PrPro engineer's system ...

Neil

Adobe Bug /Feature service: https://adobe-video.uservoice.com/forums/911233-premiere-pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2018 0
Explorer ,
Dec 17, 2018

Copy link to clipboard

Copied

GMPM_george,

It is not clear to me just yet that we are having the same problem. Could you help me understand by giving more details about your situation? The Color Sync worked for me and therefore became the correct answer for this thread however if alternative solutions are discovered I am willing to add them to the correct answer post.

Unfortunately, if the problem you are encountering is not the same as my original issue then I must politely suggest making your own thread, if you have not already.

That being said, please explain the details of your issue, including your system specs, software you use, solutions you have already tried, how you test color correctness, etc. The more detail provided the better we can compare issues.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2018 0
Guide ,
Sep 05, 2018

Copy link to clipboard

Copied

AE (with color management off) is just following your native monitor color profile by default(usually P3). premiere ignores it.and stays in rec. 709. So, either use color management with AE/view simulate or use a p3 to rec. 709 lut for premiere. one of them will be wrong. you get to choose which. Try to "load a Null/Bypass ICC" in the mac's color profile OS type. Steve Shaw said that is the only way for it to let you customize profiles. I don't have a mac, so I can't verify this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Explorer ,
Sep 05, 2018

Copy link to clipboard

Copied

Chris,

I have tried setting my monitor to rec.709 with no luck. I did this through my Mac's System Preference Panel. Is there a different method I should be using?

But I must say that with the nature of this issue, I have a hard time believing it is an issue based solely on my monitor's color profile. Just today as I was editing a video, and the colors of some of my clips started flickering between the original color and the high contrast version without being routed through AE. It seems to me that Premiere has the ability to interpret the video colors correctly but is glitching somewhere. Of course this is just my current take on the situation and appreciate your input.

Could you explain to me how I can use color management with AE in Premiere?

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Explorer ,
Sep 05, 2018

Copy link to clipboard

Copied

This was a comment that disappeared as I was replying to it that mentioned a similar issue when Non Accelerated Effects were applied to the sequence.

"Hi I have had a similar issue in particular when I have upgraded from 12.0.0 to 12.1.2, it seems to occur when you apply non accelerated effects and the timeline goes from the yellow bar to the red one. I have tried it on two different machines and the same issue occurs. I'm not on a Mac but on a PC and it sounds very similar to the issue I have been having. I think if you haven't applied a non accelerated effect to your work recently you might not have noticed the colour shift.

This colour shift still occurs if you lower the effect so that it doesn't effect the image. So an example is setting the camera blur effect to 0, in theory the effect should do anything to the image however toggling the effect on and off shows the shift in the waveform. Non accelerated transitions also produce the colour shift. These aren't limited to only 8bit effects either, I have tried with 32bit effects like neat video and still get the colour shift. I have also rendered these out to make the red line go green and set the sequence to max bit depth and max render. The preview renders are set to cineform 10bit yuv 10bit 3840 x 2160. This still shows the colour shift. I have also exported the project and it gets the colour shift."

While similar, I have the color shift occurring even when I start new projects and import brand new footage with no effects attached to it.

But I am open to the possibility that this is a solution. Is it possible for Non Accelerated Effects be applied automatically without me knowing? If so, is there a way I can stop that from happening?

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
New Here ,
Sep 08, 2020

Copy link to clipboard

Copied

I was having the same issue and this totally worked for me. I thought Ae comp looked darder in premiere, but then realized it was actually Premiere's preview of the footage the one that was looking "clearer". I actually prefered that look instead of the darker/original one, so I just set rec 709 in the After effects composition and was good to go. Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2020 0
Community Beginner ,
Sep 05, 2018

Copy link to clipboard

Copied

Hi sorry I deleted the comment because i was about to write a new discussion on this issue. We have tested on 3 separate computers now running 12.1.2 and have been using the inbuilt bars and tone to test the colour shifts to get the following results. Sequence settings are set to Max bit depth and max render, can anyone explain what is occurring here:

GPU enabled no effects:

no effects.jpg

GPU enabled with 8bit effect and non accelerated effect - camera blur set to 0:

8bit effect no acceration.jpg

GPU enabled with 32bit effect and non accelerated effect - neat video no effect applied:

32bit effect no acceration.jpg

GPU Disabled:

gpu disabled.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Explorer ,
Sep 05, 2018

Copy link to clipboard

Copied

Korin Unka,

Thank you for reposting.

Unfortunately, I don't quite understand what you are doing in each image. Could you provide more detail on how you went about testing. I would like to recreate your test to see if we have the same issue. Up until this point I have not any issues with color shifts when it comes to bars and tone. I have only had shifts with my video clips.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0
Community Beginner ,
Sep 06, 2018

Copy link to clipboard

Copied

I'm testing whether non accelerated effects do a colour shift. I'm also testing whether disabling my gpu and setting it to software causes a colour shift. I'm using inbuilt bars and tone from premiere pro to do the test so that I can discount whether it's imported footage. With the above screen shots what I have done is created a new "bars and tone" from the within the project tab (right click "New item" > "Bars and Tone"). I then right click on the new bars and tone clip and select "New sequence from clip". That produces the sequence with the bars and tone. From that I have added 3 effects, one is a non accelerated 8 bit effect (Camera blur), The next is a non accelerated 32bit effect (Neat Video Reduce noise"), an accelerated effect "Gaussian Blur". I have disabled all the effects using the option in the top left of the effect (FX). I have then enabled each effect and set the effect so that is doesn't effect the clip, so I have set the Camera Blur to "0". On the above screen shot the camera blur does a colour shift to the bars and tone. I then disabled the camera blur and enabled the "Reduce noise" (32bit non accelerated effect). This effect doesn't effect the clip until you select specific options, as a result I have left it and it produces a colour shift. I then disabled this effect and enabled a hardware accelerated effect (Gaussian Blur) and set that to (0). I got no colour shift. After this I have disable the gpu - "File" > "Project settings" > "renderer" > Set it to "Mercury playback engine software only". This gave me a colour shift. I have done some other tests around rendering the project and the clips in the project and get the same colour shift. What I was testing out is whether it was my footage or whether it was to do with hardware acceleration, the shift is subtle however it is noticeable when you apply it to part of a clip, an example might be a non accelerated transition where the clip changes to the subtle colour shift as it does it's transistion. My current workaround is to not use non hardware accelerated effects or to try and do a secondary colour adjustment. Has anyone encountered this or maybe can point to where I maybe going wrong?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 0
Explorer ,
Sep 09, 2018

Copy link to clipboard

Copied

Korin,

Thank you for the in depth reply. I will do what I can to see if these issues are related.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 09, 2018 0
New Here ,
Sep 06, 2018

Copy link to clipboard

Copied

I'm working at a production company where one of the other editors encountered this problem on import too, and I'm trying to figure out why.


We have 5d3 H264 footage which is correctly exposed. In finder, in Resolve, in After Effects, it all looks fine, with good detail in the shadows.

He imported it into Premiere  by simply dragging the ten files into the browser (12.1.2), and one of the ten files has this heavy added contrast that blows out the highlights and destroys the shadow detail. Just randomly one clip.

What I've checked: Master clip effects are not applied, and all the footage is being interpreted the same way as far as I can see.

I've deleted the files and re-imported, and it looked fine last night, but this morning, all the clips now have the contrast problem.

Lumetri curves can't recover the crushed detail, nor can any low-con LUTs.

I suspect some kind of random bug with how it's deciding footage is legal range or extended range, and just cutting off any value below 16 and above 235. If there's a way to change how Premiere interprets this range on a clip by clip basis, that would help.


Literally never encountered this in previous versions, so I feel like it's a bug.

(edit): I've found an earlier thread here where no solution has been found either. Premiere Pro interprets wrong color space for MP4 files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 0
Guide ,
Sep 06, 2018

Copy link to clipboard

Copied

I think that is a separate issue as it only affects .mp4 and doesn't crush the blacks, just rotates the hues around.

For the crushed blacks, if lumetri is unable to recover the blacks, then its either a bug in the interpretation of the file or a bug with lumetri itself.

Can you try another video grade effect to raise the blacks(not lumetri) to confirm this? or a TIFF image to see if its codec related?

or disable high quality playback, or software only playback?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 0
Adobe Community Professional ,
Sep 06, 2018

Copy link to clipboard

Copied

I should be able to test your file today.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2018 0
Explorer ,
Sep 09, 2018

Copy link to clipboard

Copied

Jimmyfuwafuwa,

Your issues sound exactly like mine. Very frustrating.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 09, 2018 0
Community Beginner ,
Nov 14, 2018

Copy link to clipboard

Copied

Hello everyone, I have been using the new iMac Pro and have been experiencing these issues regarding an added high contrast from time to time and thought I was going crazy. Has anyone figured out a solution to this, or is it just a bug.... I work on the same exact project on an older iMac and the color is fine, totally matches how it was shot.

My System Info:

iMac Pro

High Sierra v.10.13.6

3 GHz Intel Xeon W

64 GB 2666 MHZ DDR4

Radeon Pro Vega 64 16368 MB

Premiere v.13.0.1 (PICTURED ON THE LEFT)

AfterEffect v.16.0.0 (PICTURED ON THE RIGHT) CORRECT EXPOSURE

Nothing has been added to the footage in premiere, so I cannot understand how its being interpreted this way upon import.

Screen Shot 2018-11-14 at 10.45.03 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2018 0
Adobe Community Professional ,
Nov 14, 2018

Copy link to clipboard

Copied

In your new Mac, I'll assume it's a P3 wide-gamut monitor, and you've not set the Preferences option to "enable display color management" ... try that and see if it helps.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2018 1
Adobe Community Professional ,
Nov 14, 2018

Copy link to clipboard

Copied

R Neil Haugen​ the new P3 wide gamuts are awful. I can't stand them. Apple needs to take a lesson from Dell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2018 0
Adobe Community Professional ,
Nov 14, 2018

Copy link to clipboard

Copied

Can't disagree!

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2018 0
Community Beginner ,
Nov 15, 2018

Copy link to clipboard

Copied

When I enable "display color management" they actually appear even darker.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2018 1
Adobe Community Professional ,
Nov 15, 2018

Copy link to clipboard

Copied

Can u post screengrabs of with and without color management

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2018 0
Adobe Community Professional ,
Nov 15, 2018

Copy link to clipboard

Copied

That's not a "tool" that can fix everything, sad it didn't help you.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2018 0
Guide ,
Nov 15, 2018

Copy link to clipboard

Copied

nothing my $600 lut won't fix. eh $0.

try it for free. lemme know if its works. I haven't heard if it doesn't work for cc 2019 premiere color management enabled.

To get bt1886 into srgb mode to match firefox/VLC but quicktime would probably still be in P3 mode. so you'd need a special bt1886 to P3  lut. argggg so many problems. use VLC to compare against premiere with my lut instead. At least I don't own a mac!

there's two luts depending on if your going from FCPX to premiere or premiere to VLC. one darkens, other lightens

bt1886 to srgb/rec709 2.2 and srgb to bt1886

https://drive.google.com/open?id=1HHxxaOWifI3TEhBwEyGSl139x2jRM9dO

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2018 0
Explorer ,
Nov 18, 2018

Copy link to clipboard

Copied

JRitz,

Unfortunately, all of my communications with Adobe Support have gone silent without any solutions. They even closed my support chat saying it was resolved.(a bit peeved by that) Your system and issues look identical to mine. All can give you are two work arounds that are a pain but will get the job done.

1. Create a After Effects Comp for every clip

2. Roundtrip it through Resolve using FCP XML

I recommend the Resolve method at the moment. For tutorials, search Roundtripping for Premiere Pro and Resolve. I hope this helps.

Geoff

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2018 0
Community Beginner ,
Nov 19, 2018

Copy link to clipboard

Copied

Is this just an issue with the newest iMac Pro. This issue has never happened with any other iMac we run at our studio.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2018 0
Adobe Community Professional ,
Nov 19, 2018

Copy link to clipboard

Copied

Yes, Apple made some changes in the OS as they've gone to the P3 wide-gamut monitors. The new 'enable display color management' option is an attempt by the PrPro team to work with that.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2018 0