Highlighted

How do I fix the "Invalid Font" issue?

Contributor ,
Feb 01, 2018

Copy link to clipboard

Copied

missing_fonts.jpg

This is what I get every time I open a project, every single time. It never happened until I updated Premiere Pro a couple of weeks ago. Also I was having trouble with Photoshop fonts after updating it. I renamed the CT Font Cache folder to OLD_CT Font Cache folder then restarted photoshop and the problem was solved. But I can find on such folder for Premiere Pro. What gives with this? Does anyone know how to fix this problem with Premiere Pro?

Views

17.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I fix the "Invalid Font" issue?

Contributor ,
Feb 01, 2018

Copy link to clipboard

Copied

missing_fonts.jpg

This is what I get every time I open a project, every single time. It never happened until I updated Premiere Pro a couple of weeks ago. Also I was having trouble with Photoshop fonts after updating it. I renamed the CT Font Cache folder to OLD_CT Font Cache folder then restarted photoshop and the problem was solved. But I can find on such folder for Premiere Pro. What gives with this? Does anyone know how to fix this problem with Premiere Pro?

Views

17.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 01, 2018 1
Engaged ,
Feb 01, 2018

Copy link to clipboard

Copied

Try solution number 2 (should work for your programs, too): "The font dictionary can't be read" error in After Effects

Found it in this thread: Adobe CC 2018 PrePro/AE Invalid Font

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Contributor ,
Feb 24, 2018

Copy link to clipboard

Copied

Thank you for trying to help. I couldn't make that work though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2018 0
Community Beginner ,
May 01, 2018

Copy link to clipboard

Copied

Same problem here.  I tried this with no solution: "The font dictionary can't be read" error in After Effects

Fonts were fine before the last update.  I guess I'm going to downgrade and try that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2018 0
Adobe Community Professional ,
May 01, 2018

Copy link to clipboard

Copied

01. Preferences - General - Uncheck 'Show Event Indicator'

02. If you have Teamviewer and updated it, roll back to a previous version

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2018 0
Explorer ,
Apr 01, 2020

Copy link to clipboard

Copied

Hi Carlos.

I've been working on a project for ages now and I too always get this message about invalid fonts and have to clear them. I previously worked on a Mac, so I assumed its got to do with that. I've got the latest CC and Premiere is 13.1.5 (Build 47) on a Windows system (10) on a laptop with high specs. Your suggestion: 'Preferences - General - Uncheck 'Show Event Indicator'. I don't see this in my display.

Any suggestions?

Several hours later - I did find and try what you suggested but still get the same exclamation mark and then lists of fonts with a clear button. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2020 1
Adobe Community Professional ,
May 06, 2020

Copy link to clipboard

Copied

you need to be signed in to creative cloud and have your fonts synced to adobe fonts

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 0
New Here ,
Nov 04, 2020

Copy link to clipboard

Copied

This worked for me. My creative cloud needed to be updated. Once i opened my creative cloud fonts section, a notification came up saying all my fonts were reactivated. I restarted my project and continued my day. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Explorer ,
Nov 04, 2020

Copy link to clipboard

Copied

Thanks Carlos - Out of time, I know, but still here and still got the same problem (same project). I clicked 'synch account' after signing in, but opening up the project, I still got the usual clear fonts issue. How do I synch my Adobe fonts - which was your answer to the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Adobe Community Professional ,
Nov 04, 2020

Copy link to clipboard

Copied

check that file syncing is on on your creative cloud app

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Explorer ,
Nov 15, 2020

Copy link to clipboard

Copied

Admittedly, this s not an area I am particularly familiar with. I just checked 'file syncing' - it has a tick next to it and says "up to date". I'm getting to the end of this project (extremly lengthy learning curve) and this is probaby one of the simpler issues that has come up, but it has prevailed the whole three years!

I further checked what has been saved int eh Creative cloud backup and found only current Audition files, and some Premiere Pro files from more than a year ago.

I get the feeling I've been doing things the hard way. Could you suggest a tutorial tha will get me up to speed on the issue of file syncing and backing up onto cloud, please? 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 0
Adobe Community Professional ,
Nov 15, 2020

Copy link to clipboard

Copied

you might want to clear your sync settings.. anyway check Adobe Help here:

https://helpx.adobe.com/premiere-pro/using/sync-settings.html#:~:text=On%20first%20launch%2C%20you%2...).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 0
Community Beginner ,
May 01, 2018

Copy link to clipboard

Copied

I had this problem in Premiere 2018. For the life of me, I could not figure it out. So I opened Apple Pages and wrote a few lines using the font that Premiere did not like. Suddenly, Premiere began recognizing the font in my sequence. I still get the error messages, but my sequence now has all the lower-thirds I created with the "Invalid Font." Worth a shot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2018 0
Community Beginner ,
May 02, 2018

Copy link to clipboard

Copied

I fixed my problem!  I upgraded my MacOS to 10.13.4.  Premiere runs like normal again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 1
Adobe Community Professional ,
May 02, 2018

Copy link to clipboard

Copied

Greetings ! but if any issues, hoping none will happen again, always share your OS and system specs

to help us help you faster

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 1
Community Beginner ,
May 02, 2018

Copy link to clipboard

Copied

Will do.  Thanks Carlos. Hopefully the OP Joe found his solution too and will post it so others will know what worked for him.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 0
Community Beginner ,
May 14, 2018

Copy link to clipboard

Copied

I have the same problem and I'm using osx 10.12.6 (16G29)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Community Beginner ,
May 14, 2018

Copy link to clipboard

Copied

I had to upgrade to 10.13.4

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Community Beginner ,
May 14, 2018

Copy link to clipboard

Copied

upgraded to osx 10.13.4 and it did not fix the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Community Beginner ,
May 15, 2018

Copy link to clipboard

Copied

Oh no... which version of Premiere Pro?  Is your error list a whole bunch of fonts or just a few?  If it's just a few, you might actually have a bad font.  If it's a whole list, hopefully someone else can chime in with help.  What a frustrating problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
New Here ,
May 17, 2018

Copy link to clipboard

Copied

I also tried all of the above and nothing has worked. What's the fix for this? For me, it happened after I updated Adobe and is linked to a specific font which I need for all my editing. Premiere insists on replacing it with courier even though the font is installed. Looking for an answer!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2018 0
Community Beginner ,
May 28, 2018

Copy link to clipboard

Copied

its a whole list, but these font were work fine right before i updated, and they are supported by photoshop and not premiere or after effects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2018 0