How do I install plug ins to Premiere Pro CC?

New Here ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

I just downloaded Pro CC and my New Blue Plug Ins are missing. What do I do?

Views

33.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Jul 02, 2013 Jul 02, 2013

Copy link to clipboard

Copied

Install them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

LATEST

how is this helpful bruh? fooh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 03, 2013 Jul 03, 2013

Copy link to clipboard

Copied

Moving this discussion to the Premiere Pro forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2013 Jul 10, 2013

Copy link to clipboard

Copied

Having the same issue with New Blue FX Plugins not loading in PPCC. Updated to CC earlier today. Created an alias folder of the plug-ins contained in AE CS6 and placed in AECC > plugins folder. They register fine in AECC but are not loading into PPCC???

Tried this approach : http://forums.adobe.com/message/5420399#5420399

Still nothing. Anybody have similar issues or any knowledge to offer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 04, 2013 Sep 04, 2013

Copy link to clipboard

Copied

I have recently moved to PP CC and just bought ColorFast  and Titler Pro 2.0 plug-ins from New Blue FX.

Had no end of trouble with them so far. Worst one being that once I have applied the effect (ColorFast) to a clip or group of clips, exit out of Premiere (end of the day), go back to project to start work again, the project fails to open with this message:

http://note.io/1cG9wOe

Happens every time and always when the effect is concerned. Really hacked off with New Blue too as their support has been basically appauling!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2013 Sep 04, 2013

Copy link to clipboard

Copied

Don't drive yourself crazy. Call Customer support. They will remote into your computer. Sit back, watch them do it and problem solved. I had the same issue with my New Blue FX bundles...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 04, 2013 Sep 04, 2013

Copy link to clipboard

Copied

Too Late! but thanks for the sentiment!

I spoke with Adobe but they won't support the problem as it is a Third Party Plug-In!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2013 Sep 04, 2013

Copy link to clipboard

Copied

That's BS. New Blue FX is third party plug in. When I installed CC (im on a subscription) it didn't recognize them. Support told me it was a glitch with CC. He took over my computer and in 10 minutes they were all loaded. He had to re-create folders etc...I don't see what's different than your situation... 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

hi if you version of premiere is cc 2014 your premiere is  8.0  you need in the plugins folder where are 7.0 create the  folder  8.0 and copy the content of the  7.0  to the  8.0 and ready yo can see your new blue in premiere cc

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines