Highlighted

I was very excited to try out the new features, but unfor...

New Here ,
May 19, 2020

Copy link to clipboard

Copied

I was very excited to try out the new features, but unfortunately, 14.2 broke Hardware Encoding in Export for me. I am using Windows 10 with an i9-9900k and RTX 2080 Ti graphics card.

I have always used Quick Sync Hardware Encoding when rendering with no issues but now the option is greyed out.

I tried updating my drivers etc. but nothing seems to fix it.

Other programs I use have no problems using Quick Sync, my Intel GPU works properly and shows up in Task Manager as it should.

 

I just downgraded again to 14.1 and now Hardware Acceleration is available again! So this seems to be a problem exclusive to 14.2.

arkadiuszk40353057_0-1589922053097.png

 

Views

630

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

I was very excited to try out the new features, but unfor...

New Here ,
May 19, 2020

Copy link to clipboard

Copied

I was very excited to try out the new features, but unfortunately, 14.2 broke Hardware Encoding in Export for me. I am using Windows 10 with an i9-9900k and RTX 2080 Ti graphics card.

I have always used Quick Sync Hardware Encoding when rendering with no issues but now the option is greyed out.

I tried updating my drivers etc. but nothing seems to fix it.

Other programs I use have no problems using Quick Sync, my Intel GPU works properly and shows up in Task Manager as it should.

 

I just downgraded again to 14.1 and now Hardware Acceleration is available again! So this seems to be a problem exclusive to 14.2.

arkadiuszk40353057_0-1589922053097.png

 

Views

631

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
May 19, 2020

Copy link to clipboard

Copied

Arkadias,

Did you toy with the Profile and/or Level settings at all? Things like that can void the Hardware Decoding feature. Let us know.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 20, 2020

Copy link to clipboard

Copied

Thanks, Kevin. I am trying the same file with the same preset in both versions of Premiere.

In 14.1 the Hardware Encoding option is available, in 14.2 it is greyed out with a message saying that no compatible hardware was found.

 

The settings are as follow. The only difference is that 14.2 does not allow me to choose "Performance: Hardware Encoding" in the Encoding Settings anymore.

arkadiuszk40353057_0-1589967678322.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
May 19, 2020

Copy link to clipboard

Copied

If I'm not mistaken, with 14.2 installed and a 2080, you would no longer be using Intel QuickSync but instead you'd be using NVENC for Hardware Encoding. I honestly don't think it's possible to select between the two even if you have a machine that is eligible for both. I don't have a CPU that suppoorts Intel QuickSync encode though so I couldn't tell you. Kevin would likely need to validate this, I'm just taking a guess... but I didn't read anything about being able to switch between hardware encode methods for what its worth.

 

That said as Kevin brought up, your GPU-based render might have certain or different limitations with export settings that your CPU-based render might not of had. What are the rest of your export settings? For example, I recall reading something like GPU encoding is not able to do 2-pass VBR, so if you set it to 1-pass instead it should allow Hardware Encoding to be available again.

 

So yeah at face value I don't think it's so much an issue with 14.2 breaking QuickSync, as it is 14.2 is saying "hey you have an eligible Nvidia GPU, let's use that instead" and NVIDIA GPU based hardware encoding (NVENC) has a different rulset than Intel CPU based hardware encoding (QuickSync).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 20, 2020

Copy link to clipboard

Copied

Well, unfortunately that's not the case, because with the Hardware Acceleration option not available, 14.2 falls back to Software Rendering with 0% usage on my GPU or my QuickSync encoder. Render times are now about 3 times slower than what they were on 14.1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
May 20, 2020

Copy link to clipboard

Copied

You're right, but you missed the part of my post regarding specific criteria GPU acceleration encodes have.

 

Yes, with Hardware Encoding greyed out and not selected, you are using Software Rendering. Not QuickSync, Not NVENC. No doubt about that.

 

That said my point was that depending on the rest of your encoding settings, GPU Hardware Encoding might not be eligible to use (whereas previously it was still ok with CPU Hardware Encode)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 20, 2020

Copy link to clipboard

Copied

I have a h.264 preset set up for rendering. When using the preset in 14.1 the option for Hardware Encoding is enabled. The same preset in 14.2 disables it.

These are the Export settings in 14.1:

arkadiuszk40353057_2-1589991821067.png

 

And in 14.2:

arkadiuszk40353057_3-1589992247420.png

 

It's the exact same project. Exact same files. Exact same presets.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
May 21, 2020

Copy link to clipboard

Copied

Hi arkadiuszk40353057,

 

Please check if "Hardware accelerated Encoding and decoding" option is enable under Edit> Prefrences > Media.

Try clean Driver installation ( During driver installation option choose custom click on next then check "Perform a Clean installation")  with following driver :

https://www.nvidia.in/Download/driverResults.aspx/159726/en-in

 

Test with H.264 High Quality 1080p HD Preset & High Quality 2160p 4K Preset

Regards

Abhishek 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...