Highlighted

Importing Subtitles .srt, all subtitles / captions get grouped at start

New Here ,
Aug 22, 2020

Copy link to clipboard

Copied

Hello All,

I did the following things -

1. Imported .srt file. Some of the lines look like this.

 

Arjit6C29_0-1598080633457.png

 

2. I changed the timecode in premiere pro cc 2019, to match the timings in milliseconds to the start of my subtitles. 00.01:020

 

Arjit6C29_1-1598080776389.png

 

3. I double click on my srt file in the project pane to check if timings are showing correctly.

Arjit6C29_2-1598080853391.png

 

4. Then I go back and drag the entire srt file in the timeline and I see all the captions are clustered in one corner.

 

Arjit6C29_3-1598080940639.png

 

5. I tried to expand manually by dragging the end, but it doesn't help.

Arjit6C29_4-1598080991787.png

 

This is my PP version.

Arjit6C29_5-1598081029784.png

 

and OS is Windows 10

 

Please let me know, what am I doing wrong. Thanks in advance.

 

 

Adobe Community Professional
Correct answer by Ann Bens | Adobe Community Professional

Set timeline to Timecode instead of Audio Time Units.

Think you need to reset all caps in the timeline manually.

Set the beginning of the file to 00;00

TOPICS
Editing, Effects and Titles, Error or problem, Import

Views

60

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing Subtitles .srt, all subtitles / captions get grouped at start

New Here ,
Aug 22, 2020

Copy link to clipboard

Copied

Hello All,

I did the following things -

1. Imported .srt file. Some of the lines look like this.

 

Arjit6C29_0-1598080633457.png

 

2. I changed the timecode in premiere pro cc 2019, to match the timings in milliseconds to the start of my subtitles. 00.01:020

 

Arjit6C29_1-1598080776389.png

 

3. I double click on my srt file in the project pane to check if timings are showing correctly.

Arjit6C29_2-1598080853391.png

 

4. Then I go back and drag the entire srt file in the timeline and I see all the captions are clustered in one corner.

 

Arjit6C29_3-1598080940639.png

 

5. I tried to expand manually by dragging the end, but it doesn't help.

Arjit6C29_4-1598080991787.png

 

This is my PP version.

Arjit6C29_5-1598081029784.png

 

and OS is Windows 10

 

Please let me know, what am I doing wrong. Thanks in advance.

 

 

Adobe Community Professional
Correct answer by Ann Bens | Adobe Community Professional

Set timeline to Timecode instead of Audio Time Units.

Think you need to reset all caps in the timeline manually.

Set the beginning of the file to 00;00

TOPICS
Editing, Effects and Titles, Error or problem, Import

Views

61

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 22, 2020 0
Explorer ,
Aug 22, 2020

Copy link to clipboard

Copied

What's the last entry in your SRT?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2020 0
Adobe Community Professional ,
Aug 22, 2020

Copy link to clipboard

Copied

Set timeline to Timecode instead of Audio Time Units.

Think you need to reset all caps in the timeline manually.

Set the beginning of the file to 00;00

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2020 1
New Here ,
Aug 22, 2020

Copy link to clipboard

Copied

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2020 0
mdbtaa LATEST
Community Beginner ,
Oct 29, 2020

Copy link to clipboard

Copied

Try setting the Import Settings in the Captions panel to the following. This is for Premiere Pro 2020 CC, 14.5.0 (Build 51)

 

caption-import.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2020 0