It's a YEAR that I have an incomprehensible problem: tripled render times after ANY update.

New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

I do not know where to look anymore, and now that rollbacks to 14.3.2 are no more a thing, I'm seriously cornered.

 

When I export my sequences from Premiere 2020 14.3.2 (they are .mov files captured from OBS and exported in h264), the export time is around 20 minutes: GPU usage is almost always capped at 90%.

When I do it since any further update, EVEN the 15.0... It becomes an hour, with GPU under 50%.

I do have hardware encoding and CUDA on, with a Nvidia 2080S.
I really do NOT know what to do. 

Things are less diverse between versions when turning off hardware and GPUs encodings, but then everything goes far beyone 50 minutes.

TOPICS
Export, Hardware or GPU, Performance

Views

198

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Delete your cache files as follows. 

The files are located here: Paste the whole line into File Explorer.
%UserName%\AppData\Roaming\Adobe\Common

 

I just delete the three folders:
Media Cache
Media Cache Files
Peak Files

You can also just delete the files inside. Ethier way, Premiere will create the one's it needs automatically. I do this before every upgrade. And/or if things seem to go strange.

MyerPj_0-1612377393038.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Sadly I do that all the time. It's not that. 
Two versions of Premiere are rendering at whole different speeds, and I tried everything: containers (mov/h264); CFR vs VFR... Nothing REALLY changes the fact that the newer performs always terribly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Recommendations and possible remedies

0) Avoid direct editing of VFR (variable framerate) footage. Things like Screen Captures, iPhone-, Zoom-, Twitch-, YouTube- and any other online videos. It's highly recommended to transcode such clips to CFR before editing. Tools people use for this: Handbrake, Avidemux, Shutter Encoder, ffmpeg, nvencc, or even a build-in Windows editor.

    If you still have same issues after transcoding or you just hope to avoid conversion, try next steps:

1) Manually clear media cache - close Adobe PP/AE/ME, go to cache location and clean/delete folders: Media Cache, Media Cache Files, PTX, Peak Files

2) Toggle off hardware accelerated Decoding in Preferences > Media... Remember to clear media cache and restart the app each time you change this settings, or after any app/driver update as well

3) Reset app preferences (with a backup): close all Adobe apps, go to My Documents > Adobe  and rename folders Premiere Pro / Adobe Media Encoder. Now start the app while holding Shift+Alt, open your test project and see if there is any improvements.
4) Try Creative Cloud Cleaner Tool, but remember that app versions below 14.9 are not available anymore from Adobe. So make sure you have some sort of backup if you still want to have older version(s)

5) Remember that none of the current GPUs support 2-pass VBR encoding. The app is just silently fall back to software mode without warning.

6) One more possibility for owners of Intel CPUs. Make sure that your display is not connected to iGPU port. Otherwise Premiere will consider dGPU as secondary and some functions may be unavailable or it just use iGPU instead.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

The only thing that I never tried is the Decoding change, but I'm afraid that's not the issue here... Thank you for your support, but sadly this thing is very weird. 

(I have a Ryzen 9!)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Hi Michele,

Sorry about this. Have you tried a clean reinstallation of your NVIDIA Studio drivers?

Thanks,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

The issue seems to be weirder than a driver thing, since it works perfectly on my old Premiere and absolutely Not on updated ones: since I had the good performance only on 14.3.2, I tried to to multiple tests and it's not something related to the kind of footage I put in: it actually is as I said a difference between how much resources are been used during render.  The updated ones does not do a lot of video encode using CPU, for example (17ish vs 75% of CPU used). 


I can reach the same results of the old one in the 15.0 only if I disable the HVEC acceleration WHILE using Voukoder as external plugin. It's weird and pretty dangerous for my worflow. 😞

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Sorry, Michele. Gain, try turning off hardware decoding. Restart the computer. This shows performance, but it may also help your exports. Please also make sure CUDA is enabled in Project Settings. Hardware Encoding should also be enabled on Export Settings.

 

 

Thanks,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

No, sadly it does not help, it just make things worse. 

I also tried to export a 14 hour long footage and on version 14.3.2 it takes 3 hours.
On anything after, 15 included, over 25 hours using less than 20% GPU and 15% CPU.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

del

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines