Jagged edges for new Essential Graphics Titler

New Here ,
Jun 13, 2017 Jun 13, 2017

Copy link to clipboard

Copied

Hi guys,

I'm running Premiere Pro 11.1.0 (222 Build).

I find that the Essential Graphics Titler is producing titles with more jagged edges as compared to the Legacy Titler. Same issue over a few machines. Is there a fix for this? See the screengrab attached.

(Above text is legacy, below is the new essential graphics.)

Screen Shot 2017-06-13 at 19.37.23.png

Views

11.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

Direct message. It should not any media, right? Just a graphic, I suspect.

Also some steps would be good... like, what do you actually want me to do with the Project/Graphic onc eI open it? (export method, settings, etc)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

Yeah exactly, should just be stuff generated in premiere. I will try to dm you that later today

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

My frustration comes from the fact that I cannot seem to get a consistent result, please forgive me if that is and has been coming across here. I mostly get renders where the weird anti-aliasing shows up interspersed with a few renders where everything looks mostly OK. I had one render where the EG actually changed slightly from bad aliasing to slightly better.

I did some additional test renders and had some interesting results. By interesting, I mean kind of different from the pic I posted on Jan. 8. The first thing that I found was that, at least in my case, hardware acceleration makes it worse. Yet going to software only doesn't fix the problem; it improves the final product but does not fix it

CUDA off.jpg

Notice the "O" in "One" of the line to the right side (and the vertical bar of the "D" in the line below), this is the "software only" result.

For now, I gotta take a break from this. I've rendered so many iterations in trying to troubleshoot this problem that I can't tell which one is which anymore.

@jstrawn My offer to get you this sample file still stands, I just don't know how to send it through a DM.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

I went back and compared your system to mine and they're not similar, but I'm having the same problem as you.  I'm on a mac with a Radeon graphics card and the only way to solve the problem for me is "software only" rendering.  My workflow has been to turn on GPU acceleration during editing and then turn off for rendering.  I haven't tried the updated Premiere that came out yesterday, maybe it's changed and gotten better, but I doubt it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

Luckily, the Legacy Titler is still around so my projects are fine for the time being. I'm going to go through your steps from your 11/6 post and try to get you something but for the time being see the sample below.

I've censored the logo out of my images but these are actual renders of a video file with the anti aliasing problem (I didn't want to waste space with seven separate uploads so I moved them around). So the only edits that have been done on this image are: blurring of the TV logo, placement and cropping so several can be seen at once, addition of green and red text.

Master with side by side.jpg

The "Premiere Screenshot" on top was an "Export Frame" of a rendered timeline; it is remarkably clear. The remaining samples were rendered to video files. Rendering in AME or directly from Premiere yielded the same results (both with "Import Sequences Natively" checked and unchecked). The issue persists in both a 1080 and 720 environment, and whether or not a layer is below on the timeline.

All frames shown are of the exact same frame. The Project Settings: 1280x720, Square Pixels, Progressive, 59.94 NDF. On the Outputs: the Comcast settings basically retain the original settings but end up as a 45 Mb CBR MPEG2, H264 local converts to a 20.97 frame rate with Upper fields first, and the rest are system presets.

The Essential Graphic: the font is "Gotham" using Medium, Book, and Bold styles. All layers are Pinned to the video frame. Each text layer has the same drop shadow applied: 0 0 0 RGB, 25% Opacity, 135° Angle, 2.0 Distance, 5 blur. I am going to try other fonts but my instincts tell me the results will be no different.

FWIW: I'm on a Dell Precision Tower 5810 with Windows 7 Enterprise, Intel Xeon E5-1650 v3 (3.5GHz) with 64 GB RAM, and a Nvidia Quadro K2200.

Jstrawn: I am willing to share my EG templates and project files with you privately; some elements are proprietary.

In the meantime I am going to avoid creating EG inside Premiere. I'll remake the above template in After Effects even though it's only a still frame or simply keep using my older Titler GFX.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

I tried the Software Only vs. GPU Acceleration and found the issue also is present (although there was one time when it rendered fine!).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

A quick and dirty fix that I have found is to add a channel blur all zeros to the graphic, anti-aliases all the text nicely in both preview and render with no blurriness.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 18, 2018 Jul 18, 2018

Copy link to clipboard

Copied

Thanks bryanrpromedia

That tricks work for me !!!!!!!

That's the only one that work here...

A quick and dirty fix that I have found is to add a channel blur all zeros to the graphic, anti-aliases all the text nicely in both preview and render with no blurriness.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 06, 2019 Jun 06, 2019

Copy link to clipboard

Copied

This fix worked for me, thank you. I shouldn't have to do it though!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

I have this problem too. I notice it randomly occurs with shadow applied and ONLY when softness is applied. I've tried different strengths of softness right down to '1' but the 'jaggys' still happen. If I deselect softness the text is sharp, if I remove shadow the text is sharp. So definitely a bug. Any news on getting it sorted Adobe? This thread has been going since November 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

Hello everyone! I made it work on my PC!!! Had the same issue, but somehow I fixed it, I did two things:

1. Updated all my drivers( I used Driver Booster) - it's a free software.

2. Updated Premiere Pro from  Adobe Premiere Pro CC 2017 (v11.1.1) Multilingual Update 3 to Adobe Premiere Pro CC 2017 (v11.1.2) Multilingual Update 4

One of these two things definitely helped, not sure which one, though! Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

Still waiting for Adobe to give us any additional info...

I simply hope that one of the future updates does NOT take away the Legacy Titler before correcting this issue.

*knocks on wood*

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2018 Mar 22, 2018

Copy link to clipboard

Copied

This is outrageous. I had not run into this problem until today. I've lost hours of my day and will need to delay a delivery to a client. Extremely bad experience and absolute crickets from Adobe.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 22, 2018 Mar 22, 2018

Copy link to clipboard

Copied

I continue to get notifications in this thread,so I thought I’d post although I’m sure it will not solve everyone’s issue. All my problems with essential graphics text looking jagged went away when I changed my sequence settings to progressive rather than upper field first. I don’t know why assets Created in premiere like text would work better with some sequence settings than others, but I have tried many combinations of sequence settings a and it seems that the titles agree more with progressive scan.  Hope that helps someone somewhere

-A

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

Ideally A thing (like one text layer inside one graphic) for the sake of reliability. Thanks in advance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

I was having the same issue randomly when using drop shadow...but then everything got fixed simply by checking "toggle animation for scale" in the essential graphics panel. See screenshot. Hopefully this will help some of you.

toggle.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

This Voodoo fix absolutely worked for me. I'm glad you got out there in front of this one for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2018 Jun 13, 2018

Copy link to clipboard

Copied

Thanks, so much. mazmaw. Checking that did the trick for me, as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 22, 2019 Jul 22, 2019

Copy link to clipboard

Copied

LATEST

Using the Essential Graphics text (with drop shadow) it looked fine in the preview monitor. Once I I exported the video, however, the text looked super jagged and aliased:

Jagged.JPG

But then I followed mazmaw123​ suggestion and checked the "toggle animation for scale" in the Essential Graphics panel and it made the exported text look perfectly smooth.

Fixed.JPG

Thanks, mazmaw123​ !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2018 Jul 12, 2018

Copy link to clipboard

Copied

Same problem here.

The jagged edges occur in the preview AND when I export.

I created texts from the tools panels. Most of them were right but four of them (but each one was an edited copy from the other) got jagged.

- No shadows.

- Tried preview with high quality.

- Sequence settings matched what some people suggested above (ARRI Cinema with progressive field).

What I did to solve the problem was recreate the problematic titles from the top menu. But it seems very annoying .. too much bugs on Premiere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2018 Aug 24, 2018

Copy link to clipboard

Copied

Same here, happens only on render, jagged text, I tried the solutions and didn't work for me, I'm using just the text tool. Premiere v12

Captura de pantalla 2018-08-24 a la(s) 11.17.10.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2018 Sep 10, 2018

Copy link to clipboard

Copied

I had exactly the same bug under the current Premiere version at work (12.1.1) and was able to fix it because "Composite in linear color" was not selected in the sequence settings.

Afterwards the problem was completely gone. I hope I can help you with that.

jaggedTittle.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2019 Feb 25, 2019

Copy link to clipboard

Copied

This problem is incredibly frustrating! I decided to go around the Essential Graphics shadow by adding an Effects drop shadow, and because it was a bit too subtle I doubled it up. This literally resulted in my text drifting diagonally across the screen as if I'd put a set of position key frames, but only on export. The preview looks fine and animates in place as it was intended to.

It also seemed to connect and respond to a clip cut on the layer below (when the clip changes on V1, the title on V2 jumps - Why would this even happen? I guess the drop shadow is responsive to what's beneath it in a sense, but this sort of behaviour is so random.

The only other effect on it is a Gaussian Blur which I used to improve the animation.

I then tried to add the Channel Blur potential fix which resulted in random diagonal animation again.

Clearly the algorithms and coding behind the Essential Graphics functionality is not entirely stable, it's really disappointing as someone who used to use AE to do all titles - I've now invested all my time into Premiere based titles on this project and the quality is a let down.

I'm now going to work without any shadow (despite visibility issues) and will possibly place my titles into another sequence to be subbed in once the rest of the video is set, then I will add a drop shadow to that entire sequence so it isn't directly connected to my Essential Graphics, and hopefully this will provide a better result.

Very frustrating to need to deal with problems that simply shouldn't exist.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines