Laggy/choppy playback in Premiere v15

Community Beginner ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

Hello,

When using Premiere v15.0.0 I am getting extremely choppy playback which makes previewing VERY difficult and slow.  The preview plays back at full speed for about 1 second then begins getting very chopping where it shows 1 frame every 1/4 second or so.  My computer is very adequately speced to run the porogram and I have setup the optimum drive setup as well but the issue persists.  I've also monitored my system resources and even when previewing they never go above 30% usage  Ive also followed a number of online guides and forum posts on similar issues but no solution has worked thus far.

Here are the specs for my editing PC:

  • Windows 10 Pro v10.0.18363
  • AMD Ryzen 7 3700x @ 3.6ghz
  • 32GB DDR4 @ 3200hz
  • Nvidia Geforce 2080
  • OS Drive: 512GB SATA SSD
  • Media/Project Drive: 512GB M.2 Drive
  • Cache Drive: 128GB M.2 Drive
  • Storage Drive: 2TB Western Digital HDD

 

From the fix posts and videos Ive seen, Ive already done the following:

  • Enabled hardware accelaration H.264
  • Cleared media cache
  • Set preview quality to 1/4
  • Turned off high quality playback
  • Turned off mercury transmit setting
  • Added Premiere as a dedicated GPU specific program
  • Run as admin
  • Changed audio hardware to ASIO and MME and changed output/input hardware

 

Im not sure what else to do at this point and its becoming a hinderance to whaere I cannot edit videos at all without spending hours to make simple edits.  I NEED a fix for this please.  Any help would be appreciated.

 

TOPICS
Error or problem, Performance

Views

139

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

Enabled hardware accelaration H.264 -  Actually you have to Disable it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

Let me give that a try.  Thanks for the response

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

Just disabled H264 NVENC encoding and decoding and im still having the same issue of stuttering and lagging.    

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

LATEST

Did you do app restart as required? Also, what is the color of the timeline render bar, red or yellow? what about different types of sources? Did you try to reset a workspace or all of the app preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines