Laggy playback Premiere Pro despite 1600€ PC

New Here ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Hi !

 

Posting for my girlfriend, she's using a newly acquired PC (specs below) yet she has hugely laggy playback, and quite the delay when pausing/playing the videos. We've checked the RAM allocated for the adobe suite (26GB) and optimized rendering to performance, lowered playback resolution to 1/4, set renderersetting to GPU Acceleration (CUDA), move all footage to SSD or HDD, purging media cache and Premiere is up to date. 

Her older laptop (Intel Core i7 6700, GTX 970m and 8GB RAM) runs the files better without having to render.

 

PC Specs :

Win 10 x64 

GPU : KFA2 Geforce RTX 2060

CPU : AMD Ryzen 7 3700X

RAM : 32GB DDR4 Corsair 

500GB SSD (premiere pro installed there)

2TB HDD

 

Is there any setting we're missing to check ?

TOPICS
Editing, Error or problem, Freeze or hang, Performance

Views

59

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Things to try/check:

0) Try Preferences > Audio Hardware > Default Input => select "No Input"

1) Do you have VFR footage on a timeline? Things like iPhone-, ScreenRecordings-, Zoom-, Twitch-, YouTube- videos, etc. It's highly recommended to transcode such clips to CFR before editing. Tools people use for this: Handbrake, Avidemux, ffmpeg, nvencc, or even a build-in Windows editor
2) Try to turn off Hardware accelerated Decoding in Preferences > Media... Remember to clear media cache each time you change this settings.

3) Always do clean media cache after any app/driver update: Preferences > Media Cache => Delete all media cache files from the system. Ideally do it manually - close Adobe PP/AME/AE, go to cache location and delete folders: Media Cache, Media Cache Files, PTX, Peak Files

4) Make sure that NVidia G-Sync/ AMD Freesync is off in driver control panel
5) Make sure you are using NVidia 'Studio' driver and not 'Game ready' one
6) Reset workspace: Window > Workspaces > Reset to saved layout
7) Try on/off "Mercury Transmit" option (Preferences > Playback > Enable Mercury Transmit)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines