Highlighted

Latest update to Premiere Pro 14.5 does not launch past the splash screen

New Here ,
Oct 30, 2020

Copy link to clipboard

Copied

I see the splash screen, then nothing. v14.5.

Task manager shows nothing past the launch CClibraries disappears - any help is appreciated.PPcc_tm.jpgPPcc_splash.jpg

 

TOPICS
Error or problem

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Latest update to Premiere Pro 14.5 does not launch past the splash screen

New Here ,
Oct 30, 2020

Copy link to clipboard

Copied

I see the splash screen, then nothing. v14.5.

Task manager shows nothing past the launch CClibraries disappears - any help is appreciated.PPcc_tm.jpgPPcc_splash.jpg

 

TOPICS
Error or problem

Views

53

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2020 1
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

Please tell us your system specs: OS version, Premiere version (you've already told us), amount of RAM, Hardware specs including graphics card and you might check to make sure your system meets minimum requirements

https://helpx.adobe.com/premiere-pro/system-requirements.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Community Beginner ,
Nov 04, 2020

Copy link to clipboard

Copied

Same problem, Adobe Premiere 2020 as well as Adobe Premiere 2019 both fail to launch. I have uninstalled and reinstalled 2020 v.14.5. The application starts opening and then just sits there spinning on the launch screen. 

 

Specs: OS Name Microsoft Windows 10 Pro, Version 10.0.19041 Build 19041. 16GB installed RAM. NVIDIA GeForce GTX 1060 and Intel UHD Graphics 620.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
Adobe Community Professional ,
Nov 04, 2020

Copy link to clipboard

Copied

2 thoughts.  People have reported issues when they've got multiple displays attached.  Might try disconnecting all but the primary screen and see if you can get started.  And there apparently have been issues with having 2 graphics cards installed.  You might do some research about disabling one or the other...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2020 0
valkerri LATEST
Community Beginner ,
Nov 06, 2020

Copy link to clipboard

Copied

UPDATE: I went into the office yesterday and Premiere worked on the same laptop that had not worked from home. The only difference is the connected external monitors. 

 

Working setup in office:

* Two connected external Dell V2412M monitors connected to UHD Graphics 620

 

Not-working setup at home

* One connected external ASUS VP28U monitor connected to UHD Graphics 620

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2020 0