Long videos produce laggy playback in Premiere Pro 2020

New Here ,
Nov 24, 2020

Copy link to clipboard

Copied

For the past couple days I've been working on a project with many different subclips from many different pieces of gaming footage. All footage has the exact same framerate, Codec, format, etc, but I've run into a problem with extreme playback lag with videos longer than 3 hours. All other pieces of footage, which span from 10 minutes to a little over an hour, run completely fine through the playback monitor with little to no issues. After subclipping moments I would like to use from the 3 hour video, the clips still have terrible framerate drops, thus generating the copious amounts of frustration you usually see from these situations. 

 

I've tried importing the 3 hour piece of footage into a new project, which had the same issue. I'm not sure if this is a bug and I'm also not sure if it's my computer not being able to keep up (which is highly unlikely considering all other pieces of footage are running fine). If anyone has any feedback or details I can provide, please leave them down in the comments.

TOPICS
Error or problem, Freeze or hang, Performance

Views

75

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

New Here , Nov 24, 2020
craigc83452101 New Here , Nov 24, 2020
Nevermind! Apparently the most recent version of Premiere Pro causes this issue. I downgraded a version below and my playback is back to normal. If anyone is having this problem as well, this may be the cause of it. Just another kink Adobe has yet to iron out.

Likes

Translate

Translate
Jump to answer Jump to answer
New Here ,
Nov 24, 2020

Copy link to clipboard

Copied

Nevermind! Apparently the most recent version of Premiere Pro causes this issue. I downgraded a version below and my playback is back to normal. If anyone is having this problem as well, this may be the cause of it. Just another kink Adobe has yet to iron out.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Dec 08, 2020

Copy link to clipboard

Copied

Hey! Lowly Zoom editor of 5 hour videos. The lag is killing me. I am on v14.6.0 - I think I am due an update. Which version works for you? I am losing my mind. THANKS.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Dec 08, 2020

Copy link to clipboard

Copied

I'm the lowly Zoom editor btw, to be clear. Sounded like an insult when I read it back. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
lucyve LATEST
Explorer ,
Dec 08, 2020

Copy link to clipboard

Copied

Ok. In case anyone sees this, I happen to keep a 2018 PPro v12.1 version on hand and MY 5 HOUR ZOOM VIDEOS WORK FINE IN THIS VERSION. I also tried it in DaVinci resove via an XML timeline export, and that handles them well too.  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more