Highlighted

Lumetri Not Compatible / Older Mac Version

New Here ,
Oct 18, 2020

Copy link to clipboard

Copied

Hello All!   Hope everyone is doing well.   I work on a Macbook Pro OS X Yosemite 10.10.5    My Preimer Pro version 7.72 (33) seems to have all the function capablities exept color correction, specifically Lumetri.   Is there some form of PP lumetri download out there?  For an older Mac such as mine?  Thank you!

TOPICS
Editing

Views

20

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lumetri Not Compatible / Older Mac Version

New Here ,
Oct 18, 2020

Copy link to clipboard

Copied

Hello All!   Hope everyone is doing well.   I work on a Macbook Pro OS X Yosemite 10.10.5    My Preimer Pro version 7.72 (33) seems to have all the function capablities exept color correction, specifically Lumetri.   Is there some form of PP lumetri download out there?  For an older Mac such as mine?  Thank you!

TOPICS
Editing

Views

21

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 18, 2020 0

Have something to add?

Join the conversation