LUTs problem after update Solution

New Here ,
Nov 25, 2017 Nov 25, 2017

Copy link to clipboard

Copied

A lot of users face a problem with LUTs when they try to open an old project with a new updated version of Premiere.That is: They find that the grading they did using Lumetri LUTs has completely changed, even if they load the old LUTs again.
The reason is that Premiere does not save a link to the "Name" of the used LUT, Instead, unfortunately it saves the number the LUT is sorted in the LUTs dropdown menu .

To solve that, I opened LUTs dropdown menu and noted the order number of the LUT updated Premiere is using instead of my original LUT (That was #5 in the menu) , I then closed Premiere and browsed to Lumetri LUTs folder, deleted all the LUTs (After saving a backup) and I let only the four first LUTs and put the LUT I used in the 5th order.

Everything is solved .

It's clear that this solution suggests that you used only one LUT for the whole project, but still, If you sort all your used LUTs according to the order Premiere saved in your original project, you will solve the problem .

P.S: In Lumetri folder, the LUTs are sorted by name, and that's the same order used in LUTs dropdown menu in the software .

.

Views

4.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Apr 14, 2018 Apr 14, 2018
The problems you are experiencing are caused by tampering with the LUTs within the application package - please do not do this.  The safest way to proceed at this point is to completely reinstall PPro and AME so the LUT directories are restored to their default state as intended by our engineers.  You will then need to remove all LUTs from your project and reapply them.  I know this is inconvenient, but it really is the safest way to make certain your project will render as intended.If you are u...

Likes

Translate

Translate
LEGEND ,
Nov 25, 2017 Nov 25, 2017

Copy link to clipboard

Copied

Adobe engineers have stated that users are not meant to alter the contents of those LUT folders on the hard drive.

Instead, use the Browse button to add third-party LUTS.  If you create a LUT folder in your Creative Cloud Files, that LUT will be available to all Adobe software on any system you're signed into.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 25, 2017 Nov 25, 2017

Copy link to clipboard

Copied

As Jim says, the engineers tell us that adding things to the Input LUT folder for the Basic tab (folder is called "Technical" in Program files) can be done. But both PrPro and MediaEncoder are expecting to have the same LUTs in the same order in their respective Creative folder locations.

So ... if you do mess with things in the PrPro Creative folder, you need to do exactly the same thing in the ME Creative folder.

JIm's comment about storing your LUTs in the cloud space your CC account includes is a good one. Also, if you store on your computer, the Custom line is a good one to use, as once you've gone to a folder with that option, it will automatically open that folder the next time you search with the Custom option. So if you use a particular folder on disc, you'll always immediately go to that folder to select a LUT.

Doesn't give you the preview monitor to see the various options, though.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

I've applied Fuji ETERNA 250D Fuji 3510 (by Adobe) LUT from lumetri look presets in the adjustment layer, colors look pretty good in software but while rending videos got converting in greyscale (black and white).

Does anyone have clues for this issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

There's not much there to go on, Ankur.  Use the guide below to post up some details.

How To Ask For Help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

The problems you are experiencing are caused by tampering with the LUTs within the application package - please do not do this.  The safest way to proceed at this point is to completely reinstall PPro and AME so the LUT directories are restored to their default state as intended by our engineers.  You will then need to remove all LUTs from your project and reapply them.  I know this is inconvenient, but it really is the safest way to make certain your project will render as intended.

If you are using several custom LUTs and want them to show up in the Lumetri dropdown menus we have a solution which is newly available in the most recent update (2018 - version 12.1).  You can install your LUTs into a specific folder in your user library and Lumetri will scan them in. Here are steps to set that up.

Mac

  1. From the finder, use the Go menu to navigate to this directory: ~/Library/Application Support/Adobe/Common/
  2. Create a folder named LUTs
  3. Create two more folders inside the LUTs folder: Technical and Creative
  4. Copy technical conversion LUTs (often called camera LUTs) such as LOG to Rec709 into the Technical folder
  5. Copy creative LUTs such as day-for-night, B&W, or anything that is just a stylistic look into the Creative folder
  6. Restart PPro
  7. Technical LUTs show up in the Input LUT dropdown inside the Basic section in Lumetri
  8. Creative LUTs show up in the Look dropdown inside the Creative section in Lumetri

Windows equivalent directories:

~\AppData\Roaming\Adobe\Common\LUTs\Technical

~\AppData\Roaming\Adobe\Common\LUTs\Creative

This is a convenient and easy way to add as many LUTs as you like to the Lumetri dropdown menus and this will persist through updates - unless of course you delete or change this directory. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

Francis, THANKS for the development team adding this into the app!

When the code was changed about 2015.3, so that putting our own LUTs/Looks into the Tech & Creative folders caused issues, it was such a pain. This finally fixes that issue, and is SO appreciated!

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

This doesn't correct the problem at all. I have just tested this method three times and the same problem persists. I have opened a previous project from two years ago, client wants a simple change, but now the LUT that it was referencing is in the incorrect place and therefore a five minute job now has become a whole day re-colour job. (who can remember which LUT they used two years ago?)

Francis, I tried your method of putting LUTs into the /Common/ folder within the library preferences however the same issue applies. PPro will read the LUTs from there, great, however it will still affect the LUT order and therefore change the LUT that Lumetri references.

This is quite frankly unacceptable.

Unless I am missing something?

The only workaround I can see is to rename all custom LUTs so they have a "z" before them to make sure they come after the order of the LUTs provided with the default software.

But I wish I knew this for the last couple of years. Every single project I might need to go back to will need fixing because of this.

Seriously this is just a rubbish way of dealing with this, just return the reference paths to absolute (named) paths again and this issue will go away.

Seriously thinking about moving to resolve as main editing program.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

Adding LUTs to the proper Library location changes the order as viewed, but does NOT change the reference system to the internal LUTs, so that works perfectly correct across even version changes.

So your comment that it still changes the LUT referenced by Lumetri is incorrect ... Pr tracks the internal LUTs and external ones separately.

If you are getting any other behavior please give further details.

And I have no interest in going all the way into the program files to move LUTs in and out. As designed works. I've used it heavily over two years and several version changes without any issues whatever.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2019 May 23, 2019

Copy link to clipboard

Copied

Hi Neil,

I will go through my steps and you can tell me if it was the incorrect procedure.

Step 1: Removed custom LUTs from /applications/pp/contents/lumetri/LUTs

Step 2: Created new folder(s) in /library/application support/adobe/common/LUTs (creative and technical)

Step 3: added custom LUTs to these folders

Step 4: re-opened PP, order was changed and LUT was referencing order, not name. (order was alphabetical and included both custom and default LUT locations.

I repeated this process three times, including taking out custom LUTs from both folders, and keeping them in both folders. Each time the project was referencing different LUTs, according to the order the were in the folder structure(s).

I am unsure if this has anything to do with opening up an older project, I will test this now with the most up to date version of Premiere.

You can let me know if this is the incorrect procedure to follow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

First thing ... looking at my last posts, I was responding quickly from my phone, and they come across as rather curt. My apologies ... as I do fully understand your frustrations. And concerns.

I gave a longer response in the other thread this time ... but I do understand your concerns. And frustrations.

Moving forward, using the correct process does work through version changes and updates without troubles. It's the transition that is painful.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2019 May 23, 2019

Copy link to clipboard

Copied

Hi Neil,

I have tested this with the newest Premiere Pro and adding more custom LUTs into /library/application support/adobe/common/LUTs/ does still change the LUTs that PP is referencing. Even though it is in the 'common' folder rather than the default folder.

Again, I will through my steps in case I am doing something incorrect.

Step 1: To test I picked no5 in the default technical list "arri universal hd".

Step 2: Closed PP.

Step 3: Added two custom LUTs (names beginning with a to make sure they are early in the list) to /library/application support/adobe/common/LUTs/technical

Step 4: Re-opened PP

Step 5: The new LUTs were in the Lumetri basic input column AND the file was referencing no5 in the LUT order, which is now "alexaV3_K1S1..."

Am I doing something incorrectly or does adding/deleting LUTs in the 'common' folder affect which LUT PP references? As it seems to on my machine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2019 May 23, 2019

Copy link to clipboard

Copied

LATEST

That is very odd, I can't replicate. I'm constantly changing the LUTs in both my Tech and Creative folders, and never gave an issue.

Something is really screwy there.

At this point, I might nuke Premiere. Download and rubtge Adobe CC Cleaner Tool and use it for both uninstall of Premiere and the cleanup.

Reboot and reinstall from the CC app.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines