Mercury playback software only

Community Beginner ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Hi, everyone!


I'm on Windows 10 Pro (version 20H2, OS build 19042.844, Windows Feature Experience Pack 120.2212.551.0). My PC specs are: i7 7700K 4.2 GHz, GTX 1080 Ti 11 MB, Maximus 9 Formula, 32 GB DDR4 RAM.


Lately (sorry, I cannot point at the exact date) I have noticed while editing in Premiere Pro (v14.9.0. build 52) that my video clips are lagging a lot, which makes editing very uncomfortable. Not only the DJI drone footage (which honestly was never fluid), but also other cameras' footage, which previously was smooth for me.


After doing some research, I realized that I used to work with the Mercury GPU Acceleration CUDA selected, but now the selection is grayed out (showing Mercury Playback Software Only). No matter what, I cannot change the selection.


I did some Google reading and some folks suggested reinstalling video drivers. I am on the laterst driver (461.72), as Adobe recommends. So I tried clean reinstalling (even using the DDU software). Tried both the Game Ready and the Studio ones. Then tried to roll back to the previous driver. Nothing. Still no selection possible. Also, if it matters, I checked with GPU-Z and CUDA is not marked, I don't know why.


What may be happening? I am very frustrated, as my video edition is so slow, lagging and hard to bear now. Thank you very much in advance for any suggestions on what to do.

To be clear: I am not a computer specialist and my IT skills are limited to, say, average at most.


All the best, Rafal

 

prgpuz.png

TOPICS
Performance

Views

178

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Can someone possibly help me somehow or point to the right direction?


In the meantime I have used NVIDIA support, but they just told me to use DDU and install earlier graphics dirvers, which I did, but there is zero difference. In the meantime there was a Windows update plus Adobe update, but neither changed anything.


Why is the Premiere footage so laggy now (it was so nice for a few years) and why can't I select its GPU acceleration no matter what?


Thank you so much in advance,
Rafal

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Something is wrong with GPU driver or OS itself. Remove/toggle off antivirus if there is any. Turn off OS driver auto-update feature. System event log may provide some hints too.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Thanks a lot for your reply!
My Windows Defender is off (no extra antivirus), as well the driver auto update.
As for the OS, I was also thinking about it and though it's going to be a real pain (I have so many things installed and so many projects open), I do consider it if nothing elese (graphics related) helps. 🙂

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

If among "so many things" there is any Game/3D development software, that easily can be a reason:

(Epic Unreal Engine Launcher) laggy playback of all vi... - Adobe Support Community - 11785480

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

No, I'm not a gamer and do not develop in 3D. I may have not be clear enough, sorry for that.
By 'many" I meant mostly usual stuff (browser, documents, video clips, images, GE, Skype, graphics and video edition software, etc.). Plus I did not install anything (except for Adobe, OS and NVIDIA updates) in the recent period when things started going badly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Hi @Rafal Haczek, I've seen this happen with students. I'm guessing it is a driver issue. Can you please install the most recent Studio Driver for your GTX 1080 Ti? You can find them here:

https://www.nvidia.com/Download/driverResults.aspx/170888/en-us

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Thank you very much for your reply, Joost!

As I showed and described in my initial post, I am on the latest driver, exactly the one you link to.
Tried the Game Ready ones too and a few earlier ones. I used clean reinstall, DDU, Windows Safe boot, etc. Nothing. 😞

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Is it possible to check CUDA (at the red arrow on the TechPowerUp panel. Pr needs CUDA to enable GPU hardware acceleration.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

No, you can't check (choose) it. This is only to show whether particular functions are active/available.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines