Mercury Transmit either does not work or chooses the wrong monitor

Participant ,
May 14, 2019 May 14, 2019

Copy link to clipboard

Copied

I am having a frustrating issue with my Mercury Transmit function on Premiere Pro (13.1.2) and After Effects (16.1.1). Every time I open either program after my computer has been shut down, Mercury Transmit is no longer working correctly. It usually does not transmit anything, or sometimes but rarely, it is transmitting to a wrong monitor.

Frustratingly, when I go in to Preferences > Playback in Premiere (or Preferences > Video Preview in AE) and I switch the transmit to the correct (4K) monitor, when I hit OK, it either does not transmit, or transmits to an incorrect 1080 monitor. When going in to the preferences after this error, it shows the wrong monitor check box is checked.

Example in Premiere:

I go in to Preferences > Playback and select my 4K monitor as the monitor I want to transmit to:

Screen Shot 2019-05-14 at 1.05.32 PM.png

After hitting OK, nothing is transmitting, so when I go back in to my preferences, the wrong monitor is selected:

Screen Shot 2019-05-14 at 1.07.17 PM.png

My computer recognizes all of the monitors correctly, and I even took advice from another post where I unchecked 'Automatically rearrange Spaces based on most recent use' in Mission Control. That didn't help.

Screen Shot 2019-05-14 at 1.02.01 PM.png

Screen Shot 2019-05-14 at 1.11.54 PM.png

Workarounds that have worked to solve this issues for me in the past are now not working:

  • Toggling "Enable Mercury Playback" off, closing preferences, opening again and toggling it back on
  • Switching from a Thunderbolt>HDMI to a HDMI>HDMI
  • Resetting all program preferences (which is an unacceptable solution)
  • Restarting my computer

This is a very time-consuming and infuriating problem. Does anyone have any theories why my computer is acting this way and how I can fix it?

Views

5.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 14, 2019 May 14, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 14, 2019 May 14, 2019

Copy link to clipboard

Copied

There is a bug in this version, and yea, it's in both Ae and Pr. So ... we are waiting for the release with the fix for this to be 'dropped' ... and no idea when that might be. I'm hoping for "soon" myself. We'll know when we know, as always.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2019 Dec 12, 2019

Copy link to clipboard

Copied

Pretty annoying bug.. Is there a way to work around?

I just need my preview/comp screen on an fullscreen on my second monitor (After Effects.

Any fixes yet? Searching everywhere and can't find a solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

I have exactly the same issue, but on Windows and using 13.1.2

Annoyingly, if I move the Premiere program to my second monitor (the one I want to mercury transmit to) and select to transmit to my first monitor, it works. However, with testing this using a 3K anamorphic clip, the scaling is completely off and does not resize to the monitor it is outputting to. Both monitors are 3840x2160 but with different size Windows scaling options, though this has never been a problem before.

For the meantime I guess I will have to not use the second monitor for colour correction, which is extremely unhelpful, which is what it is set up for.

Anyone got any fixes?

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

As noted, it's an acknowledged bug and we are waiting for the next bug patch release. Sadly, no way around it for most of us.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

Interesting idea to swap around where the timeline and other windows sit on another of my 3 screens and see if, after changing the transmit monitor settings, PP somehow starts to transmit again.  Will let ya know, but confidence ain't runnin' high... MacPro 2013 10.13.6

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

Interesting idea to swap around where the timeline and other windows sit on another of my 3 screens and see if, after changing the transmit monitor settings, PP somehow starts to transmit again.

Sorry for the bug. That truly stinks.

Actually, you may find it interesting that BITD, it was crucial to set your Program Monitor on the same screen as the main output of your video card (In my case the Targa 2000 Pro). The other monitor could only carry the lower overhead Project Bin window.

With 4K workflows and tons of GPU accelerated effects going into today's modern timelines, I'm not surprised at all that your GPU might eventually just run out of memory given all that users throw at it.

My 2 cents, anyway.

340_truevision_complete_hq.jpg

The Targa 2K Pro with optional "daughter" card for 300KB component SD output & FCP 1.0.1 to Beta SP (circa 2000).

Cheers,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

Has this been fixed? I just connected a 4k monitor to my 2019 iMac (USB-C to Diplay Port) and it only works when Premiere Pro seemingly outputs Mercury Transmit to a 1920x1080 monitor option (which I don't have). The OS recognizes the monitor's full 4k resolution. Odd...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

What does Premiere show for that monitor in the Transmit Out options?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

It just lists a 1440 monitor and a 1080 monitor (none of which exist), even though it’s a 2160 (which the system confirms). Only the 1080 selection sends anything to the external monitor. Strange.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

Premiere is seeing something from somewhere that shows the monitors as having a 'native' size different than you're expecting. So ... what are the brand/product numbers for the two monitors? What ICC profile is the Mac seeing for them?

 

And which version of Premiere also?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

I only have my iMac’s native 5k P3 monitor and the new BenQ PD2700U. Radeon Pro 580x with 8GB RAM, system has 64GB memory. The system simply says “BenQ” for ice of the external monitor. I am going out Thunderbolt 3 to an OWC 4M2, then looped out from there to the DisplayPort of the BenQ. Latest version of Premiere Pro, but a couple versions back on OS (I’d have to doublecheck).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

I'm wondering if Premiere can't "see" through the external box?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

Possibly, but why does it show two monitors in resolutions I don’t have? Everything seems to be working otherwise. Seems like just a labeling issue.

-Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

I think what I mean is that Premiere can't see the proper metadata from those monitors through that system.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

@R Neil Haugen Would a usb-c to hdmi adapter casue similar issues as listed here (diff monitors labeled that are not available)? I am using a Samsung 4k tv as a secondary display and getting very similar results as Chris (aka @housejacket ). I've tried all 3 recent versions of Premiere (14.5-14.7) adn it was initially, freezing up when trying to open a project. If I disconnected the secondary display from my iMac, Premiere would work just fine. Now, it's opening projects again like it should, but I am having no luck with the preview showing up on the secondary monitor. Feels like a bug with Mercury Transmit...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

That might be the case. I don't suppose the computer has an HDMI out, or the TV a USB-C in ...

 

I'd like to see if @Kevin-Monahan might be able to pop in, he's got a lot more experience and knowledge of Mac connections & other such issues.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 31, 2019 May 31, 2019

Copy link to clipboard

Copied

Same issue on my system. I select the 2nd screen and Premiere just deselects it, or picks the main  monitor. Only one monitor configuration "works" but is very very stuttery.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

I've literally been clinging to V - 11.1.2 trying to avoid bugs and for some reason decided now was the time to update. Just like that, there goes mercury transmit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2019 May 28, 2019

Copy link to clipboard

Copied

I've been trying to bring more attention to this bug as I think the length of time it has been unaddressed is completely ridiculous on Adobe's part.  Please vote here so we can finally get this essential feature fixed:  https://adobe-video.uservoice.com/forums/911311-after-effects/suggestions/37282141-mercury-transmit-...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2019 May 28, 2019

Copy link to clipboard

Copied

Yes, it's good to get the data on their system.

However, they acknowledged this one a while ack and like all bugs, they will release the patch when they feel they have this and a number of other bug fixes ready to release.

It's not being ignored at all. Not that any of us would mind a quicker release of the patch.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2019 Jun 02, 2019

Copy link to clipboard

Copied

With respect!

Sorry but when Adobe sale a "professionnal" product at this price to professionnal editor or business, they have to react faster then waiting for multiple bugs to release a patch. I have multiple editing room and this problem is really a mess with clients when you can't use multiple display. For me, it's a amateur service!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2019 Jun 02, 2019

Copy link to clipboard

Copied

Can't say I disagree. Like any other business they have their policies. And there are always bugs in process of fixing. This or Resolve or name your app.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

I agree what has been said. 

In particular as we have now Version 17.1.4. and the FIX is not induced yet.
It seems Adobe is not planing on fixing this anytime soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines