Mercury Transmit only on primary monitor

Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

My setup:

latest 15" Macbook Pro

latest Adobe Premiere ProCC

HP Monitor

I want my big Monitor as a primary display and for working on premiere pro.

macbook should just be the secondary monitor for full playback.

but it's not working.

it only works when i make the macbook the primary display and then rearrange all the windows.

then everything works.

that sucks.

any ideas?!

IMG_8712.jpg

Bildschirmfoto 2018-08-09 um 21.07.54.png

Bildschirmfoto 2018-08-09 um 21.08.20 (2).png

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Aug 10, 2018 Aug 10, 2018
I ended up fixing it by going to System Preferences, Mission Control, and disabling Displays have separate spaces!HOOORAAAYY! (now everything works nice and smooth and as it should)

Likes

Translate

Translate
Adobe Community Professional ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

I've attempted to duplicate your setup and had no issue using either my monitor or my laptop as the display. I did notice you have an AirPlay display selected under your Display preferences in OSX. If you set that to off, does that work?

desk.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Yes the setup used to work with my 4yrs older macbookPro.

but i got a brandnew one yesterday.

AirPlayMonitor is set to "aus" german for: "off" / "disabled".

there aren't any other options neither.

Bildschirmfoto 2018-08-09 um 21.35.37.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Ah gotcha! The only other thing I noticed was if my Premiere window even slightly overlapping my 2ndary monitor, the video would not show up. Can you make sure your Premiere edit window is not overlapping onto the 2nd monitor (the laptop monitor)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

It's not overlapping. This was one of the rare advice i found online.

but it's def. not overlapping i even made it super small to be really really sure.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

How is your monitor connected to your Macbook? Directly or through a hub/router/signal convertor?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Display > HDMI > HUB > USBC

IMG_8979.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

you think this can cause trouble with mercury transmit even if beside that everything with the displays works?

(anyway, first thing tomorrow morning when stores open in germany i will get something else. what is the best way to connect a macbookpro with only usbc to a hdmi monitor?)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Check these out:

Mercury Transmit Issue with full screen playback to second monitor.

Video preview (mercury transit) not working in AE!

Others are having similar issues with USB-C hubs. The problem I see is that the hub does much more than pass the video signal. In many cases it's passing power, USB, video, and whatever else is daisy chained in there. Plus, not all hubs are created equal.

Regardless, it looks like mercury transmit is not correctly interfacing with the hub bus. While this may be an Adobe issue, it's more likely an Apple/hub problem that will not be easily resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

I will try in a few hours when stores are open. I will let you know if it worked!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

manuel, if you're going to buy anything, I recommend getting something like this: Amazon.com: CHOETECH USB C to HDMI Cable (4K@60Hz), 6ft/1.8m USB Type C to HDMI Cable (Thunderbolt 3...

A USB-C to HDMI cable (or whatever format your monitor supports). You need to try to bypass the hub functionality.

Another note: This is my personal idea and not endorsed by Adobe. There is ZERO guarantee that purchasing anything will resolve your issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

Bought a usbc to hdmi cable. But problem stays the same.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

Also tried an older version of premierepro. but problem stays the same.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

Also called the support hotline. They couldn't help me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

tried it with a different monitor from a different brand. but problem stays the same.IMG_6093.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

things got even worse.

its not working at all. wtf.

take a look. please help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

I ended up fixing it by going to System Preferences, Mission Control, and disabling Displays have separate spaces!

HOOORAAAYY! (now everything works nice and smooth and as it should)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 10, 2018 Aug 10, 2018

Copy link to clipboard

Copied

Glad you were able to figure it out! Interestingly enough, on my Macbook Air and external display, it worked fine with that option selected. Might just be an odd aspect of the new MacBook. Regardless, good to know!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2020 Apr 08, 2020

Copy link to clipboard

Copied

So I'm having the same problem since the last upgrade in Premiere 2020, in the past everything was working so good, but now I have the same problem, actually I follow all the thread and try all your solutions but it doesn't work.

I'm working in a MacBook Pro 13' late 2012 with 1T SSD and 16G of RAM. I have conected my Second Monitor by a HDMI converter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Also, correct me if I am wrong - but isn't the attached display (either laptop lcd or iMac monitor) always display #1 in the settings panel? It seems to be so on my iMac with 27" thunderbolt display attached. If you move the menu bar to the external display, that display is still display #2.

MtD

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

here #1 and #2 change dependig on where i moved the bar. display.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

LATEST

I know this thread is like 3 years old and there is a solution to this, but I think I found a better solution if anybody wants Displays have seperate spaces

ok so the problem I had was I had about 4 spaces ( virtual desktop) open and I usually work on desktop 2, my secondary screen is labeled desktop 4 BTW.

whenever I enable mercury transmit to my 2nd monitor, it appears on my primary monitor.

yes, disabling displays have separate space did "partially" solve the problem. I say partially because if you use a full-screen app/window, this will render the 2nd monitor useless. 

so the workaround was I created a new space and moved whatever was on Desktop 2 to the new space and deleted desktop 2 and this fixed the problem for me.

I think for some reason the system recognized desktop 2 as monitor 2 which is a weird behavior because that would mean I would have up to 4 monitors listed in mercury but there wasn't.

well anyway if anyone needed a solution without disabling displays have separate space, here's your solution. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines