Highlighted

Metal Engine always renders 8 Bit

Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi,

 

I have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7

I have 10 bit video files and while working with these files I see a lot of banding on the sky.

I have tried different configs to understand the issue.

My sequence settings use Maximum Bit Depth.

When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.

And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.

But When I swicth my project settings to openCL. I immidiately see the difference. The sky gradient is perfect. Even if i switch off the MAximum depth in sequence settings the banding is slightly better then the Metal engine.

Check out the following images:
metal_off.jpgmetal_on.jpgopencl_off.jpgopencl_on.jpg

 

when I render out these clips with Maximum Depth /16 bpc the banding occurs when using Metal on the final output whereas when opencl is used output is perfect. You can check the files from the below link.

 

https://we.tl/t-WbSRKkbU3X

PS: When these same files checked on a PC with a 1080 graphics adapter (cuda engine). Maximum bith depth turned on there is no banding and rendered with maximum bith depth, output file is perfect. 

 

Seems like an AMD / Metal releated issue.

 

Any thoughts ?

 

Koray Birand


 

TOPICS
Export, Hardware or GPU

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Metal Engine always renders 8 Bit

Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi,

 

I have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7

I have 10 bit video files and while working with these files I see a lot of banding on the sky.

I have tried different configs to understand the issue.

My sequence settings use Maximum Bit Depth.

When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.

And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.

But When I swicth my project settings to openCL. I immidiately see the difference. The sky gradient is perfect. Even if i switch off the MAximum depth in sequence settings the banding is slightly better then the Metal engine.

Check out the following images:
metal_off.jpgmetal_on.jpgopencl_off.jpgopencl_on.jpg

 

when I render out these clips with Maximum Depth /16 bpc the banding occurs when using Metal on the final output whereas when opencl is used output is perfect. You can check the files from the below link.

 

https://we.tl/t-WbSRKkbU3X

PS: When these same files checked on a PC with a 1080 graphics adapter (cuda engine). Maximum bith depth turned on there is no banding and rendered with maximum bith depth, output file is perfect. 

 

Seems like an AMD / Metal releated issue.

 

Any thoughts ?

 

Koray Birand


 

TOPICS
Export, Hardware or GPU

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2020 0
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

There may be something on your system that is somehow interfering with things, or it could be as you posit, an AMD/Metal thing. Either way, it would be good to post the above on their UserVoice system so the engineers see it. This site is user-to-user peer support, that page is the portal to the engineers.

 

You should be able to get 10 bit files out even without the Max Depth button involved. And should see 10 bit files on your system while playing back.

 

For fully exported files to a 10/12 bit format/codec, what does the export show for bit depth in say MediaInfo ?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Mediainfo does not show the bit depth of the file. But I can tell that this banding is a typical 8bit issue. 
mediainfo.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

Yea, for some reason on some ProRes files MediaInfo doesn't show the bit depth, which is annoying.

 

And no question about the banding/bit-depth problem, you showed that very clearly. I was just curious what bitdepth Pr actually processes the file to for exporting.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
kbirand LATEST
Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Thanks for the suggestion. I have filed the problem to Uservoice system. I am going to test this on other macs now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 1