MP4 Video Imports Audio Only

New Here ,
May 20, 2016

Copy link to clipboard

Copied

I recently bought a Canon EOS Rebel T6i DSLR camera, and I've been having some issues uploading video from it into Premiere. Currently I'm using Adobe Premiere CS4, but whenever I import the the MP4 video file, it only imports the audio but not the video.

I've looked at a variety of forums to fix this, but so far I've had no luck. I've tried changing the file extension to mov, re-downloading Quicktime, and installed other codecs, but nothing has worked. Any suggestions? Currently I'm using a PC with Windows 7.

Adobe Community Professional
Correct answer by Ann Bens | Adobe Community Professional

I assume the camera is a quite new model, CS4 is quite old.

Could be a codec problem.

Make sure you copy the entire card before importing into Premiere.

Convert with HandBrake see if that will help.

Can you upload a short clip?

TOPICS
Import

Views

94.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

MP4 Video Imports Audio Only

New Here ,
May 20, 2016

Copy link to clipboard

Copied

I recently bought a Canon EOS Rebel T6i DSLR camera, and I've been having some issues uploading video from it into Premiere. Currently I'm using Adobe Premiere CS4, but whenever I import the the MP4 video file, it only imports the audio but not the video.

I've looked at a variety of forums to fix this, but so far I've had no luck. I've tried changing the file extension to mov, re-downloading Quicktime, and installed other codecs, but nothing has worked. Any suggestions? Currently I'm using a PC with Windows 7.

Adobe Community Professional
Correct answer by Ann Bens | Adobe Community Professional

I assume the camera is a quite new model, CS4 is quite old.

Could be a codec problem.

Make sure you copy the entire card before importing into Premiere.

Convert with HandBrake see if that will help.

Can you upload a short clip?

TOPICS
Import

Views

94.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 20, 2016 0
Adobe Community Professional ,
May 21, 2016

Copy link to clipboard

Copied

changing the file extension to mov

Try changing them to mpg.

And on a side note dont every install codecs (unless you need a particular one like mjpeg etc) as they can realy mess up your computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2016 0
New Here ,
May 21, 2016

Copy link to clipboard

Copied

I've tried changing them to mpg as well. Same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2016 0
Adobe Community Professional ,
May 21, 2016

Copy link to clipboard

Copied

I assume the camera is a quite new model, CS4 is quite old.

Could be a codec problem.

Make sure you copy the entire card before importing into Premiere.

Convert with HandBrake see if that will help.

Can you upload a short clip?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2016 2
New Here ,
May 21, 2016

Copy link to clipboard

Copied

The camera is fairly new, model's just under 2 years old, but fortunately Handbrake worked. The clips upload properly when I run them through the program.

Probably will upgrade to Adobe CC soon, seems to be worth the investment. Thanks for the help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2016 0
New Here ,
Aug 03, 2016

Copy link to clipboard

Copied

I am going crazy to try and find the answer to this. I was using CS6 with my Canon T5i and it read my video files completely fine! Now that I am updated to CC it only imports my files as audio. Everyone one says, re-download QuickTime, or that PP can't read H264 but it was working before and now it won't! This is such BS, this program is expensive. I go through a lot of video, I don't have time to convert each one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 03, 2016 3
Adobe Community Professional ,
Aug 04, 2016

Copy link to clipboard

Copied

Clean out media cache and rename top folder the footage is in and try again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2016 0
Community Beginner ,
Dec 15, 2016

Copy link to clipboard

Copied

I had this problem with a project I had open over night and just restarted Premiere and reopened my project and importing was working again.  (Note I also cleared cache before restarting, but I do not think it did anything as after cleaning I tried importing with no success)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2016 0
Community Beginner ,
Dec 19, 2016

Copy link to clipboard

Copied

Now Im having the same problem again and clearing cache/ restarting is no longer working.  Adobe please try and find a fix for this, I am wasting so much time just trying to put video in a video editing program.  Also tried renaming top folder

EDIT:

I figured out the problem, I made a tutorial for everyone and so I can remember in a few months time.

How to fix video import bug to Premiere Pro CC 2017 timeline - YouTube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2016 24
Adobe Community Professional ,
Jun 08, 2017

Copy link to clipboard

Copied

You should import via the Media Browser instead of dragging from Explorer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2017 0
Community Beginner ,
Jun 12, 2017

Copy link to clipboard

Copied

I believe I tried that as well.  It was because the video track line was not selected (showed at start of video)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2017 3
New Here ,
Jul 24, 2017

Copy link to clipboard

Copied

Do what davey suggested. Seriously took 5 seconds.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2017 2
New Here ,
Aug 26, 2017

Copy link to clipboard

Copied

The problem is actually not that but thanks for the info...just incase.

My problem is that when i upload a video file, I only get and audio of the video but not the video.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 6
Community Beginner ,
Aug 26, 2017

Copy link to clipboard

Copied

I am just rendering a video to upload to youtube for how you should REALLY be importing to Premiere as I write this.  As Ann Bens​ suggested the media browser is really the big fix.  But even how you use that has a trick to it though as dragging directly from media browser only works with some footage.

@nalitye Just to make sure this is the same problem you are having.  When you say upload a video file, do you mean to Premiere or when you upload your video file to something like youtube?  And more specifically when you try to place video files into your timeline?

EDIT:

Here is the video I just made to stop this problem from happening.  Let me know if this fixes all problems around this area.

This is a replacement for my previous video I posted as it was still not how you SHOULD be using Premiere

How to properly import audio and video to Premiere Pro - YouTube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 2
New Here ,
Dec 30, 2017

Copy link to clipboard

Copied

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2017 0
New Here ,
Feb 14, 2018

Copy link to clipboard

Copied

DaveysWorld Thank you. Lost hours yesterday trying to figure this out and it was just that simple click at the beginning of your video. Serious gratitude.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2018 2
New Here ,
Apr 15, 2018

Copy link to clipboard

Copied

THANK YOU DAVEYS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2018 0
New Here ,
May 12, 2018

Copy link to clipboard

Copied

YOu are the best!!!!!! thank you!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2018 0
Community Beginner ,
Dec 09, 2018

Copy link to clipboard

Copied

OH MY GOOD LORD YOU SAVED ME YOU VIDEO GOD

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2018 0
New Here ,
Jan 18, 2019

Copy link to clipboard

Copied

Bless you, sir. This worked perfectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2019 0
Community Beginner ,
Jul 01, 2019

Copy link to clipboard

Copied

This Works!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2019 0
Community Beginner ,
Jan 09, 2020

Copy link to clipboard

Copied

WOW - I never thought UI of software in CC 2020 could be such "un-friendly" - Looks like a MEGA MEGA UX bug (Why someone wants to import mp4 (video) audio only) - and if so what about some alert/clue/popup? hh and the solution is so weird.

 

Thanks for the solution but this is a certificate of poverty for Adobe Premier. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2020 0
New Here ,
Jan 11, 2021

Copy link to clipboard

Copied

If I could find you and kiss you I would. I'm not a new user to PP but I just immediately thought it was a much bigger issue and dived straight in a frenzy for and lost a day of editing than actually looking at what's in front of my face! Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2021 0
Engaged ,
Sep 30, 2017

Copy link to clipboard

Copied

I've just started having the exact same issue, some (not all) of my MP4 video/audio files will only import the Audio??? 

I can select to two MP4 files created from the same source and one will import just fine, the other imports as audio only.  Both files are valid video/audio files and both files will play thru Microsoft's Win 10 video player so I know the files are not the problem and this appears to be specific with Adobe.

Can someone point me to a link where I can submit an official support ticket.   This issue only started happening today 2017.1.2, v11 Oasis.  11.1.2 (22) Build.

Cheers, Rob.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2017 1
Community Beginner ,
Oct 07, 2017

Copy link to clipboard

Copied

Hey Rob, did you see the link to the video I created on this issue? It most likely comes down to a import issue.  There is a very specific way I have found to import to get all content types working every time How to properly import audio and video to Premiere Pro - YouTube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2017 0
Community Beginner ,
Oct 31, 2017

Copy link to clipboard

Copied

I just started having the same issue and the fix you posted does not work.  It doesn't matter if I import from the media browser or drag and drop the file to the project.  I can see the video in Windows but it is not imported into my project.  I have 3 other files made at the same time that are fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2017 1
Engaged ,
Oct 31, 2017

Copy link to clipboard

Copied

Same with me.  This issue has No resolution.  In fact I know it’s an Adobe import problem because when I do the import it will actually crash PP 2017.  Adobe should always be error trapping to catch and handle import problems.  The fact an impor can crash PP is clear indication of a Bug in CC.

In addition, the MP4 video file that has a problem with PP does work just fine in my other editing suites, even Final cut Pro.

Unfortunately Adobe have not acknowledged the problem so I’ve had to move onto other editing suites to get my work done. 

These issue sue started recently with PP new update but without any official response from Adobe my only option is to cancel my subscription.

Cheers, Rob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2017 0
New Here ,
Jun 04, 2018

Copy link to clipboard

Copied

make a copy of the videos and paster them in the same folder and only use the file thats now renamed to Copy(and whatever the name is) or just rename all the videos. then those copies will work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2018 0
Explorer ,
Nov 14, 2017

Copy link to clipboard

Copied

I have this problem too. The MP4 videos I've worked with before import ok still, but the latest one doesn't. Has anyone had a response from Adobe? I'm wondering if this is me or a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2017 1