New computer not utilizing full CPU/GPU potential

New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Hi all, 

 

Hoping someone can help me with this. 

 

I just bought a new Intel i9 10900k with 64gb ram and an nvidia rtx 3090

 

Although the system is working well and a definite upgrade over my i7/1080 combo i previously used Im feeling like Premiere's not taking full advantage of my new hardware. For one thing rendering H.264 and MXF files only taxes about 15-20% of the system load. Sometimes less. 

 

Additionally I've turned on Hardware acceleration in the Media Preferences pane and it shows nvidia hardware as checked. I checked the BIOS and I do not have the integrated gpu enabled. But I still get the following error message when I try to enable hardware encoding on my H.264 renders:

"Your system's hardware does not support hardware acceleration for the current settings"

 

As you can imagine having a powerhouse processor and gpu but getting render times equivalent to my last five year old PC is very frustrating. Ideally the computer would utilize more of the CPU and GPU during render processes. Any advice is appreciated!

 

Some images of settings below:

 

 

 

TOPICS
Error or problem, Hardware or GPU, Performance

Views

357

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Enthusiast , Mar 16, 2021 Mar 16, 2021
If you enabled iGPU, you have to update Intel driver too: https://downloadcenter.intel.com/product/80939/GraphicsAlso remember, 2-pass VBR can't be combined with HW-accelerated H264/HEVC encoding, use 1-pass VBR instead.

Likes

translate

Translate

Translate
Most Valuable Participant ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Do not count on Windows to be fully up to date when it comes to device drivers
Go to the vendor site to be sure you have an updated driver for your graphic adapter
•nVidia Driver Downloads http://www.nvidia.com/Download/index.aspx?lang=en-us
••for Premiere Pro and MAYBE Premiere Elements use the STUDIO driver, not the GAMING driver
•••such as https://www.nvidia.com/en-us/drivers/results/170344/ (this MAY not be the latest)


There are also intermittent reports that the newest driver is not always the best driver due to driver bugs or compatibility issues, so you MAY need to try an earlier driver version

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I JUUUUST reinstalled the new driver (studio driver) and no change. 

Additionally I tried enabling the IPG in the BIOS to see if that made a difference since I read that intel quick sync was needed. But still no change. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

 

GPU Accelerated Rendering & Hardware Encoding 
https://helpx.adobe.com/x-productkb/multi/gpu-acceleration-and-hardware-encoding.html

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Thanks for this. I've looked at it. Is that page up to date? The third image from the top shows a Renderer pull  down menu in the General Preferences tab that does not appear in my up to date Premiere Pro. See attached image for difference

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

go Project Setting ... > General >

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Yep. Done and done. Been set correctly. I was only pointing out that the adobe help page is out of date.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Which piece of info is out of date? Help me so I can provide feedback for the docs team.

 

Thanks,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

The third image from the top shows a Renderer pull  down menu in the General Preferences tab that does not appear in my up to date Premiere Pro. See attached image for difference

No Renderer option.PNG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

The third image form the top is the Project Settings window, not the Preferences window.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

If you enabled iGPU, you have to update Intel driver too: https://downloadcenter.intel.com/product/80939/Graphics

Also remember, 2-pass VBR can't be combined with HW-accelerated H264/HEVC encoding, use 1-pass VBR instead.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Ok this definitely increased my render time. Still not getting very high CPU usage. My old computer would go max load on a render. Does premiere utilize the CPU optimally?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Ok this definitely increased my render time. -  what 'this', exactly?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Sorry, updated the intel graphics driver after enabling the integrated gpu in the bios allow me to finally select hardware encoding for all H.264 profiles except High10. This resulted in a pretty dramatic rendering speed increase. Went from 5-6 minutes render on a TRT 5 minute timeline to 1.5-2 minutes.

Still the CPU usage only hovers at 20%. I wonder if the intel gpu (which goes to a bout 50-60% usage according to task manager performance pane) just circumvents the CPU usage? I just wonder what the render speeds would be like if the CPU got fully involved.  my rtx 3090 hovers at 15% while rendering.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Try to turn off Hardware accelerated Decoding in Preferences > Media... Remember to clear media cache and restart the app each time you change this settings.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I would leave it enabled so you can use the iGPU for hardware decoding. I believe it has better performance than the discrete GPU doing the decoding. What's your experience, basil?

 

Thanks,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

@Kevin-Monahan  With such powerful CPU as modern i9 and alike, the iGPU will be a bottleneck if used for both Decoding and Encoding. So it make sense to hand Decoding task to CPU, while leave encoding to iGPU

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Interesting. Thanks for the feedback and observation. I will take this info back to the engineers.

Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Omar,

Thanks for writing in and sorry for the frustration. It sounds as if you have your hardware working correctly now. You are not seeing CPU and GPU processes maxed out because, as the engineers say, your computer is using only the power that is needed. Keep in mind that your system might be able handle more than Premiere Pro can dish out. You definitely need to have both the iGPU and discrete GPU working with the latest drivers in order to take advantage of your very powerful and well balanced hardware setup. The iGPU is more powerful with hardware decoding over your NVIDIA GPU, as I understand it. I would leave it enabled. Glad you have that going and are no longer getting the warning you got in your OP. 

Regards,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

@omarc26568164Here is one more possibility why you have issues with rtx3090 in Premiere. Check if your display is actually connected to the 3090, you may unknowingly connected it to iGPU port. If so Premiere will consider 3090 as secondary and some functions may be unavailable

 

Ports layout - iGPU vs dGPU.jpg 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines