None functioning editing menus

New Here ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Since this update, the program is not even useable, it's super laggy and unresponsive, the menus aren't working and when they do, sliders don't actually show they've moved. Before the update the program was running flawlessly. I've tried uninstalling the program, shutting down the PC, re-installing and clearing out old files just as a precaution but this is the absolute worst this program has ever performed. I've had to ask clients to wait for their products because the program doesn't work and looks bad on me, can anyone help??

TOPICS
Audio, Editing, Freeze or hang, Performance, User interface or workspaces

Views

55

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Hello shaun,

 

I wonder if clearing your preferences and trashing your media cache would help. 

 

Preferences: FAQ: How to reset (trash) preferences in Premiere Pro?

Media Cache: FAQ: How to clean (delete or trash) media cache files?

 

Let me know if this works!

 

Can you please provide us with your pc and system specs 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

The problem still remains after doing both clearing the preferences and trashing the media cache.

The menus really struggle to work and not responsive.

 

Dell Inspirion 5680

Intel (R) Core i7-8700 CPU @ 3.20 GHz

16GB Ram

64-bit OS, x64 -based processor

NVIDIA GeForce GTX 1070

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Sames issues here. I can't work like this. I may roll back to 15.0.

 

Custom-built PC

Processor Intel(R) Core(TM) i7-6900K CPU @ 3.20GHz 3.20 GHz
Installed RAM 64.0 GB
Edition Windows 10 Pro
Version 20H2
Experience Windows Feature Experience Pack 120.2212.551.0

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

P.S.

 

NVIDIA GTX 1080 in my rig

 

I rolled-back to Premiere 15.0 and all is well. Looks like I'll be waiting for 15.2 or later to update again.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines