Not able to Enable Mercury Playback Engine (OpenCL) with 5600XT

Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

I just upgraded my GPU from an AMD R9 Fury to an AMD RX 5600XT and I can't seem to enable Mercury Playback Engine (OpenCL) on my system now. The dropdown is just grayed out. I can't seem to find a solution online either.

 

I reinstalled drivers for my gpu. Reinstalled Premeire Pro, and installed the lastest version of Premeire pro, and nothing has worked.

 

Also if it's pertinant, In my registry editor I don't even seen OpenCL under Khronos, just Vulkan.

 

Livid right now as I can only render with software and it takes HOURS instead of minutes.

TOPICS
Hardware or GPU

Views

358

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Jun 18, 2020
Carlos Ziade Adobe Community Professional , Jun 18, 2020
did you try to update your operating system?

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

try to get the latest driver for your GPU from AMD website

and I think you will have to add Premiere Pro to the gaming settings of your AMD

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Radeon software says I'm on the latest driver.

 

Adding the apps to the Radeon game software doesn't seem to fix it either. Tried multiple times and even tried going back to an older version of PPro. 😕

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

did you try to update your operating system?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 19, 2020

Copy link to clipboard

Copied

This worked for me! Something on Windows must have not installed properly. I did a total system reinstall and started fresh, but OpenCL is working for me now. Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 19, 2020

Copy link to clipboard

Copied

GREAT !!!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 16, 2020

Copy link to clipboard

Copied

Hi, 

please can you help me? 

When I install newer graphic driver on ma HP Zbook G15, I can work with Mercury Playback Engine GPU Acceleration on Adobe Premiere 2020, but when I turn the laptop off and on again, the settings disappear and I can't select. 
I will reinstall the graphics drivers, i can select the add-on again, but Every time I turn off the laptop, the add-on disappears and I have to reinstall the drivers again and again-

 

I've tried through youtube tutorials, nothing helps

 

Thank you for your help

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 16, 2020

Copy link to clipboard

Copied

i have AMD Radeon Pro WX 3100, Win 10, last version

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 26, 2020

Copy link to clipboard

Copied

try to download gfx card status

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more